Welcome, Guest. Please login or register.

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - SchmuFoo

Pages: [1] 2 3 ... 5
1
Discovery / PWR: Total used power is 0W
« on: June 06, 2019, 04:56:22 PM »
Hello,

just updated to NeDi 1.9 and saw the following new output during Re-Discovery:

[..]
TYPE:X460G2-48t-10G4 (using 1.3.6.1.2.1.47.1.1.1.1.2.3)
LOAD:System load is 1%
MEM :Available memory 652 KBytes
TEMP:Temperature is 58 Degrees Celcius
PWR :Max PSE power is 0W
PWR :Total used power is 0W

[..]

But I don't see any Power Values on the Device-Status and in the Defintion file  ::)

BTW the OID should be:

extremeSystemPowerUsageValue
.1.3.6.1.4.1.1916.1.1.1.40.1

Source: https://gtacknowledge.extremenetworks.com/articles/How_To/What-is-the-SNMP-OID-to-retrieve-System-Power-Usage

Cheers

2
Discovery / Re: DNS update for existing nodes
« on: March 21, 2019, 11:33:34 AM »
i'm new to NeDi. The installation seem to work. Now I'm testing various functions of NeDi. Here I noticed that the database structure has changed. I didn't found the field ipupdate in nodes, but it exists in iptracks and nodarp. Which field must i set to zero, if i want to use this maintenance function?

System-Database.php -> Execute: Reset Address Update -> "UPDATE nodarp set ipupdate=0"

I tried that now several times but it didn't had any affect.

Still have multiple Nodes which have old DNS Names listed under Nodes-Status.php

When I do an dig/host on the NeDi Linux System, I got "NXDOMAIN" for that specific entries. So I dont know why NeDi is still mapping those old entrys  :-\

Even when I use the Nodes-Status.php?dip Feature to delete them, after Rediscovery of the Layer-3 Device, the old (in DNS not existing anymore) Entrys are coming back.

Any Ideas?

3
Discovery / Re: Discovery of IP addresses of connected Nodes
« on: March 11, 2019, 10:45:17 AM »
As long as you also have an Layer-3 Devices where NeDi can extract the ARP Cache, you should see the Nodes on the Layer-2 Device automaticly.

4
Discovery / Re: DNS update for existing nodes
« on: March 08, 2019, 12:18:12 PM »
i'm new to NeDi. The installation seem to work. Now I'm testing various functions of NeDi. Here I noticed that the database structure has changed. I didn't found the field ipupdate in nodes, but it exists in iptracks and nodarp. Which field must i set to zero, if i want to use this maintenance function?

System-Database.php -> Execute: Reset Address Update -> "UPDATE nodarp set ipupdate=0"

5
Discovery / Re: DNS update for existing nodes
« on: March 08, 2019, 11:19:10 AM »
[..]
EDIT:
maybe it be a good idea to have a button in the Node-Status.php to reset the DNS
So that a single host can be resolved again

Aggree  8)

6
Discovery / Re: Discovery of IP addresses of connected Nodes
« on: March 07, 2019, 11:28:07 AM »
Example Def File Settings for an Cisco WS-C2960CG-8TC-L working as Layer-3 Switch

Oh:

Code: [Select]
ArpND (SNMP) ---------------------------------------------------------------- Thu Mar 7 11:24:11 2019
SNMP:Connect X.X.X.X X v2 Tout:2s MaxMS:1472 Retry:1 NB:0
ERR :ipNetToPhysical The requested table is empty or does not exist

But VS. "Blue Man" Button Result from that same device:

Code: [Select]
ipNetToMediaPhysAddress.X.X.X.X.X: 78:e3:X:X:X:X
[..]

7
Discovery / Re: Discovery of IP addresses of connected Nodes
« on: March 07, 2019, 11:15:43 AM »
Example Def File Settings for an Cisco WS-C2960CG-8TC-L working as Layer-3 Switch

8
Discovery / Re: Discovery of IP addresses of connected Nodes
« on: March 07, 2019, 11:00:45 AM »
When this is a Layer-3 Switch (Mode) it should work out of the box. Maybe you can post your .def file.

9
Discovery / Events: LLDW link changed type from LLDD to LLDW
« on: February 26, 2019, 01:31:48 PM »
I have various "HP VC Flex-10/10D Module" as Devices and during every Discovery-Cycle I see messages like:

d4v1 is LLDW link changed type from LLDD to LLDW
d2v1 is LLDD link changed type from LLDW to LLDD


What does this mean? I know LLDP but what is LLDD and LLDW?

10
Discovery / Re: Exclude Nodes from LAG Interfaces?
« on: February 26, 2019, 11:19:59 AM »
Common problem, if neighbors are not detected on an interface. You can set linktype='NOP' on those LAG interfaces (e.g. with System-Database). In NeDi 1.9 it can be set comfortably with Devices-Interfaces...

Can I also explicity INCLUDE Nodes WHEN an neighbor is deteced?

Reason: I have thousands of FTTO 5 Port Switches (From Nexans, Microsens and also Dafur/CBL) but I don't want to add them also in NeDi. I only want to have all their Upstream Switches in NeDi with the ability to use the Node-Tracking / Population feature also for Nodes connected directly to the FTTO Switches.

11
GUI / Display (f.e.) Number of Devices on Top and not Bottom of Table
« on: February 05, 2019, 03:32:18 PM »
At the moment when displaying f.e. all devices, you have to scroll down the whole list to get the info a la "82 Devices, Sort: device, Limit: 250 ".

I would like to see that info (additionally) in the top section of the table, so you don't have to scroll.


Cheers


12
GUI / Re: Monitoring VLAN Traffic for VTAP Interface with SMON?
« on: February 05, 2019, 03:24:36 PM »
One step closer: smonVlanIdStatsTotalOctets:

http://cric.grenoble.cnrs.fr/Administrateurs/Outils/MIBS/?oid=1.3.6.1.2.1.16.22.1.2.2.1.7

Based on an SNMPwalk of that, my specific VLAN Index-Mapping is:

The instance for VLAN 99 is .1.99
The instance for VLAN 999 is .2.999

So for my queries:

Code: [Select]
nedi01-bn:~ # snmpget -v2c -c .. IP 1.3.6.1.2.1.16.22.1.2.2.1.7.1.99
RMON-MIB::rmon.22.1.2.2.1.7.1.99 = Counter64: 147497497837163

nedi01-bn:~ # snmpget -v2c -c .. IP 1.3.6.1.2.1.16.22.1.2.2.1.7.2.999
RMON-MIB::rmon.22.1.2.2.1.7.2.999 = Counter64: 125397217538


Now the only question is, can I map those OID values to the Graph under https://nedi.foobar.tld/Devices-Graph.php?dv=DEVICENAME&if[]=vtap.0.999&it[]=t and rt-popup? The will be needed some calculation to compare the delta between two values (Bytes) and optional to rewrite it to bps instead of Bps..

13
GUI / Monitoring VLAN Traffic for VTAP Interface with SMON?
« on: January 10, 2019, 01:23:39 PM »
Hello,

I have configured a few VTAP Interfaces for SMON Monitoring on an Enterasys Switch.

According to..

http://cric.grenoble.cnrs.fr/Administrateurs/Outils/MIBS/?module=SMON-MIB&fournisseur=ietf

I should use..

http://cric.grenoble.cnrs.fr/Administrateurs/Outils/MIBS/?oid=1.3.6.1.2.1.16.22.1.2.2.1.5

.. for this.

Does NeDi Support this?


NeDi Discovery sees the Interface during discovery as:

Code: [Select]
IF :100099 vtap.0.999 0 - 3 0 IEEE 802.1Q VLA 0
On the Device-Status.php it shows up as Interface with Name: "IEEE 802.1Q VLAN 999 Tap Interface"

But when I open up the rt-popup.php, I can't see the Traffic -> "Cannot get data about interface 1000999"

Code: [Select]
Switch(su)->show smon vlan

Data Source      : vtap.0.999
Status           : Enabled
Last Enable Time : 2019-01-10 11:46:54
Owner            : (none)
--------------------------------------

Vlan    NonUnicast Packets     NonUnicast Octets         Total Packets          Total Octets
----  --------------------  --------------------  --------------------  --------------------
999                    460                 41572                 60803              10695850


Cheers,
Jan

P.S.: I'm also not able to do a normal snmpget for ifInOctets for that interface (Altough I'm not sure why NeDi Discovery says 100099 but rt-popup is mentioning 1000999)

Code: [Select]
X:/usr/share/snmp/mibs # snmpget -v2c -c X 10.23.10.252 ifInOctets.1000999
IF-MIB::ifInOctets.1000999 = No Such Instance currently exists at this OID

X:/usr/share/snmp/mibs # snmpget -v2c -c X 10.23.10.252 ifInOctets.100099
IF-MIB::ifInOctets.100099 = No Such Instance currently exists at this OID

14
Discovery / Re: Exclude Nodes from LAG Interfaces?
« on: January 09, 2019, 02:08:10 PM »
Does the lastseen timestamp still get updated on those nodes? When you add debugging (-db), you should see lines like this:

DBG :$mc on $if vl$vl ignored due to NOP

Oh you have right, I didn't realize that the timestamp was not updated any longer. In the meantime the wrong mapping is gone on my test-switch (I think after round about 30 days).

Is there a manuall way to "re-map" old entrys, without deleting the Nodes? I would like to keep the Node Details and History, but want to get rid of the old wrong mappings.

15
Discovery / Re: Exclude Nodes from LAG Interfaces?
« on: November 28, 2018, 03:05:46 PM »
Thanks, but it seems it doesnt work for me -> Nodes are still there -> See Screenshots from System-Database.php

@kami and @all: Any idea what I else can do? (See Post before)

Thanks,
Jan

Pages: [1] 2 3 ... 5