Welcome, Guest. Please login or register.

Author Topic: Net::Nslookup not available  (Read 467 times)


  • Newbie
  • *
  • Posts: 15
    • View Profile
Net::Nslookup not available
« on: January 28, 2020, 11:10:32 AM »
I have been using NeDi for along time and recently noticed that every time I kick off NeDi.pl, the first line says that Net::Nslookup is not available when I run the script as NeDi user.

DNS :Net::Nslookup not available
CLI :IO-Pty loaded
WEB :LWP-UserAgent loaded

when I run it as root, the module looks to be available to NeDi script:
DNS :Net::Nslookup loaded
CLI :IO-Pty loaded
WEB :LWP-UserAgent loaded

The Net::Nslookup module is correctly installed on the server and I tested it with a basic script.
Is there any way to fix it or to debug?

« Last Edit: January 28, 2020, 11:50:39 AM by ghermant »


  • Administrator
  • Hero Member
  • *****
  • Posts: 2780
    • View Profile
    • NeDi
Re: Net::Nslookup not available
« Reply #1 on: February 05, 2020, 09:08:57 AM »
I don't know, what causes this. However Net::Nslookup is only required for selecting different DNS servers. This can be done with mapns in nedi.conf
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!