Welcome, Guest. Please login or register.

Author Topic: Issue updating from 1.7 to 1.8  (Read 1071 times)

jocke92c

  • Newbie
  • *
  • Posts: 21
    • View Profile
Issue updating from 1.7 to 1.8
« on: October 31, 2019, 05:02:29 PM »
Hi
I did download the 1.7c file to update from nedi 1.6 something to nedi 1.8c. The 1.7c updated succeeded but now when I'm running to 1.8c update is says "Please do an updatedb with 1.7.090p1 first". But I can't find that update on the website. And since my files is 1.7c now I don't know how to proceed.

pc_sg

  • Guest
Re: Issue updating from 1.7 to 1.8
« Reply #1 on: November 04, 2019, 03:36:29 PM »
First update NeDi to 1.7c, then apply the same procedure as noted in the 1.8c update page (menu "System", "NeDi", choose "reset" that is the rightmost option, and be sure that the string in first field is "updatedb", hit "Execute" and verify the reported output.
The do the 1.8 update and then the database update should be successful.

marco.mereu

  • Newbie
  • *
  • Posts: 16
    • View Profile
Re: Issue updating from 1.7 to 1.8
« Reply #2 on: November 05, 2019, 12:53:57 PM »
After update
 (menu "System", "NeDi", choose "reset" that is the rightmost option, and be sure that the string in first field is "updatedb", hit "Execute" and verify the reported output.


DB version 1.8.100 is not supported, sorry! HELP!!!

pc_sg

  • Guest
Re: Issue updating from 1.7 to 1.8
« Reply #3 on: November 05, 2019, 01:06:46 PM »
My server(s) are all Debian, daily updated.
No
I don't know if is there any requirements/restriction to update to 1.8c.

I hope somebody more skilled then me will be able to help you.


jocke92c

  • Newbie
  • *
  • Posts: 21
    • View Profile
Re: Issue updating from 1.7 to 1.8
« Reply #4 on: November 15, 2019, 11:17:51 PM »
First update NeDi to 1.7c, then apply the same procedure as noted in the 1.8c update page (menu "System", "NeDi", choose "reset" that is the rightmost option, and be sure that the string in first field is "updatedb", hit "Execute" and verify the reported output.
The do the 1.8 update and then the database update should be successful.
Do you mean that I should be able to upload the 1.7c patch and downgrade all the files and then run the updatedb command? (And then run the 1.8 update and the updatedb command for 1.8?)

pc_sg

  • Guest
Re: Issue updating from 1.7 to 1.8
« Reply #5 on: November 18, 2019, 04:05:41 PM »
Yes, this is what I did.

rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2765
    • View Profile
    • NeDi
Re: Issue updating from 1.7 to 1.8
« Reply #6 on: December 03, 2019, 10:10:17 AM »
Yes, that works indeed. That 1.7p1 thing was confusing and won't happen again. In addition I'll make it smarter for future releases (avoiding too many incremental updates)...
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo

ghermant

  • Newbie
  • *
  • Posts: 15
    • View Profile
Re: Issue updating from 1.7 to 1.8
« Reply #7 on: June 08, 2020, 04:41:16 PM »
Hi, if this can help (I faced the same kind of issue as I forgot to run the updatedb stuff after upgrading...) here is a small procedure I tested on production environments to update the DB schema and structure to your current NeDi files and scripts version.

1/ Identify the current version of NeDi DB
Go to System/Database, find the System table and click on Show icon (eye icon) and take a note of the current NeDi DB structure version.

All the trick is done by replacing your current /nedi/inc/libdb.pm with an older version so that this older version will do the required database upgrade for you without touching the other NeDi files.

I have attached to the post the original libdb.pm files for NeDi version 1.7 and 1.8.
If you prefer to extract them on your own, you have to download the NeDi install files for both 1.7C and 1.8C from www.nedi.ch, extract them and get the libdb.pm in the /inc directory.

2/ Please make a backup of your current libdb.pm file:
# cp -p libdb.pm libdb.pm.bak

3/ Stop all NeDi active background processes.

4/ If your current version of NeDi (files and scripts) is 1.8:
If the version shown in the NeDi DB is 1.6xx or 1.7
--> copy libdb.pm.1.7 to /nedi/inc/
Replace the current libdb.pm with the libdb.pm.1.7 file:
# cp libdb.pm.1.7 libdb.pm

Go to the NeDi web interface in System/NeDi and select "reset" after making sure that the login field contains "updatedb" and then execute.
The DB should update correctly to the 1.7.100 version

Then, copy libdb.pm.1.8 to /nedi/inc/
Replace the current libdb.pm with the libdb.pm.1.8 file:
# cp libdb.pm.1.8 libdb.pm

Go to the NeDi web interface in System/NeDi and select "reset" after making sure that the login field contains "updatedb" and then execute.
The DB should update correctly to the 1.8.100 version.

Do not forget at the end to recover your original libdb.pm file:
# cp libdb.pm.bak libdb.pm

Hope this will help you and will avoid you to go through all files upgrade process that is very impacting if you made any customisation to your def files...

rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2765
    • View Profile
    • NeDi
Re: Issue updating from 1.7 to 1.8
« Reply #8 on: June 18, 2020, 02:05:25 PM »
Thanks for sharing!

BTW, I've simplified 2.0 in that you can update straight from 1.8 and 1.9...
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo