Welcome, Guest. Please login or register.

Author Topic: Ldap authentication  (Read 2270 times)

otbl

  • Guest
Ldap authentication
« on: May 24, 2013, 06:30:27 PM »
When trying to add a ldap user noting appends unde the accounts tab. Th e user is not created.

tuxfrog

  • Guest
Re: Ldap authentication
« Reply #1 on: June 06, 2013, 10:47:25 AM »
You have to configure your LDAP Server in nedi.conf like that:

#ldapsrv        ldaps://host.domain             636     PASSWORD        DC=XX,DC=YYY            USER                                            uid
ldapsrv        ldap://your.server.net          389     bindpassword     OU=People,,DC=domain,DC=dom     your binddn like (cn=ldapadm,ou=services,dc=domain,dc=dom=    uid

After that you can see a new Button at the Account Config Site near the "Add" Button. It named lile "Add LDAP User" in German: "aus ldap hinzufügen"
Now you type in a valid Ldap Username and click the add "ldap user button".

That's it.

dobst

  • Full Member
  • ***
  • Posts: 153
    • View Profile
Re: Ldap authentication
« Reply #2 on: June 17, 2013, 01:25:25 PM »
If I try to add a user via LDAP I get these error messages:

Warning: fwrite(): supplied argument is not a valid stream resource in /srv/www/htdocs/nedi108/inc/libldap.php on line 119
Warning: fwrite(): supplied argument is not a valid stream resource in /srv/www/htdocs/nedi108/inc/libldap.php on line 119
Warning: fwrite(): supplied argument is not a valid stream resource in /srv/www/htdocs/nedi108/inc/libldap.php on line 119
Warning: fwrite(): supplied argument is not a valid stream resource in /srv/www/htdocs/nedi108/inc/libldap.php on line 119
Warning: array_map(): Argument #2 should be an array in /srv/www/htdocs/nedi108/inc/libdb-msq.php on line 106

Benutzer [user account name]: OK

and an empty db entry:
"user"   "password"   "groups"   "email"   "phone"   "time"   "lastlogin"   "comment"   "language"   "theme"   "volume"   "columns"   "msglimit"   "miscopts"   "dateformat"   "viewdev"
""   ""   "0"   ""   ""   "1371467953"   ""   ""   "english"   "default"   "40"   "6"   "5"   "2"   "j.M y G:i470"   ""

LDAP is configured right. If I enter a non existing username, I get an error message. That works as expected.

tuxfrog

  • Guest
Re: Ldap authentication
« Reply #3 on: June 18, 2013, 11:50:50 AM »
For me i do not use the ldap map entry.