Welcome, Guest. Please login or register.

Author Topic: error after upgrade - "Can't locate RRDs.pm...."  (Read 3498 times)

quartz

  • Guest
error after upgrade - "Can't locate RRDs.pm...."
« on: May 18, 2011, 09:24:42 AM »
hi folks,

had the nedi run for nearly 2 years now without any problems.
Wanted to upgrade to the latest version these days and followed the instuctions mentioned on the nedi installation page.

I renamed my old nedi directory to old_nedi. I downloaded the "nedi-115.tgz RC2" and extracted it to my original /var/nedi directory. I compared the nedi.cof and made the necessary changes.

When trying to run moni.pl I get the following error messages:

C:\var\NeDi>c:\var\nedi\moni.pl
Can't locate RRDs.pm in @INC (@INC contains: C:/Perl/site/lib C:/Perl/lib .) at ./inc/libmisc.pm line 17.
BEGIN failed--compilation aborted at ./inc/libmisc.pm line 17.
Compilation failed in require at c:\var\nedi\moni.pl line 53.
BEGIN failed--compilation aborted at c:\var\nedi\moni.pl line 58.


My installation runs under Win2003/IIS.


I am an absoult scripting noop and do not understand what the problem could be. Any suggestions?

rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2780
    • View Profile
    • NeDi
Re: error after upgrade - "Can't locate RRDs.pm...."
« Reply #1 on: May 19, 2011, 11:26:22 PM »
I know documentation is behind...

You need to install lib-rrd for perl. I don't know whether this is available on Windows, but lib-io-tty is not, which is required for CLI access now.
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo