Welcome, Guest. Please login or register.

Author Topic: install cacti on nedio 1.5  (Read 3728 times)

equipereseau

  • Guest
install cacti on nedio 1.5
« on: April 29, 2011, 08:03:37 PM »
is there a tutorial on how to install cacti on nedio 1.5

i already have a cacti server running in  the network but would like to kill it and put cacti with nedi soo it would be more user friendly to create graph and weathermap.

thank you

rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2780
    • View Profile
    • NeDi
Re: install cacti on nedio 1.5
« Reply #1 on: April 30, 2011, 01:22:43 AM »
Nope, I thought about how nice it could be though  ;)

Shouldn't be too hard, but I haven't tried it actually...
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo

equipereseau

  • Guest
Re: install cacti on nedio 1.5
« Reply #2 on: May 03, 2011, 03:41:37 PM »
ok tried to install it and run into a little problem,

what is the root password for mysql i can logon on mysql with admin and no password but im unable to create table.....

equipereseau

  • Guest
Re: install cacti on nedio 1.5
« Reply #3 on: May 03, 2011, 05:57:55 PM »
found the mysql password it is "dbpa55"


was able to successfully install cacti, i'm able to add graph in cacti but im unable to see the graph in cacti heres a printscreen of a graph of a switch I added trought the nedi interface:



or the link to the image:
http://img847.imageshack.us/i/graphd.jpg/

heres the nedi.conf for cacti:

# Prefix to call Cacti CLI tools for adding graphs in Topology-Graph
cacticli   /usr/local/bin/php /var/www/cacti-0.8.7g/cli

# Cacti integration. Uncomment, if you want Devices-Status to link to Cacti.
# You will need to have the NeDi device names as host (or description) in cacti,
# with that a link can be established.
cactihost   localhost
cactidb   cacti
cactiuser   cactiuser
cactipass   ****
cactiurl   /cacti



thank you for your help

equipereseau

  • Guest
Re: install cacti on nedio 1.5
« Reply #4 on: May 03, 2011, 06:19:40 PM »
i turned on the debug and here's what i get:

ERROR: opening '/var/www/cacti-0.8.7g/rra/csp02_01_traffic_in_9.rrd': No such file or directory

and i dont have any file in /var/www/cacti-0.8.7g/rra

should cacti rrd file path point elsewhere?

thank you