Welcome, Guest. Please login or register.

Author Topic: Nedi 1.06 Beta2 (023) Backup Config Problem  (Read 2172 times)

gantert

  • Guest
Nedi 1.06 Beta2 (023) Backup Config Problem
« on: March 14, 2011, 04:05:23 PM »
Hi @All

I installed last week the lastest version of Nedi Beta2. The new Nedi does not backup all my Cat650X.

I have around 10 650X chassis with the same IOS and to 90% the same config. You will see, the login is successful. All other Cisco devices (3560/2960/...) works fine. Any idear?

IOS: s72033-advipservicesk9_wan-mz.122-33.SXI1.bin

********* Debug output "-d -v" ************
.Config (CLI)   ----------------------------------------------------------------
TEL :nd:23 Tout:2s OS:IOS EN:(.+?)#\s?$
CLI2:Matched Password:, sending password
CLI :Password sent
CLI :Matched nd70u201>, enabling
CLI6:Matched Password:, sending password
CLI9:Matched enable prompt, OK
CMD :terminal length 0:
CMD :show run

Use of uninitialized value in concatenation (.) or string at ./inc/libcli-iopty.pm line 603.
ERR :No config ()
 

tristanbob

  • Full Member
  • ***
  • Posts: 159
    • View Profile
Re: Nedi 1.06 Beta2 (023) Backup Config Problem
« Reply #1 on: April 07, 2011, 10:14:24 PM »
Thanks for reporting this issue.

I am not a programmer, but it sounds like it should be easy to trackdown that line of code and see why the variable is undefined.

Tristan
Please visit "Other"->"Invoices" on your NeDi installation to make an annual contribution and support Nedi!

rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2785
    • View Profile
    • NeDi
Re: Nedi 1.06 Beta2 (023) Backup Config Problem
« Reply #2 on: April 08, 2011, 06:24:01 PM »
I've added RC1 to the downloads today. Try it, as it should at least be more informative, if the problem persists. You could also try to increase the timeout, as it seems to enable just fine...
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo

tristanbob

  • Full Member
  • ***
  • Posts: 159
    • View Profile
Re: Nedi 1.06 Beta2 (023) Backup Config Problem
« Reply #3 on: April 11, 2011, 08:12:40 PM »
The timeout setting is in "nedi.conf".  You might try increasing that to 20 seconds?

# Timeout for SNMP and telnet communication. Extra time will be added
# for certain tasks (e.g. building the config).
timeout         2

Tristan
Please visit "Other"->"Invoices" on your NeDi installation to make an annual contribution and support Nedi!