Welcome, Guest. Please login or register.

Author Topic: Nedi scan not exiting  (Read 3651 times)

sjwk

  • Newbie
  • *
  • Posts: 37
    • View Profile
Nedi scan not exiting
« on: December 06, 2010, 07:54:48 PM »
Hi all,
Having some issues with Nedi in the last few weeks.  It's been running fine for many months but has recently started hanging at the end of the scan (which runs /var/nedi/nedi.pl -pob every 10 minutes from cron).  This means the server slowly runs out of RAM and (within 24 hours) locks up.

Running 1.0.5 on Ubuntu 8.04 server.  Nothing has changed recently on the server other than server updates to the best of my knowledge.

Looking at lastrun:

Quote
OUI:    15969 NIC vendor entries read
DEV:    23 devices read from nedi.devices
LINK:   0 links (WHERE type = "STAT") read from nedi.links

DP-OUI-Discovery (1.0.5) with 1 seed on Mon Dec  6 18:40:01 2010
<snip>
Took 1 minutes

Devs:   21 devices discovered
619 arpwatch entries used.

Not a significant number of devices - all Cisco, appears to complete fine but then nothing.  Have tried running the nedi command from the shell - same thing, it just does nothing after the arpwatch line.

The discrepancy between 23 and 21 devices is down to one switch being powered off, and one that Nedi has a duplicate of after a config change.  Otherwise it's picking up everything it should be.

Is there any way to diagnose what's causing it to stall?

Steve.

rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2785
    • View Profile
    • NeDi
Re: Nedi scan not exiting
« Reply #1 on: December 11, 2010, 03:11:33 AM »
Have a look at System-Services is the lock closed or open?
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo

BrianM

  • Guest
Re: Nedi scan not exiting
« Reply #2 on: January 04, 2011, 07:43:54 PM »
I started having this exact problem also as of a couple of weeks ago. Mine shows the lock closed.

dumbuser

  • Newbie
  • *
  • Posts: 26
    • View Profile
Re: Nedi scan not exiting
« Reply #3 on: January 04, 2011, 10:27:58 PM »
I've experienced this. The lock indicates nodes table is locked. You can try to reset discover with red X.

To manually reset you can kill all your nedi threads and use phpmyadmin to set value of system nodlock to 0. hope that helps. Curt

BrianM

  • Guest
Re: Nedi scan not exiting
« Reply #4 on: January 04, 2011, 10:40:28 PM »
I was thinking of doing the "reset discover with red X" but was worried it would clear out the existing (older) data. Will that empty the table or no?

dumbuser

  • Newbie
  • *
  • Posts: 26
    • View Profile
Re: Nedi scan not exiting
« Reply #5 on: January 04, 2011, 10:47:48 PM »
No it will not harm existing data. It will try to stop all nedi process and reset the node lock.

BrianM

  • Guest
Re: Nedi scan not exiting
« Reply #6 on: January 04, 2011, 10:56:23 PM »
that worked....thanks