Welcome, Guest. Please login or register.

Author Topic: Can't call method "get_request" on an undefined value at ./inc/libsnmp.pl line 7  (Read 4135 times)

aldotutune

  • Guest
Hi all,

I'm facing an issue with an upgrade from 1.0 to 1.0.5. First one is that for some devices I get this message :

Can't call method "get_request" on an undefined value at ./inc/libsnmp.pl line 7

I get it for a simple Cisco 2811 router.

I run this command ./nedi.pl -dvbIn under /var/nedi, and I get this

...
several seeds added for discovery
...

Discovery (1.0.5) with 56 seeds on Mon May 10 16:36:07 2010
================================================================================
Device                          Status                           Todo/Done-Time
--------------------------------------------------------------------------------
10.10.107.9      C:#####-v#GW X25 1Can't call method "get_request" on an undefined value at ./inc/libsnmp.pl line 77.
nedi-server:/var/nedi#

I've tried to copy the old def file for such routers but it didn't solve my problem.

Do you have any idea why I can't run nedi anymore as this error is blocking the script?

I have another issue to backup some routers located thousands of kms from here but I'll talk about this later.

Thank you for your help!

And thank you for developping such a tool!!

guano

  • Guest
I had the same pb once but I can't remember...
Perhaps your seedlist file is wrong.
- Try with less option (such as ./nedi.pl -d)
- Try with a correct seedlist file

steffen1

  • Guest
there is either a wrong SNMP-community or not existing or wrong .def file for this device that controlles the SNMP-version also an importent parameter to can successful open an SNMP session. The original nedi libs doesnt care about an undefined (unsuccessful) SNMP-handler and the try to query with an undefined SNMP-handler causes the crash at perl level and for the overall scan.

If you use this modified nedi-libs than you will get more failure tolerance
http://forum.nedi.ch/index.php?topic=546.0
by means the overall scan will not be infected by some single device or wrong configuration problems.

Steffen
« Last Edit: May 13, 2010, 12:08:02 PM by steffen1 »

aldotutune

  • Guest
Hi,

Thank you for your reply. I'll try to find some time to test this. I had to rollback to the older version in the meantime.