Welcome, Guest. Please login or register.

Author Topic: NeDi shows only switch port own mac address  (Read 4359 times)

Beyinsizkedi

  • Newbie
  • *
  • Posts: 7
    • View Profile
NeDi shows only switch port own mac address
« on: March 03, 2010, 03:45:20 PM »
Hello

i have been using NeDi not so long.

i used NeDi s earlier version and when i search any mac address Nedi shows the exact switch port.

but now, when i search any mac address Nedi only shows the Backbone switch's uplink port where we connected switch that nodes connected.

And also when i open Nedi Devices > Status > switch and want to see switches status information. under the interfaces section, address column only shows switches own port mac address not nodes mac address. i thing this situation caues the problem.

is there any idea.


Not: i installed the nedis 1.05 version on Ubuntu and i add the lines below to crontab

0,30 * * * *    root    /var/nedi/nedi.pl -o > /tmp/nedi.lastrun 2>&1

i have HP 2524, 4104, 4208, 3508, 9304, Cisco 6509, Enterasys B2, N3 and N7.


dekdek

  • Guest
Re: NeDi shows only switch port own mac address
« Reply #1 on: March 03, 2010, 05:06:01 PM »
hi, try to make static link and add -L option (nedi -L leave links untouch during discovery).
As Remo says : "If the uplink is detected, edge ports will be preferred over uplink ports".
hope it helps
good luck

Beyinsizkedi

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: NeDi shows only switch port own mac address
« Reply #2 on: March 09, 2010, 02:36:21 PM »
-L option doesnt work  ???

tolmstev

  • Guest
Re: NeDi shows only switch port own mac address
« Reply #3 on: May 12, 2010, 09:40:06 PM »
I'm having the same issue, hosts are reported as existing only on uplink ports. Has this issue been resolved?

rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2728
    • View Profile
    • NeDi
Re: NeDi shows only switch port own mac address
« Reply #4 on: May 13, 2010, 05:57:22 PM »
It's intended to show the devs mac & IPs in the interface table. Make sure each dev has an uplink identified. Use Topology Linked, if not. I dropped guessing uplinks as it wasn't relaible enough for me, that's probably why you don't see them anymore...
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo