Welcome, Guest. Please login or register.

Author Topic: Nothing discovered, nothing written...  (Read 2801 times)

seshadribpl

  • Guest
Nothing discovered, nothing written...
« on: November 15, 2009, 03:56:48 AM »
Hi all,

I finally got my login - thanks a lot, Remo !!!

This is my first post and excuse me for this newbie problem. My installation of NeDi 1.0.4 on CentOS 5.4 x86_64 went through fine. I created a seedlist with about 80 switches.

The majority of switches is Force10.

4 are Cisco and a few are HP.

When I run nedi.pl, I see the "...added for discovery" messages for all of them (sample one below):

------------------------------------------------------------------------------------------------------
10.232.65.136 seed79 added for discorvery (the typo in this sentence is not mine - it comes from NeDi :o)
------------------------------------------------------------------------------------------------------


Then I get the "Discovery with 80 seed(s) on Sun Nov 15 08:09:57 2009" with 80 messages like the one below:

------------------------------------------------------------------------------------------------------
10.232.23.252   Netfilter                 79/0-0s
------------------------------------------------------------------------------------------------------


However, at the end, I get:

------------------------------------------------------------------------------------------------------
Took 0 minutes

Nothing discovered, nothing written...
------------------------------------------------------------------------------------------------------


The MySQL is empty.

What am I missing?

Thanks a lot in advance !

Sesh

rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2691
    • View Profile
    • NeDi
Re: Nothing discovered, nothing written...
« Reply #1 on: November 15, 2009, 02:35:39 PM »
The guy who writes a discovery tool cannot spell discorvery or so...go figure  :D

Is netfilter set in nedi.conf? You need something like:
netfilter   .

Now that 1.0.5-RC3 is out, you might as well try this instead (featuring correct spelling and much more  ;) )...
« Last Edit: November 16, 2009, 06:20:12 PM by rickli »
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo

seshadribpl

  • Guest
Re: Nothing discovered, nothing written...
« Reply #2 on: November 16, 2009, 10:49:43 AM »
That was it ! Thanks a lot.

I have downloaded 1.0.5-RC3 and it is in the process of figuring out my network. The discovery earlier on in the day (1.0.4) took a little over 3 hours. I am keeping my fingers crossed in the hope that it will correctly identify my Force10 switches.

I am preparing installation notes for a beginner (a.k.a. NeDi for Dummies  ;)) and if you think they might be useful, I can post them here somewhere.

Thanks, once again,

Sesh

rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2691
    • View Profile
    • NeDi
Re: Nothing discovered, nothing written...
« Reply #3 on: November 16, 2009, 06:17:53 PM »
Heh, yeh another topic I never got around to do :) Feel free to add it directly on the wiki at www.nedi.ch
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo