Welcome, Guest. Please login or register.

Author Topic: How to make Nedi stop trying to discover lightweight wireless access points  (Read 9822 times)

tristanbob

  • Full Member
  • ***
  • Posts: 152
    • View Profile
Nedi is wasting 30 seconds per lightweight AP, and we have over 300 of them.  So over 2 hours of wasted time.  How can we tell Nedi to not discover these devices?  I tried this setting but Nedi is still hitting the APs...

# Regular expression to match discovery protocol description of non-SNMP
# platforms (like lightweight/controlled APs).
nosnmpdev       IP (Phone|Telephone)|MAP-|AIR-

Please visit "Other"->"Invoices" on your NeDi installation to make an annual contribution and support Nedi!

tristanbob

  • Full Member
  • ***
  • Posts: 152
    • View Profile
Re: How to make Nedi stop trying to discover lightweight wireless access points
« Reply #1 on: September 09, 2009, 05:41:35 PM »
Remo suggested I look at the output of this command, using the IP address of the switch that is connected to one of our APs:

./nedi.pl -vt 192.168.1.1

This output shows a lot of information, but the CDP information is the most interesting for my question:

CDP: Gi1/0/9> bldg-103-ap IP:172.16.16.16 Cisco IOS Software, C1130 Software (C1130-K9W8-M), Version 12.4(18a)JA1, RELEASE SOFTWARE (fc1) Technical Support: http://www.cisco.com/techsupport Copyright (c) 1986-2009 by Cisco Systems, Inc. Compiled Fri 23-Jan-09 20:07 by prod_rel_team SV:0 P:12200mW on Fa0-FD Vl0 !SNMP

Looks like I need to add a listing for the model number, "C1130".  I'll test that and report back on how it works.

# Regular expression to match discovery protocol description of non-SNMP
# platforms (like lightweight/controlled APs).
nosnmpdev       IP (Phone|Telephone)|MAP-|AIR-|C1130
Please visit "Other"->"Invoices" on your NeDi installation to make an annual contribution and support Nedi!

tristanbob

  • Full Member
  • ***
  • Posts: 152
    • View Profile
Re: How to make Nedi stop trying to discover lightweight wireless access points
« Reply #2 on: September 09, 2009, 06:26:15 PM »
Here is the actual line I used in nedi.conf:

nosnmpdev       IP (Phone|Telephone)|C1130|C1140|C1310|C1200|C1240

However, Nedi is still trying to discover all of my C1130 access points.  Did I enter it correctly?  Any ideas?

Tristan
Please visit "Other"->"Invoices" on your NeDi installation to make an annual contribution and support Nedi!

rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2695
    • View Profile
    • NeDi
Re: How to make Nedi stop trying to discover lightweight wireless access points
« Reply #3 on: September 09, 2009, 07:36:59 PM »
Wait it says !SNMP, meaning it should not try anything else. Are you sure it tries to contact the ap for 30 secs?
« Last Edit: September 09, 2009, 07:38:53 PM by rickli »
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo

tristanbob

  • Full Member
  • ***
  • Posts: 152
    • View Profile
Re: How to make Nedi stop trying to discover lightweight wireless access points
« Reply #4 on: September 10, 2009, 12:39:50 AM »
Remo,

I'm not sure, this is what I see.  Those IP addresses are for wireless access points...

172.31.77.113   No name, not discoverable          741/8-32s
172.31.43.111   No name, not discoverable          371/262-32s
172.31.58.149   No name, not discoverable          740/8-32s
172.31.56.105   No name, not discoverable          370/262-32s
172.31.59.122   No name, not discoverable          739/8-32s
172.31.86.150   No name, not discoverable          369/262-32s
172.31.86.193   No name, not discoverable          738/8-32s

I am only seeing 64 of these, so perhaps the other 200+ are correctly being discarded.  I will find out what CDP neighbors are showing for these IPs.
Please visit "Other"->"Invoices" on your NeDi installation to make an annual contribution and support Nedi!

rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2695
    • View Profile
    • NeDi
Re: How to make Nedi stop trying to discover lightweight wireless access points
« Reply #5 on: September 10, 2009, 01:49:47 AM »
The AIR- part in the regexp should catch Cisco APs (at least the ones I know). This is what I got at home:

rickli@isis:/var/nedi$ snmpwalk -c public -v2c 10.10.10.5 1.3.6.1.4.1.9.9.23.1.2.1.1.8
SNMPv2-SMI::enterprises.9.9.23.1.2.1.1.8.2.1 = STRING: "cisco AIR-AP1231G-E-K9    "
SNMPv2-SMI::enterprises.9.9.23.1.2.1.1.8.9.2 = STRING: "Cisco IP Phone 7960"
SNMPv2-SMI::enterprises.9.9.23.1.2.1.1.8.9.7 = STRING: "Cisco C836"
SNMPv2-SMI::enterprises.9.9.23.1.2.1.1.8.9.23 = STRING: "Linksys IP Phone SPA-962"
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo

rufer

  • Guest
Re: How to make Nedi stop trying to discover lightweight wireless access points
« Reply #6 on: September 10, 2009, 04:18:22 PM »
Depending where (subnet) your LWAPPs are, you can just not include their subnet in netfilter.

Greetings
Rufer

tristanbob

  • Full Member
  • ***
  • Posts: 152
    • View Profile
Re: How to make Nedi stop trying to discover lightweight wireless access points
« Reply #7 on: September 11, 2009, 11:08:21 PM »
Good point, but our switches and APs are in the same networks.

Remo - It still looks like Nedi is spending 32 seconds on my APs, even the ones that have the "! SNMP" tag during discovery.

Can anyone else confirm this?
Please visit "Other"->"Invoices" on your NeDi installation to make an annual contribution and support Nedi!

rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2695
    • View Profile
    • NeDi
Re: How to make Nedi stop trying to discover lightweight wireless access points
« Reply #8 on: September 13, 2009, 10:00:31 PM »
Have you tried sniffing to actually check what's going on? I can't think of why it stop for 30 secs  ??? You can also add some print statements in libsnmp.pl DisProtocol() (especially after this one:

print "!SNMP" if $main::opt{v};
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo

rufer

  • Guest
I'll return on this because I now have the same problem. Short explication: Until now we had Cisco AIR-AP1121G-E-K9 access points with IOS. Now we are converting them to LWAPP access points which have the same name AIR-AP1121G-E-K9. And we use new AIR-LAP1142N-E-K9 LWAPP access points

With my version of Nedi (NeDi 1.0 20.Mai 2008) I have to put the following into nedi.conf to exclude the AIR-LAP1142N-E-K9:
leafdev AIR-LAP
One important thing is that CDP needs to be enabled a) on the switchport and b) in the controller configuration.

Now for the AIR-AP1121G-E-K9 I can either exclude everything (including IOS access points) or nothing. Or can leavdev filter on other CDP fields than the Platform?

Here are some show CDP neighbour for reference:

AIR-AP1121G-E-K9 IOS
Code: [Select]
sh cdp nei fastEthernet 0/2 detail
-------------------------
Device ID: test-1100
Entry address(es):
  IP address: 10.25.201.248
Platform: cisco AIR-AP1121G-E-K9    ,  Capabilities:
Interface: FastEthernet0/2,  Port ID (outgoing port): FastEthernet0
Holdtime : 143 sec

Version :
Cisco IOS Software, C1100 Software (C1100-K9W8-M), Version 12.4(21a)JA, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2009 by Cisco Systems, Inc.
Compiled Mon 08-Jun-09 16:30 by prod_rel_team

advertisement version: 2
Duplex: full
Power drawn: 4.900 Watts
Management address(es):

AIR-AP1121G-E-K9 LWAPP
Code: [Select]
sh cdp nei fastEthernet 0/48 detail
-------------------------
Device ID: ap123.unine.ch
Entry address(es):
  IP address: 10.25.201.14
Platform: cisco AIR-AP1121G-E-K9    ,  Capabilities: Trans-Bridge
Interface: FastEthernet0/48,  Port ID (outgoing port): FastEthernet0
Holdtime : 161 sec

Version :
Cisco IOS Software, C1100 Software (C1100-K9W7-M), Version 12.3(8)JEB, RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2007 by Cisco Systems, Inc.
Compiled Fri 27-Apr-07 00:52 by hqluong

advertisement version: 2
Duplex: full
Power drawn: 4.900 Watts
Management address(es):

AIR-LAP1142N-E-K9 LWAPP
Code: [Select]
sh cdp nei fa 0/12 det
-------------------------
Device ID: test-1142
Entry address(es):
  IP address: 10.25.207.240
Platform: cisco AIR-LAP1142N-E-K9   ,  Capabilities:
Interface: FastEthernet0/12,  Port ID (outgoing port): GigabitEthernet0
Holdtime : 124 sec

Version :
Cisco IOS Software, C1140 Software (C1140-K9W8-M), Version 12.4(21a)JA, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2009 by Cisco Systems, Inc.
Compiled Mon 08-Jun-09 16:23 by prod_rel_team

advertisement version: 2
Duplex: full
Power drawn: 15.400 Watts
Power request id: 39390, Power management id: 2
Power request levels are:15400 14500 0 0 0
Management address(es):

Greetings
Rufer

rufer

  • Guest
Another easy way to minimize the time nedi "wastes" with LWAPPS is to make the "timeout" value in nedi.conf as small as possible.

Greetings
Rufer

rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2695
    • View Profile
    • NeDi
Too bad Cisco is not using AIR-LAP for all leightweight APs  :-\
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo