Welcome, Guest. Please login or register.

Author Topic: Nedio polling issue  (Read 3612 times)

tman

  • Guest
Nedio polling issue
« on: August 20, 2009, 05:48:00 PM »
I'm in the process of replacing my Nedi 1.0w install with NeDiO44. It's running as a VM and installed fine. I've transferred all my config over from the 1.0w setup ok.

I'm starting from scratch with a new db though. With my 1.0w install, the nedi poller used to run via cron with;
./var/nedi/nedi.pl -u./seedlist, and this worked fine with LLDP on my ProCurve switches. Trying the same command line in NeDiO44 gives me the following error;

NeDi 1.0.4 - 4.Apr 2009
OUI:    14892 NIC vendor entries read
Dev:    0 devices read from nedi.devices
Link:   0 links (WHERE type = "STAT") read from nedi.links


Discovery with 1 seed(s) on Thu Aug 20 16:43:47 2009
====================================================================================
Device                          Status                               Todo/Done-Time
------------------------------------------------------------------------------------
xxx.xxx.xxx.x   Can't call method "get_request" on an undefined value at ./inc/libsnmp.pl line 77.

In this case xxx.xxx.xxx.x is the gateway for the subnet the nedi client resides on, but this host is NOT in the seedlist. Why is NeDi trying to discover it? If I try and manually add one host, I get exactly the same error, but just for the device IP of the ProCurve switch I'm trying to add.

I've obviously missed something, but it's not obvious what!


rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2780
    • View Profile
    • NeDi
Re: Nedio polling issue
« Reply #1 on: August 20, 2009, 08:35:30 PM »
Do you actually use the .w config file? Please use the one that came with the archive as template and edit accordingly....
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo