Welcome, Guest. Please login or register.

Author Topic: Installation on Gentoo  (Read 5026 times)

atilla439

  • Guest
Installation on Gentoo
« on: March 11, 2009, 02:31:36 PM »
I need a little help with a new installation.  I have installed Nedi on a Gentoo box and everything appeared to go ok.  When I try to access the web page for the first time though, I can't login using the admin/admin account.  Is there an alternate account I should use?  What else can I do here? I've re-init'd the database several times to do avail.  When I check the user table the admin account is listed, I have no idea why the password wouldn't be working... Any help/insift?

+-------+----------------------------------+------+------+------+------+------+------+-------+-------+------------+----------+---------------+----------+---------+
| name  | password                         | adm  | net  | dsk  | mon  | mgr  | oth  | email | phone | time       | lastseen | comment       | language | theme   |
+-------+----------------------------------+------+------+------+------+------+------+-------+-------+------------+----------+---------------+----------+---------+
| admin | 21232f297a57a5a743894a0e4a801fc3 |    1 |    1 |    1 |    1 |    1 |    1 | NULL  | NULL  | 1236777113 |     NULL | default admin | english  | default |
+-------+----------------------------------+------+------+------+------+------+------+-------+-------+------------+----------+---------------+----------+---------+

gumba

  • Guest
Re: Installation on Gentoo
« Reply #1 on: March 12, 2009, 07:51:57 AM »
Have you already tried changing the admin password in the database itself? Maybe something went wrong during installation and the password was not stored correctly. Try
Code: [Select]
mysql> update user set password = MD5('yourpassword') where name = 'admin';
in mysql on the command-line and see if you can log in.

atilla439

  • Guest
Re: Installation on Gentoo
« Reply #2 on: March 12, 2009, 03:05:09 PM »
I tried a couple different passwords, same result.  As soon as i hit login it just clears out the user/password box and reloads the page.  The URL bar changes to: http://server/nedi/index.php?goto=<?=rawurlencode($goto)?>, not sure if thats relevant.  Is there any log that would detail errors I can check?

gumba

  • Guest
Re: Installation on Gentoo
« Reply #3 on: March 12, 2009, 03:23:40 PM »
This sounds more like a problem with your web server to me rather than a problem with NeDi itself. Have you made sure that PHP is actually up and running on your system? If so, have a look at you php.ini config file ( on my system with Apache2 and PHP5 installed, it is located at /etc/php5/apache2/php.ini, but this might differ for you) and make sure short_open_tags in the Language Options section is set to On.
Code: [Select]
short_open_tag = On

atilla439

  • Guest
Re: Installation on Gentoo
« Reply #4 on: March 12, 2009, 04:02:28 PM »
PHP was working, I have CACTI running on this box as well... But you are correct, that setting was set to off.  Changing it to on resolved my issue!  Thanks so much for your assistance.

gumba

  • Guest
Re: Installation on Gentoo
« Reply #5 on: March 12, 2009, 04:18:44 PM »
I've also stumbled across this "feature" of PHP several times before while trying to get applications to work. Maybe there should be a hint in the NeDi documentation that this configuration is necessary, since I've seen a lot of installations where short_open_tags is disables by default and this is a problem that's really hard to figure out.

rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2632
    • View Profile
    • NeDi
Re: Installation on Gentoo
« Reply #6 on: March 12, 2009, 06:50:00 PM »
I did mention it here, but it's only focussing on OpenBSD, hence harder to find: http://www.nedi.ch/doku.php?id=install:openbsd4
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo