Welcome, Guest. Please login or register.

Author Topic: libsnmp error  (Read 5283 times)


  • Guest
libsnmp error
« on: February 13, 2009, 02:48:36 PM »
After installing Ubuntu 8.04 a number of time (big learning curve) I have hit a problem installing Nedi 1.0 rc6, I tried with the stable version but I get the same error which is: -

Nothing discovered, nothing written...
root@cna:/opt/nedi# ./nedi.pl -cob
OUI:   13203 NIC vendor entries read
Dev:   0 devices read from nedi.devices
Link:   0 links (WHERE type = "S") read from nedi.links
Version 1.0-rc6 5.Feb 2008
CDP-OUI-Discovery with 1 seed(s) on Fri Feb 13 13:40:44 2009
Device            Status                 Todo/Done-Time
------------------------------------------------------------------------------------   Use of uninitialized value in regexp compilation at ./inc/libsnmp.pl line 39.
Use of uninitialized value in concatenation (.) or string at ./inc/libsnmp.pl line 41.
Use of uninitialized value in concatenation (.) or string at ./inc/libsnmp.pl line 45.
Netfilter          0/0-0s
Took 0 minutes

Nothing discovered, nothing written...

What is the issue here do you think, I the file libsnmp at all.

I followed this install guide right up to number 14 which is what gives the above error

install guide https://help.ubuntu.com/community/NediHowTo




  • Guest
Re: libsnmp error
« Reply #1 on: February 13, 2009, 11:10:59 PM »
I was wishing that I had got a reply by now  ::)
Always makes we wonder if nobody else has had an issue like this before



  • Administrator
  • Hero Member
  • *****
  • Posts: 2774
    • View Profile
    • NeDi
Re: libsnmp error
« Reply #2 on: February 14, 2009, 01:02:57 PM »
First of all anything before 1.0 sucks (I'm the only one who's allowed to say such things!). Then search the forum for "Nothing discovered, nothing written" and you'll see that your problem is not Nedi or its installation...

Have a look at how to configure NeDi (especially Netfilter) and make sure you use tabs.
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!


  • Guest
[resolved] libsnmp error
« Reply #3 on: February 15, 2009, 09:27:09 PM »
Thanks, I used the netfilter .

However I still have my original issue with system.rrd, I will do another search on the forums to see if I can find my answer, if not I will post on the back of my original thread