Welcome, Guest. Please login or register.

Author Topic: No node entrys found in nedi - only on one Stack (4 x C9300L-48T-4X )  (Read 404 times)

kierberger

  • Newbie
  • *
  • Posts: 5
    • View Profile
Hello everybody,

does anybody have an idea, why one switch from my switches has no nodes in the node-list?
It is stack of 4 pcs Cisco C9300L-48T-4X.  From other Stacks, mainly of WS-C2960X-48TD-L
i see the nodes list entrys perfect ?

How does nedi find and store nodes information in the database ?

thanx in advance,
Josef

 
sunset & beer ...

Hannu Liljemark

  • Full Member
  • ***
  • Posts: 149
  • Here to help
    • View Profile
Re: No node entrys found in nedi - only on one Stack (4 x C9300L-48T-4X )
« Reply #1 on: September 17, 2020, 12:52:57 PM »
Hi

Maybe your Nedi doesn't have a definition file for that switch stack and is unable to pull all data the switch has to offer.

If you try to re-discover the stack from via web GUI by hitting the radar icon in SNMP line or the command line with "nedi.pl -v -SGg -a ip-address-here", does Nedi print right in the beginning something like "SOBJ:Reading 1.3.6.1.4.1.11.2.3.7.11.140.def (HP2530-24G)"? The SysObjId and Type would be something else in your case.

If definition file is missing, you could try following Remo's guide on definition file creating: http://www.nedi.ch/documentation/expand/

Br,
Hannu
« Last Edit: September 17, 2020, 12:56:49 PM by Hannu Liljemark »

kierberger

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: No node entrys found in nedi - only on one Stack (4 x C9300L-48T-4X )
« Reply #2 on: September 23, 2020, 10:02:56 AM »
Hi Hannu,

thanx for responding! I think the Device is known to nedi:

DNS :Net::Nslookup not available
CLI :IO-Pty loaded
WEB :LWP-UserAgent loaded

Network Discovery (2.0.120) /opt/nedi/nedi.pl -v -SGg -a10.68.20.22
RDEV:187 devices read from nedi.devices
OUI :39103 NIC vendor entries read
RMON:35 entries (dev) read from nedi.monitoring
RMON:0 entries (node) read from nedi.monitoring
RUSR:1 entries (groups & 8 = 8 AND (phone != '' OR email != '')) read from nedi.users
TODO:10.68.20.22     10.68.20.22              added
RADR:2890 IF MAC, 145 IP and 0 IPv6 addresses read.
MAIN:1 discoveries), 1st from Wed Sep 23 10:00:01 2020 seems ok adding this one
Started with 1 seed at Wed Sep 23 10:00:25 2020
-------------------------------------------------------------------------------
Device            Status            Todo/Done-Time
===============================================================================
DISC:10.68.20.22 ID 10.68.20.22

Identify 10.68.20.22 ++++++++++++++++++++++++++
SNMP:Connect 10.68.20.22 ********** v2 Tout:2s MaxMS:1472 Retry:1 NB:0
MAP :Removing domain part of HOIKTN-93-02.horn.lknoe.at
IDNT:Sysname=HOIKTN-93-02
SOBJ:Reading 1.3.6.1.4.1.9.1.2804.def (C9300L-24T-4G)
sunset & beer ...

rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2786
    • View Profile
    • NeDi
Re: No node entrys found in nedi - only on one Stack (4 x C9300L-48T-4X )
« Reply #3 on: September 25, 2020, 10:34:44 AM »
With a verbose discovery you don't see any FWDS lines? They'd indicate reading MACs. Alternatively you can provide CLI access to NeDi and you should see FWDC lines.

It's actually a good topic for the next tutorial, I'll hopefully be able to provide soon...
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo

kierberger

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: No node entrys found in nedi - only on one Stack (4 x C9300L-48T-4X )
« Reply #4 on: October 07, 2020, 11:02:39 AM »
Hi Remo,

yes, indeed there are no FWDS lines, i think the problem could be here:

Output from verbose discorvery:

Prepare (CLI)  ----------------------------------------------------------------  Wed Oct  7 10:50:14 2020
PREP:IF-addr unsupported
DISC:Clistatus = unsupported mode ifa

__________

This output is just one section before the "Bridge Forward (CLI)" including the FWDC lines (on all the other Switches)

regards,
Josef
 
sunset & beer ...

rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2786
    • View Profile
    • NeDi
Re: No node entrys found in nedi - only on one Stack (4 x C9300L-48T-4X )
« Reply #5 on: October 12, 2020, 12:16:12 PM »
No, that's just a misleading debuginfo (I'm going to remove it again).
Check the "MAC Address" setting in Defed. You can email me for assistance...
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo

kierberger

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: No node entrys found in nedi - only on one Stack (4 x C9300L-48T-4X )
« Reply #6 on: October 16, 2020, 08:38:42 AM »
Thanx Remo,

Problem solved - It was a missing entry of the "MAC Address" field in Defed. I set the value to "Vlan community Index", like in all other Cisco Switches -> now I can see all the nodes connected to this switch in the Nodelist.

-> Close case & open a beer

regards,
Josef
sunset & beer ...