Welcome, Guest. Please login or register.

Author Topic: It's installed but I get a 403 error from the web page  (Read 300 times)

jbruyet

  • Newbie
  • *
  • Posts: 16
    • View Profile
It's installed but I get a 403 error from the web page
« on: October 09, 2017, 09:53:56 PM »
Hey all, I was finally able to complete my NeDi installation without errors; I was neglecting to "sudo" that initialization command.

Now that I'm trying to access the web page I'm getting a "403 Forbidden" error. I've chown'ed the entire /opt directory to www-data but no joy. I deleted the soft link and recreated it. Nope. I even went into the nginx default sites configuration and made /opt/nedi/html the default web site but I'm still getting the 403 error.

I've been using the NeDi instructions from this site: https://help.ubuntu.com/community/NediHowTo

Can anyone see where I may have gone wrong?

Thanks,

Joe B
« Last Edit: October 09, 2017, 10:20:02 PM by jbruyet »

jbruyet

  • Newbie
  • *
  • Posts: 16
    • View Profile
Re: It's installed but I get a 403 error from the web page
« Reply #1 on: October 16, 2017, 10:52:40 PM »
I've been looking around for nginx fixes and from what I can see nginx is working fine. File permissions are fine. I checked the nginx error log and found this entry for every time I tried to access NeDi through the web interface:

Code: [Select]
2017/10/16 13:40:47 [error] 5600#5600: *1 directory index of "/opt/nedi/html/" is forbidden,
client: 192.168.2.22, server: _, request: "GET / HTTP/1.1", host: "192.168.2.32"


I have to be missing something simple but I'm not finding anything.

Anyone?

Thanks,

Joe B

rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2558
    • View Profile
    • NeDi
Re: It's installed but I get a 403 error from the web page
« Reply #2 on: October 17, 2017, 10:29:53 AM »
Ok, how about you set up an Ubuntu 17.10 Beta2 and run that new nebuntu.sh script as root? It will install everything for you :-)
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo

jbruyet

  • Newbie
  • *
  • Posts: 16
    • View Profile
Re: It's installed but I get a 403 error from the web page
« Reply #3 on: October 17, 2017, 05:39:53 PM »
Well, since I just did another fresh install and I'm getting the same error I think I'll try that. Hopefully I'll be back with a happy face.

Thanks,

Joe B

jbruyet

  • Newbie
  • *
  • Posts: 16
    • View Profile
Re: It's installed but I get a 403 error from the web page
« Reply #4 on: October 17, 2017, 05:47:14 PM »
Quick question -- I've been using 64 bit Ubuntu so I checked to see if NeDi needs 32 bit but I can't find any information as to the preferred bit-ness. Should I be using 32 bit Ubuntu?

Thanks,

Joe B

rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2558
    • View Profile
    • NeDi
Re: It's installed but I get a 403 error from the web page
« Reply #5 on: October 17, 2017, 10:45:48 PM »
NeDi is perl and php only...not architecture dependant. I only use 64-bit myself...

I really recommend using this: http://www.nedi.ch/pub/nebuntu.sh as root

You may have to replace 7.1 with 7.0 for non 17.10 Ubuntus as described here https://forum.nedi.ch/index.php?topic=2066.0
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo

jbruyet

  • Newbie
  • *
  • Posts: 16
    • View Profile
Re: It's installed but I get a 403 error from the web page
« Reply #6 on: October 19, 2017, 10:49:34 PM »
Thanks Rickli, I downloaded Ubuntu 16, did the script tweak, ran it and now NeDi is running.

Thanks,

Joe B