Welcome, Guest. Please login or register.

Author Topic: CLI access fail on 20% of my switches  (Read 67 times)


  • Newbie
  • *
  • Posts: 29
    • View Profile
CLI access fail on 20% of my switches
« on: March 14, 2017, 08:24:00 AM »
Hello Forum,

I run NeDi 1.5.225p3 on Ubuntu 16.04 with PHP 5.6.30 and MySQL 5.7

In general, this system runs as expected.

But for approx. 20% of my switches (all Cisco) the configuration backup fails with errror
Code: [Select]
Prepare (CLI) ----------------------------------------------------------------
SSH :admin@ Tout:2s OS:IOS EN:[\w+().-]+#\s?$
PTY :Forking ssh -o 'StrictHostKeyChecking no' -l admin
ERR0:pattern match timed-out
EVNT:MOD=B/1 L=150 CL=cfge TGT=SWITCH23 MSG=Config backup error: connection pattern match timed-out

I set
Code: [Select]
usessh always in nedi.conf.

The failing device types are different, i.e. WS-C3750-24FS-S (IOS 12.2(53)SE2), WS-C2960-24PC-L (IOS 12.2(53)SE2), WS-C3560G-24TS-S (IOS 12.2(53)SE2).

I tried to run nedi.pl in debug mode (/var/nedi/nedi.pl -v -d -b -a to get additional information with input.log and output.log, but I could not get these files being created. I run the nedi.pl command as user www-data.

Does anybody has any hint how to fix this isse or at least how to get input.log and output.log being created?

Many thanks