Welcome, Guest. Please login or register.

Author Topic: Updating to 1.5 receiving DB error  (Read 754 times)

achandab

  • Newbie
  • *
  • Posts: 1
    • View Profile
Updating to 1.5 receiving DB error
« on: January 03, 2017, 01:43:25 AM »

DB version 1.5.225 is not supported, sorry!


rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2558
    • View Profile
    • NeDi
Re: Updating to 1.5 receiving DB error
« Reply #1 on: January 04, 2017, 10:05:44 AM »
It sounds like the upload of 1.6 fails in the first place!

The NeDi init only updates the DB scheme to the current version. If the upload fails, your still running 1.5, which can only perform an update from 1.4…

To update NeDi via browser the following prerequisites have to be met:

1)
On your server in php.ini or php-fpm.ini, make sure the NeDi archive can be uploaded:
post_max_size = 128M
upload_max_filesize = 128M

2)
Also if you’re running nginx:
  client_max_body_size 128m;

3)
All files need to be writeable by webserver:
cd /var/nedi
chown -R www-data.www-data /var/nedi

Now you can try again and you should get a green status line after uploading 1.6.
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo