Welcome, Guest. Please login or register.

Author Topic: problem with update to 1.5  (Read 2828 times)

radoslaw

  • Newbie
  • *
  • Posts: 5
    • View Profile
problem with update to 1.5
« on: October 06, 2016, 07:29:58 PM »
Hello,

I use nedio 1.4 and want to upgrade to 1.5 community version. I follow upgrade instructions but every time i get the following error:

Read nedi-1.5C.tgz

(...)

Errors Write nedi-1.5C.tgz

What could be wrong?

velmeran

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: problem with update to 1.5
« Reply #1 on: October 06, 2016, 07:56:11 PM »
I'm having similar problems also.

Did a fresh install of 1.4 in Centos this morning, its up and running with no problems.

Try to apply 1.5C patch and just get "Errors Read nedi-1.5C.tgz"

Try to apply 1.4p6 Patch and get:

Read nedi-1.4p6.tgz

Backup msg.txt
Backup devtools.php
Backup crontab
Backup nedi.conf
Backup seedlist
Backup agentlist

tar: sysobj: Cannot utime: Operation not permitted
tar: sysobj: Cannot change mode to rwxr-x---: Operation not permitted
tar: inc: Cannot utime: Operation not permitted
tar: inc: Cannot change mode to rwxr-x---: Operation not permitted
tar: html/languages/english: Cannot utime: Operation not permitted
tar: html/languages/english: Cannot change mode to rwxr-x---: Operation not permitted
tar: html/inc: Cannot utime: Operation not permitted
tar: html/inc: Cannot change mode to rwxr-x---: Operation not permitted
tar: html/languages: Cannot utime: Operation not permitted
tar: html/languages: Cannot change mode to rwxr-x---: Operation not permitted
tar: html/log: Cannot utime: Operation not permitted
tar: html/log: Cannot change mode to rwxr-x---: Operation not permitted
tar: html: Cannot utime: Operation not permitted
tar: html: Cannot change mode to rwxr-x---: Operation not permitted
tar: Exiting with failure status due to previous errors
Errors Write nedi-1.4p6.tgz

I have the system in permissive mode and still seems like permissions aren't correct somewhere.  This is the guide I used for setup:  https://wiki.fysik.dtu.dk/it/NeDi_installation_on_CentOS

rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2542
    • View Profile
    • NeDi
Re: problem with update to 1.5
« Reply #2 on: October 08, 2016, 02:52:15 AM »
Errors Write nedi-1.5C.tgz means the archive couldn't be extracted...

For both of you:
- Does the webserver have write permission in the nedi folder?
- In general make sure your webserver has post and upload max size of at least 5M set in php.ini
- Last but not least, Chrome (and Safari by default) decompresses gz automatically. If the archive is 12MB you need to download with something else...
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo

joserra

  • Newbie
  • *
  • Posts: 15
    • View Profile
Re: problem with update to 1.5
« Reply #3 on: October 10, 2016, 10:10:18 AM »
Choosing .tar file instead .tgz worked fine for me !

leckermojito

  • Newbie
  • *
  • Posts: 13
    • View Profile
Re: problem with update to 1.5
« Reply #4 on: October 19, 2016, 08:30:35 AM »
I had the same issue.
Also the tip with .tar didnīt help.

I have copyed it manually to the system and unpacked it
cheers

Benjamin

dohco

  • Newbie
  • *
  • Posts: 27
    • View Profile
Re: problem with update to 1.5
« Reply #5 on: October 19, 2016, 09:34:23 AM »
My simular problem was solved with Remo's last tip:
"- Last but not least, Chrome (and Safari by default) decompresses gz automatically. If the archive is 12MB you need to download with something else..."

When I switched to Internet Explorer and downloaded the file it worked just fine. Chrome didn't work since it unpacks the file on the fly.

/Conny

Sam Conder

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: problem with update to 1.5
« Reply #6 on: October 21, 2016, 04:48:23 PM »
Same issue here, NeDiO14, attempting to upgrade to 1.5.  Same exact error as original post, using IE and FF did not work. Trying .tar versus .tgz does not work either.

rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2542
    • View Profile
    • NeDi
Re: problem with update to 1.5
« Reply #7 on: October 21, 2016, 04:54:58 PM »
How big is the tgz you're uploading?

If all fails you can extract the archive in /var/nedi. Make sure to keep a copy of the existing nedi.conf and seedlist for reference. Change owner to www afterwards...
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo

Subordination

  • Newbie
  • *
  • Posts: 26
    • View Profile
Re: problem with update to 1.5
« Reply #8 on: November 05, 2016, 02:59:01 PM »
when I attempt to upgrade from Nedi 1.4 p6 on my CENTOS platform - once I've extracted 1.5C and modified the nedi.conf + permissions I get this error when attempting to run nedi.pl ; (nedi14 is my db)


[root@SHCNETMON104] [/usr/local/nedi] > ./nedi.pl
DBD::mysql::db selectall_hashref failed: Table 'nedi14.policies' doesn't exist at ./inc/libdb.pm line 2112.
DBD::mysql::db selectall_hashref failed: Table 'nedi14.policies' doesn't exist at ./inc/libdb.pm line 2112.

any ideas do i need to alter the object "stolen" to be "policies" ?

rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2542
    • View Profile
    • NeDi
Re: problem with update to 1.5
« Reply #9 on: November 06, 2016, 10:34:44 AM »
Did you do nedi.pl -i updatedb?
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo

Subordination

  • Newbie
  • *
  • Posts: 26
    • View Profile
Re: problem with update to 1.5
« Reply #10 on: November 12, 2016, 02:18:40 PM »
thanks that worked -

another slight issue seems like navigation of the topology layers , from my snmp location strings does'nt dig as previously;

at the third delimiter it won't open further - is there a nedi.conf adjustment required?

rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2542
    • View Profile
    • NeDi
Re: problem with update to 1.5
« Reply #11 on: November 15, 2016, 12:58:37 PM »
There is a more recent building separator (_ by default) allowing for sub-buildings at the same adress.

Pls post your strings and locsep settings, if you can't find a solution...
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo

Subordination

  • Newbie
  • *
  • Posts: 26
    • View Profile
Re: problem with update to 1.5
« Reply #12 on: December 01, 2016, 09:31:39 PM »
Thanks - that was the issue