Welcome, Guest. Please login or register.

Author Topic: rrd graph not drawn  (Read 3432 times)

Vince

  • Guest
rrd graph not drawn
« on: August 18, 2015, 11:59:47 AM »
Hello!

After a lot of researches I've finally decided to come to ask some help.
I have two different NeDi installations and I have the same problem on the both: the graph are not drawn in the GUI, the grid is there but stays empty even after many days. I can't see any graphs.

My first check was to control if the rrd files were created and if the discovery was doing the update of those files. On this side, everything is working.

I checked the Apache logs and the only thing I see is:
Quote
[Tue Aug 18 11:34:40.963146 2015] [:error] [pid 1483] [client xxx.xxx.xxx.xxx:xxxxxx] PHP Notice:  Undefined variable: exportxls in /var/nedi/html/inc/header.php on line 247, referer: https://xxx/Devices-Graph.php?dv=NameOfDevice&if[]=cpu
Or
Quote
[Tue Aug 18 11:44:28.077215 2015] [:error] [pid 32480] [client xxx.xxx.xxx.xxx:xxxxxx] PHP Notice:  Undefined variable: exportxls in /var/nedi/html/inc/header.php on line 247, referer: https://xxx/Devices-Graph.php?dv=NameOfDevice&if%5B%5D=cpu&sta=07%2F16%2F2015+03%3A44&end=08%2F18%2F2015+11%3A34&sze=&sho=Show
This shouldn't be a problem, it's related to the XLS export feature.

I also tried the rrdtool command:
Quote
rrdtool graph -a PNG /tmp/test.png DEF:cpu=/var/nedi/rrd/NameOfDevice/system.rrd:cpu:AVERAGE CDEF:cpu1=cpu,1,/ LINE2:cpu#884400:"%"

481x155
And
Quote
php -f inc/drawrrd.php dv=MkGwLan s=5 t=mem a=1429537740 e=1432417140 debug=1
I have no error with those two commands.

The user "Nedi" owns all the NeDi folders.

I don't know where this problem comes from, can you give me some help please?

Thanks in advance


tuxedo

  • Guest
Re: rrd graph not drawn
« Reply #1 on: September 09, 2015, 09:58:49 AM »
Hallo Vince,

please use CLI to go to your rrd directory and find a rrd-file where the graphs are not drawn for.
Than do "rrdtool dump FILENAME".
This will print all the information of the rrd-file.
Look for the "database" sections and check if there are only "NaN" in the listed rows.
If that happened than you may have a problem with the data gathering at all or with
the update of the rrd-files.

CU
Werner

rheath

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: rrd graph not drawn
« Reply #2 on: October 20, 2015, 09:33:40 PM »
Make sure that your discovery interval matches the rrdstep value in your nedi.conf.