Welcome, Guest. Please login or register.

Author Topic: no rrd graphics  (Read 4897 times)

nti

  • Newbie
  • *
  • Posts: 15
    • View Profile
no rrd graphics
« on: May 19, 2015, 12:08:14 PM »
Hi

It seems rrds are created, but can't not be shown. There are only litte greey icons on the gui.

If I call a rrd URL directly this error appears:
Code: [Select]
"Die Grafik "http://nedi.local/inc/drawrrd.php?dv=MK883&s=5&t=cpu&a=1429109760&e=1431989160" kann nicht angezeigt werden, weil sie Fehler enthält."
Debug output:

Code: [Select]
rrdtool graph - -a PNG --title="CPU Last 15.Apr 15 16:56" -w800 -h200 -s1429109760 -e1431989160  -L6
DEF:cpu=/usr/local/www/nedi/rrd/MK883/system.rrd:cpu:AVERAGE AREA:cpu#cc8844 CDEF:cpu2=cpu,1.3,/ AREA:cpu2#dd9955 CDEF:cpu3=cpu,2,/ AREA:cpu3#eeaa66 LINE2:cpu#884400:"%"

The rrd is built:
Code: [Select]
ls -la /usr/local/www/nedi/rrd/MK883/system.rrd
66 -rw-r--r--  1 www  www  65968 19 Mai 10:37 /usr/local/www/nedi/rrd/MK883/system.rrd

What can I do to resolve the problem? There are no errors in the php log.

System:
nedi 1.14p3
FreeBSD 9.3-STABLE
psql (PostgreSQL) 8.4.22
perl 5, version 18, subversion 4
PHP 5.4.40
RRDtool 1.4.8


nti



rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2632
    • View Profile
    • NeDi
Re: no rrd graphics
« Reply #1 on: May 19, 2015, 04:41:24 PM »
None at all or are some working?
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo

nti

  • Newbie
  • *
  • Posts: 15
    • View Profile
Re: no rrd graphics
« Reply #2 on: May 19, 2015, 05:18:05 PM »
None. But I've tested rrdtool on the terminal like this

Code: [Select]
rrdtool graph -a PNG /tmp/test.png DEF:cpu=/usr/local/www/nedi/rrd/switch-tl2/system.rrd:cpu:AVERAGE CDEF:cpu1=cpu,1,/ LINE2:cpu#884400:"%"
481x155
ERROR: Could not save png to '/tmp/test.png'

 After some searching on google I reinstalled "cairo" (which is necessary for rrdtool). Now it works!

rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2632
    • View Profile
    • NeDi
Re: no rrd graphics
« Reply #3 on: May 19, 2015, 06:02:06 PM »
Ah good one! Tx
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo

nti

  • Newbie
  • *
  • Posts: 15
    • View Profile
Re: no rrd graphics
« Reply #4 on: May 24, 2015, 12:28:45 AM »
After a computer crash all rrds are gone. I tried the calling on the terminal again but now everything seems to be OK, a test png is created. Nevertheless there is "Keine RRD Datei". I've deleted the hole rrd directory, the rrd files are build again, but I can't get a graphic on nedi.

This command creates a png, but it last a few seconds:
Code: [Select]
rrdtool graph -a PNG test.png -w800 -h200 -s1429536600 -e1432416000 -L6 DEF:cpu=/usr/local/www/nedi/rrd/MkGwLan/system.rrd:cpu:AVERAGE AREA:cpu#cc8844 CDEF:cpu2=cpu,1.3,/ AREA:cpu2#dd9955 CDEF:cpu3=cpu,2,/ AREA:cpu3#eeaa66 LINE2:cpu#884400:"%"
No error messages are given:
Code: [Select]
php -f inc/drawrrd.php dv=MkGwLan s=5 t=mem a=1429537740 e=1432417140 debug=1
How can I find out whats going wrong?



rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2632
    • View Profile
    • NeDi
Re: no rrd graphics
« Reply #5 on: May 24, 2015, 12:01:23 PM »
You need to comment line 13 of drawrrd.php, but in the CLI you'll get errors for missing variables. I'd really test this via browser...

Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo

nti

  • Newbie
  • *
  • Posts: 15
    • View Profile
Re: no rrd graphics
« Reply #6 on: May 24, 2015, 09:26:20 PM »
Crazy, now it works again. I don't know why....  ???

nti

  • Newbie
  • *
  • Posts: 15
    • View Profile
Re: no rrd graphics
« Reply #7 on: June 19, 2015, 11:08:38 PM »
And the RRD graphs are away again - thats very curios   :-[