Welcome, Guest. Please login or register.

Author Topic: Devices write not executing all lines  (Read 1492 times)

Mikeuyz

  • Guest
Devices write not executing all lines
« on: May 01, 2015, 02:43:48 PM »
Hi all,

When you have a big network, you want to be lazy and just enter a command in 1 field, and hit the button "Execute/Configuration". Unfortunately it looks like Nedi does not feel like helping me out today :(...

I ran in to the following issue with Nedi:

When entering the following in the box of the Write page, after this pressing show (to see an preview), and afterwards pressing "configuration" to execute.
Code: [Select]
access-list 23 remark NOCExample
access-list 23 permit 192.168.1.1
access-list 23 permit 172.16.0.1 0.0.0.15
access-list 23 remark SomethingExample
access-list 23 permit 8.8.8.8

The only thing it does is this:
Code: [Select]
conf t
Enter configuration commands, one per line.  End with CNTL/Z.
access-list 25 remark NOCExample
access-list 25 permit 192.168.1.1
access-list 25 permit 172.16.0.1 0.0.0.15
access-list 25 remark SomethingExample
access-list 25 permit 8.8.8.8
end
write mem

sw0-mer1-tc2-ams(config)#access-list 25 permit 8.8.8.8

As you can see only `sw0-mer1-tc2-ams(config)#access-list 25 permit 8.8.8.8` was being executed.

Or in some cases it only does this:
Code: [Select]
conf t
Enter configuration commands, one per line.  End with CNTL/Z.
access-list 25 remark NOCExample
access-list 25 permit 192.168.1.1
access-list 25 permit 172.16.0.1 0.0.0.15
access-list 25 remark SomethingExample
access-list 25 permit 8.8.8.8
end
write mem

Current nedi version: NeDi 1.0.9-010 (C) 2001-2013 Remo Rickli & contributors

Additional quick questions: is there any fixes regarding this in the latest version? Or is there any quickfixes? Hopefully somebody can help me out!


Thanks in advance,
Mikey van der Worp


rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2693
    • View Profile
    • NeDi
Re: Devices write not executing all lines
« Reply #1 on: May 02, 2015, 10:22:41 AM »
1.0.9 had some issues with CLI. Can you try with 1.4 on a test machine? Also debugging according to the CLI video tutorial can help...
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo

Mikeuyz

  • Guest
Re: Devices write not executing all lines
« Reply #2 on: May 04, 2015, 11:51:22 AM »
Hi rickli,

Thanks for your reply, we want to upgrade to the latest version of NeDi anyhow, so i'll just perform the upgrade.

I'll let you know if it is fixed or not.

~ Mikey

Mikeuyz

  • Guest
Re: Devices write not executing all lines
« Reply #3 on: May 06, 2015, 04:27:36 PM »
The latest update has fixed this issue, thank you very much!

~Mikey