Welcome, Guest. Please login or register.

Author Topic: An SNMPv3 question.  (Read 10282 times)

A-Zed

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: An SNMPv3 question.
« Reply #15 on: February 27, 2015, 04:51:07 AM »
And the Doofus of the year award goes to.....drum roll....... (envelope please).................

A-Zed!.......Accepting the award humbly is A-Zed.... So tell us, what led you to achieving this award tonight?

Well, what can I say? The simple thing of making sure that in your switch config you have the line:
snmp-server community <string>

and that in your nedi.conf file you have the community string set:
comm   <string>

then it all works well.

Rickli, I didn't use Nedio14, I amended my nedi.conf as well as ensuring the snmp community string was set in my switches. Once this was done, it all worked as expected. Sorry for wasting time, but I guess that's the cost of learning.

Thank you all for your comments and assistance.

A-Zed

rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2601
    • View Profile
    • NeDi
Re: An SNMPv3 question.
« Reply #16 on: February 27, 2015, 05:14:01 PM »
Glad it works now and thanks for the entertaining post ;)
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo

angrybutler

  • Newbie
  • *
  • Posts: 14
    • View Profile
Re: An SNMPv3 question.
« Reply #17 on: May 20, 2015, 08:58:04 PM »
A-Zed,

I know this thread is a bit dated, but for the possible benefit of others....

I think what you did to resolve the SNMPv3 problem was effectively disable SNMPv3 and go back to SNMPv2c.

The "snmp-server community <string> " command you entered on the switch is a 2c community, not v3.

I just finished struggling with this on 1.4, and it appears that you *need* to install the perl modules for the appropriate encryption/hash functions.  See the requirements section in this page:

http://search.cpan.org/~dtown/Net-SNMP-v6.0.1/lib/Net/SNMP.pm

"The non-core modules Crypt::DES, Digest::MD5, Digest::SHA1, and Digest::HMAC are required to support SNMPv3."

To fix this on my debian/ubuntu install, I did the following:

Code: [Select]
sudo apt-get install libcrypt-cbc-perl libcrypt-des-per libdigest-perl-md5-perl libdigest-sha-perl
The way I discovered this, was to do a packet capture of snmp traffic to my device using wireshark.  Until I installed these packages, I was seeing *no* attempt by nedi/snmpnet to send the credentials to the test device.

Best regards,
Tom Sutherland