Welcome, Guest. Please login or register.

Author Topic: vrfName disappeared  (Read 2199 times)

richard.lajaunie

  • Newbie
  • *
  • Posts: 26
    • View Profile
vrfName disappeared
« on: January 27, 2014, 03:34:10 PM »
Hello Remo,

i am testing 1.0.9 version and i discover that the vrf names had disappeared.
In the table Networks the column "vrfname" is empty.
Is there a new configuration or switch i've missed?

Thank you.
Richard

rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2697
    • View Profile
    • NeDi
Re: vrfName disappeared
« Reply #1 on: February 02, 2014, 11:36:12 AM »
They're still there and should be visible in Topology-Networks. However I found a glitch which prevented them to show up in Devices-Status, tx.
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo

richard.lajaunie

  • Newbie
  • *
  • Posts: 26
    • View Profile
Re: vrfName disappeared
« Reply #2 on: February 05, 2014, 12:35:53 PM »
Hi remo,

for information in the table «networks», the fields «vrfname» and «status» are set to NULL for all records.

What can i do to fix it ?
Is there a way i can help you ?

Tx
Richard

rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2697
    • View Profile
    • NeDi
Re: vrfName disappeared
« Reply #3 on: February 06, 2014, 07:03:55 PM »
You still get all IP addresses?
Do you get results when walking 1.3.6.1.3.118.1.2.1.1.6 on the devices in question?
When running nedi.pl -va <devip> do you see lines starting with "ERR :VRF"?
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo

richard.lajaunie

  • Newbie
  • *
  • Posts: 26
    • View Profile
Re: vrfName disappeared
« Reply #4 on: February 07, 2014, 10:24:39 AM »
Hi,
For a complete information i've a nedi 1.0.7 running in production, i'm testing 1.0.9 for prod replacement, so i can compare the result.

In the networks table, it seems that all network are not report.

I've test the oid 1.3.6.1.3.118.1.2.1.1.6 against our VSS and it work fine.

I've run a nei.pl -va and i did not find any reference at all to VRF.

it appear like if the vrfname collect was never called.

Tx
richard

rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2697
    • View Profile
    • NeDi
Re: vrfName disappeared
« Reply #5 on: February 07, 2014, 07:22:30 PM »
Ah got it! The VSS.def has a typo. The type should say WS- not SW-
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo

richard.lajaunie

  • Newbie
  • *
  • Posts: 26
    • View Profile
Re: vrfName disappeared
« Reply #6 on: February 10, 2014, 10:49:07 AM »
Hi,
Remo, i confirm that the problem was in the VSS.def.


Tx
richard