Welcome, Guest. Please login or register.

Author Topic: Nedi 321 alias problem  (Read 2064 times)

Al

  • Guest
Nedi 321 alias problem
« on: November 22, 2013, 03:02:25 AM »
Nice, tried out the 321 install and it works mighty good.

However... I have a Cisco 2960 (12.2(55)SE7) that doesn't show any entries in the alias column on the device status page but does when I query the oid (1.3.6.1.2.1.31.1.1.1.18) in the defgen (using the default sysobj). Not a problem with a 2950.

When I do a SNMP tcpdump, I can see the interface alias getting requested and returned but somewhere nedi is not importing them into the database. A verbose nedi shows an empty column for alias too:

Quote
IF  :Walking high-speed
IF  :Walking 64bit counters
IF  :Walking errors
IF  :Walking discards
IF  :Walking in-broadcasts
IF  :Walking name
IF  :Walking description
IF  :Walking type
IF  :Walking alias
IF  :Walking alias index
IF  :Walking vlan
IF  :Walking duplex
IF  :Walking admin status
IF  :Walking oper status
IF  :Index Name         Spd Dup St Pvid Description      Alias            PoE
IF  :    1 Vl1         1000M  -   3    0 Vlan1                              0
IF  :10001 Fa0/1         10M  FD  3    1 FastEthernet0/1                    0
IF  :10002 Fa0/2        100M  FD  3  106 FastEthernet0/2                    0
IF  :10003 Fa0/3        100M  FD  1    1 FastEthernet0/3                    0
IF  :10004 Fa0/4        100M  FD  3  101 FastEthernet0/4                    0
IF  :10005 Fa0/5        100M  FD  3  118 FastEthernet0/5                    0
IF  :10006 Fa0/6         10M  ?   1    0 FastEthernet0/6                    0
IF  :10007 Fa0/7        100M  FD  3  102 FastEthernet0/7                    0
IF  :10008 Fa0/8        100M  FD  3  101 FastEthernet0/8                    0
IF  :10009 Fa0/9        100M  FD  3  101 FastEthernet0/9                    0
IF  :10010 Fa0/10       100M  FD  3  101 FastEthernet0/1                    0
IF  :10011 Fa0/11       100M  FD  3  101 FastEthernet0/1                    0
IF  :10012 Fa0/12        10M  FD  3    0 FastEthernet0/1                    0
IF  :10013 Fa0/13       100M  FD  3  101 FastEthernet0/1                    0
IF  :10014 Fa0/14       100M  FD  3  101 FastEthernet0/1                    0
IF  :10015 Fa0/15       100M  FD  3  102 FastEthernet0/1                    0
IF  :10016 Fa0/16       100M  FD  3  102 FastEthernet0/1                    0
IF  :10017 Fa0/17       100M  FD  3  103 FastEthernet0/1                    0
IF  :10018 Fa0/18       100M  FD  3  102 FastEthernet0/1                    0
IF  :10019 Fa0/19       100M  FD  3  102 FastEthernet0/1                    0
IF  :10020 Fa0/20        10M  ?   1    0 FastEthernet0/2                    0
IF  :10021 Fa0/21       100M  FD  3  102 FastEthernet0/2                    0
IF  :10022 Fa0/22        10M  ?   1    0 FastEthernet0/2                    0
IF  :10023 Fa0/23       100M  FD  3  102 FastEthernet0/2                    0
IF  :10024 Fa0/24        10M  FD  3    0 FastEthernet0/2                    0
IF  :10101 Gi0/1       1000M  FD  3    0 GigabitEthernet                    0
IF  :10102 Gi0/2         10M  ?   0    0 GigabitEthernet                    0
IF  :10501 Nu0        10000M  -   3    0 Null0                              0

IF Alias:
Quote
1: "" 10001: "802.1x" 10002: "dvr 1 20090723 " 10003: "802.1x" 10004: "" 10005: "" 10006: "" 10007: "" 10008: "" 10009: "" 10010: "" 10011: "" 10012: "" 10013: "" 10014: "" 10015: "mbp fixed staff" 10016: "" 10017: "" 10018: "abs fixed staff" 10019: "" 10020: "" 10021: "" 10022: "" 10023: "" 10024: "" 10101: "" 10102: "" 10501: ""
Alias index:
Quote
1.1: 10001 1.2: 10002 1.3: 10003 1.4: 10004 1.5: 10005 1.6: 10006 1.7: 10007 1.8: 10008 1.9: 10009 1.10: 10010 1.11: 10011 1.12: 10012 1.13: 10013 1.14: 10014 1.15: 10015 1.16: 10016 1.17: 10017 1.18: 10018 1.19: 10019 1.20: 10020 1.21: 10021 1.22: 10022 1.23: 10023 1.24: 10024 1.25: 10101 1.26: 10102

Do I need to change that  Alias Index or something?

Cheers Al

rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2687
    • View Profile
    • NeDi
Re: Nedi 321 alias problem
« Reply #1 on: November 23, 2013, 08:53:52 AM »
Add .1 to alias index, but I suspect it might need more work on stacks...
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo

Al

  • Guest
Re: Nedi 321 alias problem
« Reply #2 on: November 26, 2013, 09:38:30 PM »
Tried adding a 1, no improvement. It's just a single switch, no stacking involved. I'll try a few more oid permutations.

Grisu

  • Newbie
  • *
  • Posts: 12
    • View Profile
Re: Nedi 321 alias problem
« Reply #3 on: November 28, 2013, 10:57:44 AM »
Hi,
had the same problem
Delete the entry in the field "Alias ​​Index" and it works.

Al

  • Guest
Re: Nedi 321 alias problem
« Reply #4 on: November 28, 2013, 08:38:24 PM »
Cheers Grisu, that worked.

rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2687
    • View Profile
    • NeDi
Re: Nedi 321 alias problem
« Reply #5 on: November 29, 2013, 06:17:22 AM »
ok, I'll amend the .def...
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo