Welcome, Guest. Please login or register.

Author Topic: NeDi 1.0.9 Beta test  (Read 23074 times)

rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2558
    • View Profile
    • NeDi
Re: NeDi 1.0.9 Beta test
« Reply #30 on: October 09, 2013, 06:46:44 PM »
Got, it. Was one of those "optimizations". It works if you select population...but I fixed it now...tx
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo

msbs

  • Guest
Re: NeDi 1.0.9 Beta test
« Reply #31 on: October 10, 2013, 12:00:49 PM »
Thx Remo.

I've setup "latency-warn" at 300ms but NeDi is still warning at 100ms:
Latency 176ms exceeds threshold of 100ms

There's a warning at bottom of Nodes-Status:
Warning: mysql_fetch_row(): 22 is not a valid MySQL result resource in /opt/nedi/html/inc/libdb-mysql.php on line 33


rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2558
    • View Profile
    • NeDi
Re: NeDi 1.0.9 Beta test
« Reply #32 on: October 10, 2013, 07:02:10 PM »
>I've setup "latency-warn" at 300ms but NeDi is still warning at 100ms:
Good one! Fixed, tx :)

>There's a warning at bottom of Nodes-Status:
Do you see this everytime? Can you add the surrounding html source?
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo

msbs

  • Guest
Re: NeDi 1.0.9 Beta test
« Reply #33 on: October 11, 2013, 06:54:12 AM »
>There's a warning at bottom of Nodes-Status:
Do you see this everytime? Can you add the surrounding html source?
Every time I open or refresh Node-Status.php

Code: [Select]
</tbody></table>
<table class="content">
<tbody><tr class="dsk2"><td>2 IF Change</td></tr>
</tbody></table>

</td></tr></tbody></table>

<br>
<b>Warning</b>:  mysql_fetch_row(): 22 is not a valid MySQL result resource in <b>/opt/nedi/html/inc/libdb-mysql.php</b> on line <b>33</b><br>
<p>
</p><div id="footer" class="dsk1">
2001-2013 Remo Rickli &amp; contributors
</div>


</body></html>

rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2558
    • View Profile
    • NeDi
Re: NeDi 1.0.9 Beta test
« Reply #34 on: October 11, 2013, 07:15:24 PM »
Still can't reproduce this. As admin, click on the lady-bug icon on top right to reveal the queries. You can test it as well by clicking on it...
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo

rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2558
    • View Profile
    • NeDi
Re: NeDi 1.0.9 Beta test
« Reply #35 on: October 12, 2013, 09:13:07 PM »
@pc_sg, check libmon.pm around line 160 and uncomment that MIME line. I can add this as an option, if required...

I've also added a new sms option in nedi.conf...

Here's a warning on more DB changes (yet again, sorry). This time it's due to postgres support for the backend! I hope the flexibility will make up for the pain! BTW, who'd mind seeing a ~ instead of "regexp" in the forms? (Another aspect of postgres) and it it's easier to read for the die hard Unix people amongst us...but let me know, if you have any objections!

Last but not least, D3.js maps got way too cool! It'll allow for whole new view of your network  8)
« Last Edit: October 16, 2013, 06:24:45 PM by rickli »
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo

pc_sg

  • Sr. Member
  • ****
  • Posts: 255
    • View Profile
Re: NeDi 1.0.9 Beta test
« Reply #36 on: October 16, 2013, 02:01:13 PM »
@pc_sg, check libmon.pm around line 160 and uncomment that MIME line. I can add this as an option if, required...
OK, I'll try it, even if I don't understand why this mod may change alert message sending. The case I've pointed out is only that, i my 1.0.9 beta test installation, a check on "unreachable device" doesn't sends alerts, not that NeDi doesn't send alert messages at all.
Anyway, don't worry. When a new beta or (better) a stable release will be available, I'll try it from scratch.
I'm only preoccupied that I may need to reinitalize databases on the "production" servers, loosing a lot of hystorical information.


TIA!


Paolo

Peter@Lichtenberg

  • Newbie
  • *
  • Posts: 20
    • View Profile
Re: NeDi 1.0.9 Beta test
« Reply #37 on: November 05, 2013, 12:04:25 PM »
Hello,

yesterday I installed NeDi 1.09 beta and I see following message at adding my first device. CfgChg and CfgWrt at sysobj/1.3.6.1.4.1.9.1.542.def are defined. Second run with nedi.pl -A "inet_ntoa(devip) regexp '^172.16.x.x'" is ok.

Code: [Select]
$/var/nedi-1.09/nedi.pl -i
...
# First run with message
$/var/nedi-1.09/nedi.pl -a <device>
172.16.x.x    <device>      Use of uninitialized value in string ne at /var/nedi-1.09/inc/libsnmp.pm line 534.
...
END :Took 0 minutes

# Second run without message
$/var/nedi-1.09/nedi.pl -A "inet_ntoa(devip) regexp '^172.16.x.x'"
...
END :Took 0 minutes

Any hints?

 Peter

rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2558
    • View Profile
    • NeDi
Re: NeDi 1.0.9 Beta test
« Reply #38 on: November 11, 2013, 06:41:55 PM »
That's a new feature to check whether a config was changed after writing to flash and if NeDi's backup is still current. Compare with other .defs to find the right OIDs. ProCurve devices don't seem to provide this info...

@pc_sg, I've improved the "changing module" problem. However it also happens for other SNMP queries, if the device is busy. I try to fix this...
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo

rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2558
    • View Profile
    • NeDi
Re: NeDi 1.0.9 Beta test
« Reply #39 on: November 18, 2013, 12:23:57 AM »
Final RC is out. Have fun!

It's full version is nedi-1.0.8-321! I remember earlier discussions, but it'll change to nedi-1.0.9-xy after the actual 1.0.9 release...
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo

pc_sg

  • Sr. Member
  • ****
  • Posts: 255
    • View Profile
Re: NeDi 1.0.9 Beta test
« Reply #40 on: November 18, 2013, 01:57:36 PM »
Final RC is out. Have fun!

It's full version is nedi-1.0.8-321! I remember earlier discussions, but it'll change to nedi-1.0.9-xy after the actual 1.0.9 release...


Good!
Immediately in try!


BTW, a strange elipse compare on two devices. Have a look in attached snapshot (one of the involved devices).


Have it a undocumented meaning?


TIA!


Paolo

harry

  • Full Member
  • ***
  • Posts: 125
    • View Profile
Re: NeDi 1.0.9 Beta test
« Reply #41 on: November 19, 2013, 12:14:09 AM »
Hi Remo,
Aruba device discovery is responding with this message screenshot attached.

Congratulations and thanks Heap on new version of NEDI.

I am in process of testing this new RC and will provide feedback within few days.

Thanks and Regards,
Harry.



rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2558
    • View Profile
    • NeDi
Re: NeDi 1.0.9 Beta test
« Reply #42 on: November 19, 2013, 06:29:33 AM »
Hm, seems to be related to the SNMP error you have at the beginning. Did that work better with oh8?

pc_sg that's a loop! Add IF names or check the links in Devices-Status...
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo

pc_sg

  • Sr. Member
  • ****
  • Posts: 255
    • View Profile
Re: NeDi 1.0.9 Beta test
« Reply #43 on: November 19, 2013, 08:34:14 AM »

pc_sg that's a loop! Add IF names or check the links in Devices-Status...
Yes, was a loop!
But in past release this was shown near the interface description in the interfaces table in the device-status page. And now is shown on the top, in the links table.
Anyway, now is a fake, because this loop was solved some time (month) ago.
Is there a way to clear this "situation"?


Thanks!


Edit1:
tested SMS send using dedicated SMTP server.
Strange, but "moni.pl" crashes with this error: "Can't call method "mail" on an undefined value at /var/nedi/inc/libmon.pm line 206."
The line is exactly the same first line of standard mail sending routine, i.e. "$smtp->mail($misc::mailfrom) || &ErrSMTP($smtp,"From");"

Unluckily, I've lost my roughly modified SMS send routine... a little distraction and ... sorry!

Edit2:
may be missing SMTP SMS server initialization ? Like in line 146 of libmon.pm ?
I don't see any initialization of this second server.
Another doubt is about line 209. Now is "$smtp->datasend("To:Mobile#\n");" but I think that should be something like "$smtp->datasend("To:$main::usr{$u}{ph}\n");"

Paolo
« Last Edit: November 19, 2013, 01:25:51 PM by pc_sg »

harry

  • Full Member
  • ***
  • Posts: 125
    • View Profile
Re: NeDi 1.0.9 Beta test
« Reply #44 on: November 20, 2013, 11:42:17 PM »
Hi Remo,

yes it was SNMP error, now it is not. I had a new model of Aruba controller (3600)and the .def file was not present for the device.

I have created the def file and it is working well now.

Thanks
Harry