Welcome, Guest. Please login or register.

Author Topic: NeDi 1.0.9 Beta test  (Read 20496 times)

rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2526
    • View Profile
    • NeDi
Re: NeDi 1.0.9 Beta test
« Reply #15 on: September 12, 2013, 08:05:18 PM »
On those devices, is lastdiscover less than 90min. ago?
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo

harry

  • Full Member
  • ***
  • Posts: 125
    • View Profile
Re: NeDi 1.0.9 Beta test
« Reply #16 on: September 13, 2013, 01:06:20 AM »
Hi Remo,
No, this morning out of my (256) ios device, 142 ios device were showing last discover time stamp as of 4.00 PM yesterday. i.e after 16 hours.

Does this helps..? or do you need any more information?

Re
Harry

harry

  • Full Member
  • ***
  • Posts: 125
    • View Profile
Re: NeDi 1.0.9 Beta test
« Reply #17 on: September 13, 2013, 02:23:59 AM »
Hi Remo,
One more bug, in  Reports--> Interface Reports--> Netwrok destibution, I get "Node Age [Days]" as attached picture.

Any Idea...?

rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2526
    • View Profile
    • NeDi
Re: NeDi 1.0.9 Beta test
« Reply #18 on: September 13, 2013, 09:14:41 AM »
You should check why it doesn't discover anymore then...

As to the node age days, thought I caught it now, but obivousely it's still happening sometimes. It's a problem with the DB query. I'm gonna look into it...

For some reason certain nodes have lastseen < firstseen, which of course is not possible. Unless NeDi discovers ruptures in the space-time continuum :D You can verify by Report-Nodes -> Summary. Then click on fast nodes and change the = to > in Nodes-List...
« Last Edit: September 14, 2013, 12:02:04 PM by rickli »
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo

harry

  • Full Member
  • ***
  • Posts: 125
    • View Profile
Re: NeDi 1.0.9 Beta test
« Reply #19 on: September 17, 2013, 01:16:59 AM »
Hi Remo,
Just one request if you can incorporate in new version.
The nodes when they change IP, can we have a switch and its port detail with the list of IPS...?

Kind regards,
Harry.

pc_sg

  • Full Member
  • ***
  • Posts: 246
    • View Profile
Re: NeDi 1.0.9 Beta test
« Reply #20 on: September 17, 2013, 02:18:14 PM »
Hi Remo,
as already reported in another message, there is something that I'm not able to configure to make NeDi 1.0.9-240 to send alerts at least as previous version.


I use for test a "non critical" device, that I reboot to simulate a unreachable device (really it is ureachable, until it complete reloading, and it keeps 4 minutes to do it)


Following your advice I set the device monitoring as shown attached.


Rebooted device. Old NeDi (1.0.8) send me alerts (one for unreach, one for recover). 1.0.9 doesn't.
So I've tried to decrease "none reply" from 2 to 1, but in this case I receive an alert message every "pause" time (I use 60 seconds in both NeDi 1.0.8 and 1.0.9 instances)
Ah, in this case, 1.0.9 doesn't sent device recovery alert at all.


May be that I haven't understand how to correctly configure monitoring.


How can I capture any useful debugging info?


TIA!


Paolo


P.S. I've slightly modified the SMS sending routine in libmon.pm to support (roughly) our SMS send server, that is a simple SMTP server (but different from the email SMTP that sends alerts)
I can send you the code, but is only a sort of copy/paste of your SMTP code, with some changes... You can do a much better work, I'm not skilled in PERL programming at all.

rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2526
    • View Profile
    • NeDi
Re: NeDi 1.0.9 Beta test
« Reply #21 on: September 20, 2013, 06:52:52 PM »
Glad your SMS works. I'll look into making a user configurable SMS option...

If you stop monitoring from the GUI and start moni.pl -v in the CLI you should see what happens:

First you need at least one user here:
RUSR:1 entries (groups & 8 AND (phone != "" OR email != "")) read from nedi.users

Then if a mail is queued on a down event:
TRGT:1800-8G      Deps=0    Test=cifs
TEST:10.10.10.6 proto=tcp srv=microsoft-ds fail!
EVNT:CL=moni EL=2 TGT=1800-8G MSG=is down
MLQ :admin 1800-8G is down
EFWD:1 Mail and 0 SMS queued
DOWN:For 2 times, generated 1 alerts

@Harry do you mean in IPtrack or Events? In the latter case, can you write an example messge you'd like to see?

ps. Gonna bin in California soon, so don't expect quick answers :)
« Last Edit: September 20, 2013, 07:02:18 PM by rickli »
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo

harry

  • Full Member
  • ***
  • Posts: 125
    • View Profile
Re: NeDi 1.0.9 Beta test
« Reply #22 on: September 22, 2013, 04:14:51 PM »
in IP track.

rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2526
    • View Profile
    • NeDi
Re: NeDi 1.0.9 Beta test
« Reply #23 on: September 29, 2013, 01:02:01 PM »
Well, that's tracked in iftrack, so I understand it would be nice to have a combined visualization...let me think about that.
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo

pc_sg

  • Full Member
  • ***
  • Posts: 246
    • View Profile
Re: NeDi 1.0.9 Beta test
« Reply #24 on: September 30, 2013, 09:25:49 AM »
Hi Remo,
still something non clear.
Here what I obtain with only the test device monitored, and with uptime and send mail (as in my previous attached image).
Of course, is anonymized :)


Code: [Select]
root@NeDi:~# /var/nedi/moni.pl -v
PERL:Net::DNS::Resolver not available
PERL:Net::NTP not available
PERL:LWP::UserAgent loaded
RMON:1 entries (dev) read from nedi.monitoring
RMON:0 entries (node) read from nedi.monitoring
RUSR:1 entries (groups & 8 AND (phone != "" OR email != "")) read from nedi.users


Initializing Mon Sep 30 08:53:31 2013 --------------
DEPS:Test-Device = -


Building Tree ----------------------------------
TREE:Test-Device   Deps=0


Testing 1 targets in total, Pause 60s ---------------


TRGT:Test-Device   Deps=0    Test=uptime
SNMP:Connect x.x.x.x snmpdomain v2 Tout:5s MaxMS:1472
SNMP:Latency=3ms Uptime=110558872s
UP  :Last status=0
ALRT:0 mails and 0 SMS sent with 0 events
===============================================================================
1 tests on 1 targets took 0s, sleeping 60s


RMON:1 entries (dev) read from nedi.monitoring
RMON:0 entries (node) read from nedi.monitoring
RUSR:1 entries (groups & 8 AND (phone != "" OR email != "")) read from nedi.users


Initializing Mon Sep 30 08:54:31 2013 --------------
DEPS:Test-Device = -


Building Tree ----------------------------------
TREE:Test-Device   Deps=0


Testing 1 targets in total, Pause 60s ---------------


TRGT:Test-Device   Deps=0    Test=uptime
SNMP:Connect x.x.x.x snmpdomain v2 Tout:5s MaxMS:1472
SNMP:Latency=3ms Uptime=110564875s
UP  :Last status=0
ALRT:0 mails and 0 SMS sent with 0 events
===============================================================================
1 tests on 1 targets took 0s, sleeping 60s


RMON:1 entries (dev) read from nedi.monitoring
RMON:0 entries (node) read from nedi.monitoring
RUSR:1 entries (groups & 8 AND (phone != "" OR email != "")) read from nedi.users


Initializing Mon Sep 30 08:55:31 2013 --------------
DEPS:Test-Device = -


Building Tree ----------------------------------
TREE:Test-Device   Deps=0


Testing 1 targets in total, Pause 60s ---------------


TRGT:Test-Device   Deps=0    Test=uptime
SNMP:Connect x.x.x.x snmpdomain v2 Tout:5s MaxMS:1472
ERR :No response from remote host "x.x.x.x"
DOWN:2 For 1 times
ALRT:0 mails and 0 SMS sent with 0 events
===============================================================================
1 tests on 1 targets took 10s, sleeping 50s


RMON:1 entries (dev) read from nedi.monitoring
RMON:0 entries (node) read from nedi.monitoring
RUSR:1 entries (groups & 8 AND (phone != "" OR email != "")) read from nedi.users


Initializing Mon Sep 30 08:56:31 2013 --------------
DEPS:Test-Device = -


Building Tree ----------------------------------
TREE:Test-Device   Deps=0


Testing 1 targets in total, Pause 60s ---------------


TRGT:Test-Device   Deps=0    Test=uptime
SNMP:Connect x.x.x.x snmpdomain v2 Tout:5s MaxMS:1472
ERR :No response from remote host "x.x.x.x"
DOWN:2 For 1 times
ALRT:0 mails and 0 SMS sent with 0 events
===============================================================================
1 tests on 1 targets took 10s, sleeping 50s


RMON:1 entries (dev) read from nedi.monitoring
RMON:0 entries (node) read from nedi.monitoring
RUSR:1 entries (groups & 8 AND (phone != "" OR email != "")) read from nedi.users


Initializing Mon Sep 30 08:57:31 2013 --------------
DEPS:Test-Device = -


Building Tree ----------------------------------
TREE:Test-Device   Deps=0


Testing 1 targets in total, Pause 60s ---------------


TRGT:Test-Device   Deps=0    Test=uptime
SNMP:Connect x.x.x.x snmpdomain v2 Tout:5s MaxMS:1472
ERR :No response from remote host "x.x.x.x"
DOWN:2 For 1 times
ALRT:0 mails and 0 SMS sent with 0 events
===============================================================================
1 tests on 1 targets took 11s, sleeping 49s


RMON:1 entries (dev) read from nedi.monitoring
RMON:0 entries (node) read from nedi.monitoring
RUSR:1 entries (groups & 8 AND (phone != "" OR email != "")) read from nedi.users


Initializing Mon Sep 30 08:58:31 2013 --------------
DEPS:Test-Device = -


Building Tree ----------------------------------
TREE:Test-Device   Deps=0


Testing 1 targets in total, Pause 60s ---------------


TRGT:Test-Device   Deps=0    Test=uptime
SNMP:Connect x.x.x.x snmpdomain v2 Tout:5s MaxMS:1472
ERR :No response from remote host "x.x.x.x"
DOWN:2 For 1 times
ALRT:0 mails and 0 SMS sent with 0 events
===============================================================================
1 tests on 1 targets took 10s, sleeping 50s


RMON:1 entries (dev) read from nedi.monitoring
RMON:0 entries (node) read from nedi.monitoring
RUSR:1 entries (groups & 8 AND (phone != "" OR email != "")) read from nedi.users


Initializing Mon Sep 30 08:59:31 2013 --------------
DEPS:Test-Device = -


Building Tree ----------------------------------
TREE:Test-Device   Deps=0


Testing 1 targets in total, Pause 60s ---------------


TRGT:Test-Device   Deps=0    Test=uptime
SNMP:Connect x.x.x.x snmpdomain v2 Tout:5s MaxMS:1472
ERR :No response from remote host "x.x.x.x"
DOWN:2 For 1 times
ALRT:0 mails and 0 SMS sent with 0 events
===============================================================================
1 tests on 1 targets took 10s, sleeping 50s


RMON:1 entries (dev) read from nedi.monitoring
RMON:0 entries (node) read from nedi.monitoring
RUSR:1 entries (groups & 8 AND (phone != "" OR email != "")) read from nedi.users


Initializing Mon Sep 30 09:00:31 2013 --------------
DEPS:Test-Device = -


Building Tree ----------------------------------
TREE:Test-Device   Deps=0


Testing 1 targets in total, Pause 60s ---------------


TRGT:Test-Device   Deps=0    Test=uptime
SNMP:Connect x.x.x.x snmpdomain v2 Tout:5s MaxMS:1472
SNMP:Latency=3ms Uptime=27883s
UP  :Last status=0
ALRT:0 mails and 0 SMS sent with 0 events
===============================================================================
1 tests on 1 targets took 0s, sleeping 60s

As you can see, the device is not reachable for many times, but no alerts are generated.


Why?
What can I do?
How can I really check what is wrong?
How can I debug it?


Of course, old 1.0.8 is still sending correct alerts.


Thanks!


Paolo




msbs

  • Newbie
  • *
  • Posts: 13
    • View Profile
Re: NeDi 1.0.9 Beta test
« Reply #25 on: October 04, 2013, 01:54:05 PM »
Hi Remo,

I'm unable to discover SNMP v3 devices with 1.0.9 but same devices with version 1.0.7 works fine.

Using internet explorer 8/9 I can't see the header menu but with internet explorer 10 works fine.

rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2526
    • View Profile
    • NeDi
Re: NeDi 1.0.9 Beta test
« Reply #26 on: October 04, 2013, 06:37:25 PM »
pc_sg I really don't know what's wrong there...

msbs, I've tested v3 and worked in my case. Try to narrow it down by checking community settings and missing dependencies. I know there was a problem with the default theme and IE <10
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo

msbs

  • Newbie
  • *
  • Posts: 13
    • View Profile
Re: NeDi 1.0.9 Beta test
« Reply #27 on: October 07, 2013, 07:41:01 AM »
msbs, I've tested v3 and worked in my case. Try to narrow it down by checking community settings and missing dependencies. I know there was a problem with the default theme and IE <10

Thanks remo, I was missing dependencies.
 Version 1.0.7 informs about missing dependencies but 1.0.9 doesn't:
ERR :SNMPv3 support unavailable (Required module Digest/SHA1.pm not found)

pc_sg

  • Full Member
  • ***
  • Posts: 246
    • View Profile
Re: NeDi 1.0.9 Beta test
« Reply #28 on: October 07, 2013, 08:00:50 AM »
pc_sg I really don't know what's wrong there...
Me too...  ;)
Don't worry, if you can't teach me how to debug this "case", I'll wait next beta and reinstall the test server from scratch, so no doubt about corrupted data.


Thanks anyway!


Paolo

msbs

  • Newbie
  • *
  • Posts: 13
    • View Profile
Re: NeDi 1.0.9 Beta test
« Reply #29 on: October 08, 2013, 01:36:16 PM »
Hi Remo,

If I don't select all column fields in Devices-Vlans the results aren't correctly sorted. For example I see contact instead of location and Device type instead of Vlan Name.

Thanks!
msbs