Welcome, Guest. Please login or register.

Author Topic: Bintec - no interfaces in 1.0.8  (Read 1862 times)

rthrl

  • Guest
Bintec - no interfaces in 1.0.8
« on: May 24, 2013, 11:27:11 AM »
after upgrading from 1.0.7, where all router interfaces in bintec devices where found, in 1.0.8 the interfaces are gone, discovery only founds an interface "0" and that's all.

Output of manual discovery:

Code: [Select]
lxopnedi:/opt/nedi # ./nedi.pl -vop -t 90.1.1.1
Started with relative path!
PTY :Loaded
LWP :Loaded
OUI :21798 NIC vendor entries read
RDEV:165 devices read from nedi.devices
RADDR:5167 MAC, 133 IP and 0 IPv6 addresses read.
RLNK:0 links (WHERE linktype = "STAT") read from nedi.links
RMON:0 entries (dev) read from nedi.monitoring
RMON:0 entries (node) read from nedi.monitoring
RUSR:0 entries (groups & 8 AND (phone != "" OR email != "")) read from nedi.users
SEED:90.1.1.1 added for testing
MAIN:Ignoring 1 thread for testing

DP-OUI-Discovery (1.0.8-116) with 1 seed at Fri May 24 11:23:10 2013
-------------------------------------------------------------------------------
Device                          Status                          Todo/Done-Time
===============================================================================

Discover     ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Identify testing -------------------------------------------------------
SNMP:Connect 90.1.1.1 XXXXX v1 Tout:2s MaxMS:1472
IDNT:Name = ROUTER1
SOBJ:Reading 1.3.6.1.4.1.272.4.158.82.78.66.48.0.0.def
SYS :Con=
SYS :OS=other SV=14 TY=RXL12500
DISC:no skipif policy using -S ()

Enterprise   ------------------------------------------------------------------
SNMP:Connect 90.1.1.1 XXXXXX v1 Tout:2s MaxMS:1472
SERN:Serial number is RNBDIC012100070
BOOT:Image is 26 00:00:00
TYPE:Using PhysicalModelName RXL12500
CPU :Load is 1%
TEMP:Temperature is 35 Degrees Celcius

Interfaces   ------------------------------------------------------------------
RIF :1 IF read (WHERE device = "ROUTER1") from nedi.interfaces
SNMP:Connect 90.1.1.1 XXXXXX v1 Tout:5s MaxMS:1472
IF  :Walking speed
IF  :Walking 32bit counters
IF  :Walking errors
IF  :Walking discards
IF  :Walking description
IF  :Walking type
IF  :Walking alias index
IF  :Walking vlan
ERR :Vlan Requested entries are empty or do not exist
IF  :Walking admin status
IF  :Walking oper status
IF  :Index Name         Spd Dup St Pvid Description      Alias            PoE
IF  :    0 0             0M  -   3    0 REFUSE                             0W

IfAddresses  ------------------------------------------------------------------
IFIP:No useip policy set, always using discovered IPs
SNMP:Connect 90.1.1.1 XXXXXX v1 Tout:2s MaxMS:1472
IFIP:Walking old address table

Modules      ------------------------------------------------------------------
SNMP:Connect 90.1.1.1 XXXXXX v1 Tout:2s MaxMS:1472
MOD :Walking module description
MOD :Walking module HW
MOD :Walking module FW
MOD :Walking module model
MOD+:1.1.3-1 BIQ-SYS/100BT BIQ-1000BT
MOD+:0.5.1-0 SEC/8526E FM-CRYPT
MOD+:0.0.0-0 RXL12500 (16/2048 MB) RXL12500
MOD+:1.0.2-1 BIQ-SYS/100BT BIQ-1000BT
MOD+:2.0.4-2 BIQ-ISDN/BRI BIQ-BRI

Prepare (CLI)  ----------------------------------------------------------------
DISC:Cli arp = not implemented

Arp (SNMP)   ------------------------------------------------------------------
SNMP:Connect 90.1.1.1 XXXXXX v1 Tout:2s MaxMS:1472
ARPS:0 IP and 0 IPv6 entries found

DevRRD       ------------------------------------------------------------------
DRRD:CPU=1 MEM=0 TEMP=35 CUS=0
DRRD:IFName   Inoct    Outoct   Inerr  Outerr Indis  Outdis Inbcst Stat
DRRD:0               0        0      0      0      0      0      0    3
DISC:ToDo/Done-Time                                                        0/1-1s
===============================================================================
MAIN:1 devices discovered
RNOD:2811 nodes read () from nedi.nodes

BuildNod     ------------------------------------------------------------------
BNOD:FINISHED 0 IP and 0 non-IP nodes processed
END :Took 0 minutes


any help is appreciated

thanks
Robert

rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2687
    • View Profile
    • NeDi
Re: Bintec - no interfaces in 1.0.8
« Reply #1 on: May 24, 2013, 06:55:19 PM »
Do you have anything set in the .def's StartX or EndX?
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo

rthrl

  • Guest
Re: Bintec - no interfaces in 1.0.8
« Reply #2 on: May 27, 2013, 10:20:25 AM »
no, i tried that after finding no interfaces, but either way nothings reported.

rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2687
    • View Profile
    • NeDi
Re: Bintec - no interfaces in 1.0.8
« Reply #3 on: May 28, 2013, 03:58:43 PM »
Can you try tcpdump or Wireshark to see if the device actually returns all interfaces via SNMP? You could change the maxrep value in inc/libsnmp.pm function Interfaces(), to see whether it makes a difference...
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo