Welcome, Guest. Please login or register.

Author Topic: "Use of uninitialized value in subroutine" during discovery  (Read 2320 times)

fgr

  • Guest
"Use of uninitialized value in subroutine" during discovery
« on: April 15, 2013, 05:19:25 PM »
Hi,

I have the Problem that I get errors during discovery of some routers which leads to duplicate interfaces in the database (not for every interface on the problematic routers but for some). It seems like it has something to do with the "-F" Switch: If I use the Switch it works for the problematic routers but then fails on other ones. I have attached a log with a test run on two Routers - one working with -F, the other one working only without -F. (IP-Adresses and some other information is scrambled in the log)

I also found this thread, but "ifindex persist" can't imho be the problem because it works (or not) depending on the -F Switch: http://forum.nedi.ch/index.php?topic=1311.msg4873#msg4873

Best regards,

fgr
« Last Edit: April 15, 2013, 10:11:29 PM by rickli »

rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2786
    • View Profile
    • NeDi
Re: "Use of uninitialized value in subroutine" during discovery
« Reply #1 on: April 15, 2013, 10:26:11 PM »
Not sure, if your rather short sysnames (I like that, though) cause this. Would you mind trying nedi-103.tgz and check, whether it still happens?
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo

fgr

  • Guest
Re: "Use of uninitialized value in subroutine" during discovery
« Reply #2 on: April 16, 2013, 09:44:30 AM »
Hi!

I tried 1.0.3 and it seems to work without problems! Should I downgrade to that version or will you release a patch shortly for 1.0.7?

Best regards,
fgr

pc_sg

  • Guest
Re: "Use of uninitialized value in subroutine" during discovery
« Reply #3 on: April 16, 2013, 04:25:04 PM »
Is not a downgrade!

Is a 1.0.8 prerelease (or beta?), build 103, as you can see in System - NeDi

"/var/nedi/nedi.pl version 1.0.8-103 calling Getopt::Std::getopts " ...

fgr

  • Guest
Re: "Use of uninitialized value in subroutine" during discovery
« Reply #4 on: April 16, 2013, 04:34:18 PM »
Ah, I see! Thanks for the clue! So @Remo: Is that version ready for production or what's to status of it?

rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2786
    • View Profile
    • NeDi
Re: "Use of uninitialized value in subroutine" during discovery
« Reply #5 on: April 16, 2013, 09:40:51 PM »
It'll hopefully the final 1.0.8, if no bugs are detected within the next days...
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo

fgr

  • Guest
Re: "Use of uninitialized value in subroutine" during discovery
« Reply #6 on: April 18, 2013, 09:27:34 AM »
Okay, hopefully it's released soon, so we get rid of this strange behaviour! :-) Thank you very much so far!