Welcome, Guest. Please login or register.

Author Topic: Can't find libcli-netssh.pm  (Read 3078 times)

lisa66

  • Guest
Can't find libcli-netssh.pm
« on: October 10, 2012, 11:38:02 AM »
Hello everybody

I install nedi on centos 6.3 64 bits. I can't find libcli-netssh.pm even if i install perl-Net-SSH2 perl-Net-SSH-Expect perl-Net-OpenSSH-Parallel perl-IPC-Session perl-Net-SSH-Perl perl-Net-SSH perl-Net-OpenSSH.

Any suggestion ?

Thank you for your answer.

Lisa

rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2763
    • View Profile
    • NeDi
Re: Can't find libcli-netssh.pm
« Reply #1 on: October 10, 2012, 07:33:37 PM »
That's deprecated. You should have libcli-iopty.pm instead. Which nedi version did you install?
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo

lisa66

  • Guest
Re: Can't find libcli-netssh.pm
« Reply #2 on: October 11, 2012, 09:40:22 AM »
I install NEDI version 1.0.7

rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2763
    • View Profile
    • NeDi
Re: Can't find libcli-netssh.pm
« Reply #3 on: October 11, 2012, 05:50:45 PM »
Ok, but with an older config perhaps? Make sure that:


# CLI library to use
clilib
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo

lisa66

  • Guest
Re: Can't find libcli-netssh.pm
« Reply #4 on: October 12, 2012, 10:34:38 AM »
No i don't have an older config. It's a first install.

rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2763
    • View Profile
    • NeDi
Re: Can't find libcli-netssh.pm
« Reply #5 on: October 12, 2012, 09:50:45 PM »
Ok I looked at the docs for CentOS and they're referring to an older installation. Do you have a package like "perl-IO-TTY"? I assume everything but ssh works?
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo

lisa66

  • Guest
Re: Can't find libcli-netssh.pm
« Reply #6 on: October 15, 2012, 08:30:16 AM »
I install  perl-IO-Pty-Easy. But it doesn't resole my problem.

rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2763
    • View Profile
    • NeDi
Re: Can't find libcli-netssh.pm
« Reply #7 on: October 15, 2012, 05:08:08 PM »
Sorry, the entry about the config got cut-off. You should have:

# CLI library to use
clilib      IoPty

And make sure you're looking at the right nedi.conf (e.g. in /etc or /var/nedi)
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo

lisa66

  • Guest
Re: Can't find libcli-netssh.pm
« Reply #8 on: October 16, 2012, 10:30:22 AM »
Thank you. My problem is solve.

I had
# CLI library to use
clilib      IoPty

in /etc/nedi.conf