Welcome, Guest. Please login or register.

Author Topic: Config Backup with procurve HP-5406zl  (Read 5070 times)

harry

  • Full Member
  • ***
  • Posts: 131
    • View Profile
Config Backup with procurve HP-5406zl
« on: May 23, 2012, 01:35:41 AM »
Hello
My backup with Procurve is working fine(for other models and same username password). Only this model is giving the following error while scaning.
Prepare (CLI) ----------------------------------------------------------------
SSH :.:22 Tout:2s OS:ProCurve EN:(.+?)#\s?(\x1b\[[;\?0-9A-Za-z]+)+$
 PTY :Forking ssh -o 'StrictHostKeyChecking no' -l . 10.36.147.254
 CLI1:Matched any key, sending ctrl-Y
CLI4:Matched to continue[?25h[?6l[?7l[?25h2395-LRCS-LR0002-SW01-Core-254> [?25h (or gen. prompt with enpass & enable cmd), enabling
CLI7:Matched Password:, sending password
 Use of uninitialized value $match in pattern match (m//) at /var/nedi/inc/libcli-iopty.pm line 523.
 ERR :pattern match timed-out
 DISC:Cli config = pattern match timed-out
 DISC:Config backup error: pattern match timed-out
 MLQ :admin+ 2395-LRCS-LR0002-SW01-Core-254: Config backup error: pattern match timed-out DevRRD ------------------------------------------------------------------
Is there anyone who can backup this model of switch?
any one can help me to resolve this problem?

Regards,
Harry

raider82

  • Jr. Member
  • **
  • Posts: 91
    • View Profile
Re: Config Backup with procurve HP-5406zl
« Reply #1 on: May 30, 2012, 09:22:00 AM »
Yes. I have backups for those devices.

The configuration is (I think it's the standard that comes with NeDi):
$cmd{'ProCurve'}{'ropr'} = '(.+?)>\s?(\x1b\[[;\?0-9A-Za-z]+)+$';                                        # Match them nasty Escapes!
$cmd{'ProCurve'}{'enpr'} = '(.+?)#\s?(\x1b\[[;\?0-9A-Za-z]+)+$';
$cmd{'ProCurve'}{'enab'} = 'enable';
$cmd{'ProCurve'}{'conf'} = 'show run';
$cmd{'ProCurve'}{'strt'} = '^Running';
$cmd{'ProCurve'}{'page'} = 'no page';

I suggest you debug your output by adding print commands in libcli-iopty.pm.
print "PRE :$pre\nMTCH:$match\n";

tristanbob

  • Full Member
  • ***
  • Posts: 159
    • View Profile
Re: Config Backup with procurve HP-5406zl
« Reply #2 on: May 30, 2012, 06:02:21 PM »
I have several pattern match errors on my Cisco gear as well.  The odd thing is that I have other devices of these same models that do not get the timeout.  They are all accessible on the same gigabit backbone.

WS-C2950-48T
WS-C3750
WS-C3560CG-8PC-S
WS-C2960S-48LPS-L
WS-C3560G-48PS

Any idea what would cause these timeouts on models that work elsewhere?  I am going to increase the timeout from 5 seconds (my previous setting) to 10 seconds.

# Timeout for SNMP and telnet communication. Extra time will be added
# for certain tasks (e.g. building the config).  Default = 2
timeout         10

Tristan
Please visit "Other"->"Invoices" on your NeDi installation to make an annual contribution and support Nedi!

rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2777
    • View Profile
    • NeDi
Re: Config Backup with procurve HP-5406zl
« Reply #3 on: June 01, 2012, 11:57:08 PM »
This is the last time I'll post this  :) Add -d and open 2 more windows with tail -f on input and output.log. Most likely the prompt is different (or the ProCurve box generates escape sequences I don't catch yet). The log should reveal what exactly is being transmitted and received...
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo