Welcome, Guest. Please login or register.

Author Topic: Re: NeDi 1.0.7 bug  (Read 16095 times)

raider82

  • Jr. Member
  • **
  • Posts: 91
    • View Profile
Re: NeDi 1.0.7 bug
« Reply #30 on: April 02, 2012, 08:43:30 AM »
However I suspect the hourly run to mess up your graphs. Try running it with -So to skip topgraphs...
I have stopped the hourly runs about two weeks ago. Nevertheless, the effect is still the same: in the morning, I do not see any graphs. After the discovery, they re-appear and show correct data.

rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2691
    • View Profile
    • NeDi
Re: NeDi 1.0.7 bug
« Reply #31 on: April 03, 2012, 10:24:24 PM »
Bummer, running out of ideas...  I'll try to reproduce a daily graph, maybe something I've overlooked!
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo

raider82

  • Jr. Member
  • **
  • Posts: 91
    • View Profile
Re: NeDi 1.0.7 bug
« Reply #32 on: April 20, 2012, 09:25:45 AM »
I thought it might help: attached a graph that shows the time since I began with the discovery. It seems all values are available. But before today's discovery, the same graph has been empty.

rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2691
    • View Profile
    • NeDi
Re: NeDi 1.0.7 bug
« Reply #33 on: April 20, 2012, 06:26:57 PM »
Maybe it's related to the aggregation, since your running it daily. you can zoom in, right?
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo

raider82

  • Jr. Member
  • **
  • Posts: 91
    • View Profile
Re: NeDi 1.0.7 bug
« Reply #34 on: April 23, 2012, 09:51:21 AM »
Yes, I can zoom in.

rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2691
    • View Profile
    • NeDi
Re: NeDi 1.0.7 bug
« Reply #35 on: April 23, 2012, 07:27:42 PM »
Glad you're not missing any data after all  :)
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo

raider82

  • Jr. Member
  • **
  • Posts: 91
    • View Profile
Re: NeDi 1.0.7 bug
« Reply #36 on: April 24, 2012, 02:21:16 PM »
Yes. Everything is there. I just do not see it 24x7 ;-)

guillaume

  • Guest
Re: NeDi 1.0.7 bug
« Reply #37 on: January 17, 2013, 12:07:51 PM »
The problem has it been resolved because I encounter the same symptoms ??
Sometimes I have a graph which appears 1 hour, then it stops grapher ...

And when I pass my mouse on the canvas I have the last value of my CPU or Memory...

Edit : Small changes...

This morning, I realize that I have a graph that has appeared only between 1am on 01/17 and 1am on 01/18.
At 1am I have my crontab that starts the discovery (seedlist with the option-B). I have charts with 24 hours late ??

Second observation, I have a constant value, which is not normal ...

An idea?


« Last Edit: January 18, 2013, 09:17:09 AM by guillaume »

rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2691
    • View Profile
    • NeDi
Re: NeDi 1.0.7 bug
« Reply #38 on: January 19, 2013, 02:05:29 AM »
Well Bordeaux should have constant memory, right? Ok, back to networking, what is it? Does the .def show the correct OID?
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo

guillaume

  • Guest
Re: NeDi 1.0.7 bug
« Reply #39 on: January 21, 2013, 11:02:45 AM »
Bordeaux is a Cisco 2921 Router. The .def file is good.

If we consider Bordeaux should have constant memory... If I take an other graph.. For example the WAN interface. The traffic shouldn't be constant ... Right ?

(Reminder : My crontab is schedule every day at 1:00 am)

So, look the attachments :

  • First attachment: It's my graph since the 1st discover (01/16). Graph change only at 1:00am
  • Second attachment : If you zoom in on one day, we see that the graph is constant traffic ...

One has the impression that graph with a single value.
In addition, the graphs appear only after the schedule discovery network.

An idea?


pc_sg

  • Sr. Member
  • ****
  • Posts: 265
    • View Profile
Re: NeDi 1.0.7 bug
« Reply #40 on: January 21, 2013, 11:19:21 AM »
Sorry, guillaume, are you doing only a daily scheduled discovery, not hourly?

guillaume

  • Guest
Re: NeDi 1.0.7 bug
« Reply #41 on: January 21, 2013, 01:34:28 PM »
Hi PC_sg,

Yes I do a daily schedule discovery. (At 1:00 am).

It's a problem ?

I think this is enough for my network.

pc_sg

  • Sr. Member
  • ****
  • Posts: 265
    • View Profile
Re: NeDi 1.0.7 bug
« Reply #42 on: January 21, 2013, 01:46:03 PM »
Absolutely not, but we can wait a Remo reply if this "sparse" schedule may causa any inconvenience...

rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2691
    • View Profile
    • NeDi
Re: NeDi 1.0.7 bug
« Reply #43 on: January 21, 2013, 06:03:23 PM »
You're correct Paolo, the resolution of your graphs will be the discovery intervall of nedi. That's why you still should use tools like Cacti for specific interfaces, if you want 5 min. intervalls. NeDi on the other hand will generate graphs for all interfaces (and device stats) on your network...
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo

guillaume

  • Guest
Re: NeDi 1.0.7 bug
« Reply #44 on: January 22, 2013, 01:02:30 PM »
Hum Ok,

So Nedi don't graph in real time. Thank you for your replies guys !

Rickli, please, can you tell me what's is the default password when I create a nedi user ?