Welcome, Guest. Please login or register.

Author Topic: SNMP Discovery issues  (Read 3692 times)

smooter

  • Guest
SNMP Discovery issues
« on: January 09, 2012, 04:55:38 PM »
Yes, I am a total newb, and I bow to all those that knew this stuff by default, but....

Trying to do SNMP discovery, and I keep getting errors.  I am sure it is something to do with my settings in the nedi.conf file regarding SNMP, but I have tried every combination I can think of, and nothing seems to work.

Error message:  No Response From Remote Host

I can see it using the correct SNMP community (for Read Only, as that is all I have configured at this point), and it is querying the gateway (which is what I want it to do), but when I put the RO password in, it keeps saying it doesn't recognize the protocol (and puts the password I am using in  as the protocol).

So I guess the real question is:  What is the proper config column by column for SNMP settings in nedi.conf if it is SNMP v2, and the community is "goober" and the password is "g00ber1!"?

There are 6 columns (best I can tell) separated by tabs:

community   name   aprot   apass   pprot   ppass

where would my community name username and password go?

Thanks,

smooter

smooter

  • Guest
Re: SNMP Discovery issues
« Reply #1 on: January 18, 2012, 01:08:52 PM »
 :-X

Hate to be that guy, but I notice that pretty much every other question is getting an answer here, but mine has tons of views and not responses.

Something I am missing?

I do appreciate any and all assistance.

smooter

rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2786
    • View Profile
    • NeDi
Re: SNMP Discovery issues
« Reply #2 on: January 18, 2012, 09:36:53 PM »
Not intentional, but I agree more people could respond  :(

As for snmp v2 you'd only need a community. If there's more than argument it gets interpreted as v3!
The line should look like this:

community   goober

Not sure, where you use the password? If it's the cli login, you'd add that to usr like so:

usr   dummy   g00br1!
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo

smooter

  • Guest
Re: SNMP Discovery issues
« Reply #3 on: January 19, 2012, 06:47:31 PM »
Thanks for the reply rickli, I do appreciate it!!

Wow, I would love to be able to describe the blank stare that would describe how lost I am on this config.

Maybe I should include some more info, and that will help folks see through my lack of genius on this issue! :-)

My SNMP Config on my switch/routers is as follows:

snmp-server engineID local 8000000903000011208848C0
snmp-server user g00ber1! g00ber1! v1
snmp-server user g00ber1! g00ber1! v2c
snmp-server community ~goober~ RW
snmp-server community goober! RO
snmp-server user g00ber1! g00ber1! v1
snmp-server user g00ber1! g00ber1! v2c
snmp-server chassis-id Cisco-4510
snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
snmp-server enable traps tty
snmp-server enable traps fru-ctrl
snmp-server enable traps entity
snmp-server enable traps flash insertion removal
snmp-server enable traps vtp
snmp-server enable traps vlancreate
snmp-server enable traps vlandelete
snmp-server enable traps envmon fan shutdown supply temperature status
snmp-server enable traps port-security
snmp-server enable traps rf
snmp-server enable traps config-copy
snmp-server enable traps config
snmp-server enable traps hsrp
snmp-server enable traps ipmulticast
snmp-server enable traps pim neighbor-change rp-mapping-change invalid-pim-message
snmp-server enable traps bridge newroot topologychange
snmp-server enable traps stpx inconsistency root-inconsistency loop-inconsistency
snmp-server enable traps syslog
snmp-server enable traps vlan-membership
snmp-server host 192.168.0.254 ~g00ber1!~

At this point, I am just trying to setup Read Only access to the switches/routers so I can populate NeDi to see what information it can glean.

Here is my NeDi config so far (don't make fun!):


# NeDi 1.0.6 configuration file
#============================================================================
# Device Access
#============================================================================

# Set SNMP communities (preferred ones first).
# If authentication protocol is set, it will be treated as v3
#
#   name   aprot   apass      pprot   ppass
#comm   public
#comm   private
comm   TelhioCU!      TelhioCU!
;comm   initial   md5   ver3pa55   des   ver3pa55
;comm   initial   md5   ver3pa55

# Set SNMP policy for write access:
# 3      = requires SNMP v3 for write access
# 2      = also allow SNMP v2 write access
# commented   = disable write access
snmpwrite   2

Again, help is MUCH appreciated!

Thanks,

smooter

rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2786
    • View Profile
    • NeDi
Re: SNMP Discovery issues
« Reply #4 on: January 20, 2012, 07:40:31 PM »
May I ask why you use comm TelhioCU! when in your config it says goober! ?

Simply try:
comm goober!
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo