Welcome, Guest. Please login or register.

Author Topic: How to disable "Backup Config" for special Devices  (Read 2648 times)

MacBest

  • Newbie
  • *
  • Posts: 11
    • View Profile
How to disable "Backup Config" for special Devices
« on: September 13, 2011, 11:15:20 AM »
Hi there,

I'm testing nedi 1.0.6 at the moment and one of the new features is, that nedi is able to get some information from (VM-Ware) ESX hosts. That quite nice, but I don't want nedi to login an get the Config of these servers.
In the nedi events I can see:
Config backup error: no working user

every time I run my nedi.pl discovery.
So anybody out there who knows how to exclude these "devices" from the "backup config" stuff?
(or can even explain why nedi wan't to get the config if it already knows that there is no login avail)

Greetings from sunny Germany

Jürgen

rickli

  • Administrator
  • Hero Member
  • *****
  • Posts: 2728
    • View Profile
    • NeDi
Re: How to disable "Backup Config" for special Devices
« Reply #1 on: September 14, 2011, 12:06:45 AM »
Good point. It doesn't retry to login with every run, but keeps notifying about the failed login attempt the first time. You could exactly specify which switches you want to have backed up. I prefer doing this just after midnight, thus I've added an example in crontab only backing up devices, where we do have working credentials and skip everything else. This task will be pretty fast and can even run besides any regular discovery:


#3   0 * * *   /var/nedi/nedi.pl -vBA 'login !=""' -SsmgrfpitedobwaOA > /tmp/nedi-0003.bup 2>&1
Please consider Other-Invoices on your NeDi installation for an annual contribution, tx!
-Remo

MacBest

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: How to disable "Backup Config" for special Devices
« Reply #2 on: September 14, 2011, 09:21:32 AM »
WOW!

the -A Option is great! I didn't even realized, that this exists with such great stuff like
selecting special Devices from the DB.

BTW In this context I also removed the "Backup Config Stuff" from my hourly crontab.
I don't know why I didn't done this earlier  :(

Thanks a lot

Jürgen