Welcome, Guest. Please login or register.

Recent Posts

Pages: 1 [2] 3 4 ... 10
Installation / Re: Ubuntu 10.04.1 LTS Nedi using nginx Fix 502 Bad Gateway and 1 issue
« Last post by rickli on January 11, 2019, 03:52:04 PM »
Thanks for the info and feedback :)
I started getting this error, "no matching cipher found".

The fix was to edit;

uncomment the Ciphers line

   Ciphers aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-cbc,3des-cbc

NeDi is so great!

GUI / Monitoring VLAN Traffic for VTAP Interface with SMON?
« Last post by SchmuFoo on January 10, 2019, 01:23:39 PM »

I have configured a few VTAP Interfaces for SMON Monitoring on an Enterasys Switch.

According to..


I should use..


.. for this.

Does NeDi Support this?

NeDi Discovery sees the Interface during discovery as:

Code: [Select]
IF :100099 vtap.0.999 0 - 3 0 IEEE 802.1Q VLA 0
On the Device-Status.php it shows up as Interface with Name: "IEEE 802.1Q VLAN 999 Tap Interface"

But when I open up the rt-popup.php, I can't see the Traffic -> "Cannot get data about interface 1000999"

Code: [Select]
Switch(su)->show smon vlan

Data Source      : vtap.0.999
Status           : Enabled
Last Enable Time : 2019-01-10 11:46:54
Owner            : (none)

Vlan    NonUnicast Packets     NonUnicast Octets         Total Packets          Total Octets
----  --------------------  --------------------  --------------------  --------------------
999                    460                 41572                 60803              10695850


P.S.: I'm also not able to do a normal snmpget for ifInOctets for that interface (Altough I'm not sure why NeDi Discovery says 100099 but rt-popup is mentioning 1000999)

Code: [Select]
X:/usr/share/snmp/mibs # snmpget -v2c -c X ifInOctets.1000999
IF-MIB::ifInOctets.1000999 = No Such Instance currently exists at this OID

X:/usr/share/snmp/mibs # snmpget -v2c -c X ifInOctets.100099
IF-MIB::ifInOctets.100099 = No Such Instance currently exists at this OID
Discovery / Re: Exclude Nodes from LAG Interfaces?
« Last post by SchmuFoo on January 09, 2019, 02:08:10 PM »
Does the lastseen timestamp still get updated on those nodes? When you add debugging (-db), you should see lines like this:

DBG :$mc on $if vl$vl ignored due to NOP

Oh you have right, I didn't realize that the timestamp was not updated any longer. In the meantime the wrong mapping is gone on my test-switch (I think after round about 30 days).

Is there a manuall way to "re-map" old entrys, without deleting the Nodes? I would like to keep the Node Details and History, but want to get rid of the old wrong mappings.
Progress update
It looks after upgrading bionic is missing and maybe some other stuff which is required to handle netflow.

I was getting stat() error '/var/nfdump/default/nfcapd.201901051315': File not found!
Empty file list. No files to process
when I ran ./flowi.pl from the nedi folder.

checking the perldoc flowi.pl it shows that you need to install the following
 sudo apt-get install gcc make flex bison libbz2-dev libpcap-dev
 sudo apt-get install nfdump - nfdump was not missing.

Bionic was clearly missing. Still not working though.

Needed to run
sudo nfcapd -e -w -D -j -l/var/nfdump/default -p 2055  -- note changing the path in nedi config to match /var/cache/nfdump didn't work for me so I just modified the service start folder.
Files are showing up in /var/nfdump/default now
Installation / Ubuntu 10.04.1 LTS Nedi using nginx Fix 502 Bad Gateway and 1 issue
« Last post by nedijedi on January 04, 2019, 10:27:41 PM »
This morning I upgraded to Ubuntu 18.04.1 LTS (GNU/Linux 4.15.0-43-generic x86_64).  The web site was broke and I got it working again by 

editing  /etc/php/7.2/fpm/pool.d/www.conf and adding listen.mode = 0666 and
editing /etc/nginx/sites-available/default to have fastcgi_pass unix:/var/run/php/php7.2-fpm.sock; instead of 7.1.

The Monitoring-Health page I had problems was working this morning so not sure what was causing the issue.

The above should help anyone who installed using the generic Ubuntu installation.
Definition Files / assistance with Palo Alto .def files
« Last post by PoodleCannon on December 28, 2018, 07:33:31 PM »
Thank you for NeDi, it's been a massive boost to my documentation ability in this environment. I've spoken to both of my bosses (I'm a consultant) and will likely try to have a conversation with you about both a static license for this engagement and what possibilities exist for a "consultant" type of license that I could carry around on my laptop.

I have, in my stable, several models of Palo Altos that I'm trying to get better .defs for. With no .def file, basic information like interfaces, etc are being successfully polled, but things like LLDP are not. I've been going thru the Def tutorial, but some things are still confusing me. For example, if I set "Serial#" to iso., then the test icon returns a proper looking result:

But, it returns "err" or remains blank in the status page.

Any thoughts on what I'm doing wrong?
GUI / Re: CLI Send
« Last post by rickli on December 20, 2018, 02:41:09 PM »
Hey, the filenames need to begin with cmd to be listed :) See context help for more information...
GUI / CLI Send
« Last post by cmesser on December 18, 2018, 11:57:45 AM »

I just installed NeDi 1.7C.
If I create an CLI file in "System File Edit", I expected that it appears at "Device Status" in the drop down box of the CLI line for executing on this device.
But it doesn't.  :(
Did I missed something here?


Discovery / Re: SNMP v3 with AES or DES but with same community name
« Last post by rickli on December 17, 2018, 12:10:58 PM »
Different PW with same username is supported for CLI credentials but not SNMPv3 yet. I could implement it with an official feature request, if that's something you'd be willing to sponsor?

Alternatively you could change the community-name for those with less occurences (could be automated with NeDi too).
Pages: 1 [2] 3 4 ... 10