Welcome, Guest. Please login or register.

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - rickli

Pages: [1] 2 3 ... 144
1
Discovery / Re: [Enterasys C3G124-48] Missing Interfaces in GUI
« on: May 07, 2018, 03:19:38 PM »
Yeh, it's a mess, but SNMP is like 250 years old ;)

FYI, increasing maxmsgsize can result in some switches not responding at all...

2
Discovery / Re: [Enterasys C3G124-48] Missing Interfaces in GUI
« on: April 27, 2018, 08:24:53 PM »
That's the culprit:

ERR :IF Desc The message size exceeded the buffer maxMsgSize of 1472

Look at Interfaces() function in inc/libsnmp.pm and change this line to include your switch:

   my @maxrep = ($main::dev{$na}{os} =~ /DPC|ESX|Nortel|Netgear|EOSB2/)?( -maxrepetitions  => 12 ):();   # TODO limit where errors occur

3
Discovery / Re: Discovery ignoring netfilter?
« on: April 27, 2018, 08:17:59 PM »
Sniff the discovery and doublecheck :) I've added netfilter upon request from the community in order to avoid exactly that...

4
Discovery / Re: Aerohive discover connected station from AP
« on: April 27, 2018, 08:15:37 PM »
I've added support for Aerohive in 1.7. You can wait until I release it to the public or buy NeDi+ (1.8) with support...

5
Installation / Re: upgrade from 1.6 to 1.8
« on: April 23, 2018, 07:10:11 PM »
BTW, I've just updated nebuntu.sh to detect the PHP version automatically. It should be a lot more robust now...

6
Review the crontab entry and the discovery log (or Monitoring-Events). Either the wrong IP is seen by CDP/LLDP or it's not found at all. You could use something like nedi.pl -P1 -Aall to discover all devices in the DB if ping was successful...

7
Discovery / Re: libcli.pm for Comware 7
« on: April 19, 2018, 08:54:42 PM »
Weird, back when I've tested with CW3 it worked (at least with the devices I had access to). Thanks for solving this!

8
Discovery / Re: Problem getting correct PoE Infos of Cisco Switches
« on: April 19, 2018, 08:53:09 PM »
Have a look at usepoe in nedi.conf. The discovery protocol can provide reliable information, but you can set it to ifmib for device types, where it doesn't...

9
Installation / Re: Use location string in seedlist as a Prefix?
« on: April 19, 2018, 08:51:22 PM »
No, it's either or at the moment. It might be interesting to add this option. On the other side, if you configure the full location on each device, it's always clear where it belongs...

10
Installation / Re: upgrade from 1.6 to 1.8
« on: April 19, 2018, 08:49:21 PM »
NeDi 1.6 already requires additional packages on OBSD. I recommend using nebuntu.sh to continue on a more up to date platform...

11
Discovery / Re: nodes not populating interfaces
« on: April 04, 2018, 03:42:46 PM »
So, those nodes should appear on the Radwin device, not the Cisco one:

1.For the Radwin to appear linked to the Cisco switch, the MAC address of the Radwin learned on the Cisco switch, needs to be assigned to an interface. Then you should see a MAC link appearing automatically.

2.If the Radwin provides its mac address table, the nodes will apear correctly as well.

So, can you check the following:
- (Its own) MACs assigned to Radwin interfaces (can be the same on all)
- Use Defgen to find a working MAC address table OID on the Radwin.

We can debug via Hangout or Webex if you want. Just drop me a PM or mail...

12
Discovery / Re: libcli.pm for Comware 7
« on: March 29, 2018, 10:10:35 AM »
When I was with HP, CW7 worked like CW5, so I didn't need to specify.

I've made a CLI tutorial on youtube to help find out what goes wrong. Essentially start the backup with -vdc and look at the resulting logfiles.

If you let me access a CW7 I'll look at it myself, just send me a mail...

13
Discovery / Re: nodes not populating interfaces
« on: March 29, 2018, 10:06:50 AM »
Ok, so is the neighbor discovered as device or not?

14
It's not in the .def and it's ifLastChange, which is read in realtime. Therefore the switch needs to be active and the uptime available or you get the the '-'.

The problem is, this value is reset upon reboot. That's why I've added the Ethernet port icon in the status line. It shows available ports based on persistent discovery information...

15
I know, some have looked into it. I'll certainly do it, if a customer pays (some of) my time...

Pages: [1] 2 3 ... 144