Welcome, Guest. Please login or register.

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Saguu

Pages: [1]
1
Installation / Re: DOM values
« on: November 20, 2019, 08:54:40 PM »
Bump ! :D

2
Installation / Re: DOM values
« on: November 04, 2019, 10:18:40 PM »
Any idea ?

3
Installation / Re: DOM values
« on: October 17, 2019, 03:49:50 PM »
Hello,

Quick question : I would like to add the different type of SFP I have in my network.
Here is the information in my nedi.conf :

# Digital Optical Monitoring using type of transceiver to set transceiver based alert thresholds.
# Values within 3dBm generate warnings. The signal levels are stored in the transceiver's module
# entry (RX=FW,TX=SW) and set its status accordingly.
#
#      type      TX-hi   TX-lo   RX-hi   RX-lo   description (replaces module description)
;dom-alert   default      3   -10   3   -12   default-settings
dom-alert   GLC-SX-MMD    -3   -9.5   0   -17
dom-alert    GLC-LH-SMD   -3   -9.5   -3   -19
dom-alert   SFP-10G-LR   -0.5   -8.2   -0.5   -14.4
;dom-alert    1000BaseSX   -3    -9.5    0    -17

I do not understand why I have a warning ?



Thank you

4
Installation / Re: SSO Configuration - NeDi Active Directory
« on: September 18, 2019, 10:55:27 AM »
Works fine, thanks !

5
Installation / Re: SSO Configuration - NeDi Active Directory
« on: September 08, 2019, 11:23:12 PM »
Hello,

Okay, I tried to configure Kerberos on the CentOS server on which NeDi runs. 
My queries to my Active Directory server runs on the command line, but I can not log in to the NeDi interface without specifying my credentials, even deselecting "Gui LDAP" to use "Gui SSO".

I obviously configure the apache vhost with SSO guidelines.

Could you help me on this ?

Thank you.

6
Installation / SSO Configuration - NeDi Active Directory
« on: September 01, 2019, 09:24:58 AM »
Hello,

I have been using NeDi for several months and this tool really makes my job easier every day.  Whether it's configuration or troubleshooting, it works perfectly.
However, I use the LDAP connection which works well but I would like to use SSO.
When I change LDAP by SSO in NeDi.conf, I can not connect anymore. 
Could you tell me how to configure the SSO?

Thank you !

7
Discovery / Re: Disabling unused interface
« on: August 26, 2019, 08:48:30 PM »
Hello,

I tried to do it via PHP but unfortunately I'm really not good in PHP.
Instead, I use python and netmiko.

Saguu

8
Discovery / Disabling unused interface
« on: May 30, 2019, 10:19:38 AM »
Hello,
NeDi is able to find interfaces not used for 30 days by switches. Is it also possible to massively disable all unused interfaces of all switches? Or can you run a TCL script from NeDi?

Thank you for your help

Saguu

9
GUI / Re: Crontab copy running-config startup-config
« on: March 22, 2019, 09:16:26 AM »
Works fine !

Thank you very much Rickli :)

10
GUI / Crontab copy running-config startup-config
« on: March 15, 2019, 10:31:37 AM »
Hello,

We have been using NeDi for many months with great satisfaction. Currently, all configurations of our network equipment are saved in NeDi. I would also like every night, the running-config is written in the startup-config. I did not find how to do it in the documentation. Could you help me on this?

Thank you

11
GUI / Re: Active Directory authentication
« on: March 15, 2019, 10:12:20 AM »
Sorry for the delay for my answer. It works perfectly with the latest version of NeDi!

12
GUI / Re: Active Directory authentication
« on: April 19, 2018, 05:49:53 PM »
Hello,

Sorry for the delay  :o

I have spaces in my OU names. I tried with the method you tell me, but it does not work anymore. I decided to indicate the parent OU that has no space.

However, it still does not work. Here is the contents of the file :

# Authentication for GUI users can be set to:
# local, sso, pam, radius, ldap or none
# Append -pass to use the session user (entering pw each time) for device access (e.g. in Devices-Write)
;guiauth      local
guiauth      ldap

# Override the Login and Logout URLs (e.g. for your SSO setup)
# The defaults will be used if commented
#      Login URL      Logout URL
;authurls   User-Profile.php   index.php

# Set Radiusserver(s) parameters, if selected above
#      host      port   secret      timeout   retries
;radserver   localhost   1812   testing123   2   1

# Set Ldapserver parameters, if selected above:
#      host         port   rootpw      basedn      rootdn   loginattr
;ldapsrv   ldaps://host.domain   636   PASSWORD   DC=XX,DC=YYY   USER   uid
;ldapsrv   ldap://domain.int   389   pass      ou=PROD,dc=domain,dc=int   cn=user,ou=account,ou=admin,ou=prod,dc=domain,dc=int   cn
ldapsrv   ldap://UKLLOADS01   389   Spleen/*66   OU=LLO,OU=UK,OU=Country,DC=eua,DC=tonivn,DC=net   NeDilookupUser      sAMAccountName


And here is a screenshot of the error:



Thank you for your help !

13
GUI / Re: Active Directory authentication
« on: April 10, 2018, 04:51:22 PM »
Up !

Did I make a mistake ?

Thanks

14
GUI / Re: Active Directory authentication
« on: March 29, 2018, 10:58:39 AM »
Hello,

Here is my nedi.conf file:

# Authentication for GUI
guiauth      local
guiauth      ldap

# Set Ldapserver parameters
#      host         port   rootpw      basedn      rootdn   loginattr
;ldapsrv   ldaps://host.domain   636   PASSWORD   DC=XX,DC=YYY   USER   uid
;ldapsrv   ldap://domain.int   389   pass      ou=PROD,dc=domain,dc=int   cn=user,ou=account,ou=admin,ou=prod,dc=domain,dc=int   cn
ldapsrv   ldap://NameOfServer   389   MyPass   OU=XXX,OU=XX,OU=Country,DC=my,DC=domain,DC=dom   admin_xx      sAMAccountName

# Map attributes
#      adm   net   dsk   mon   mgr   oth   mail   phone
;ldapmap   cisco   cisco   cisco   support   manager   users   mail   telephoneNumber


I observed that if I indicate the complete DN of my rootdn, it does not work, I am obliged to indicate only the samaccountname of the rootdn.

15
GUI / Active Directory authentication
« on: March 28, 2018, 06:15:43 PM »
Hello, I discover NeDi and it's really a great tool. Now, I have a topology of my network, a backup of my configurations and a complete inventory of my network equipment.

However, I would like to add LDAP authentication but it does not work, as for this post: https://forum.nedi.ch/index.php?topic=1499.msg5975#msg5975

I can create a user, but when I try to create a second one, I get this error message: Duplicate entry '' for key 'PRIMARY'.

I'm using NeDi on CentOS 7 and my domain controller is in Windows Server 2012R2


Thanks for your help !

Saguu

Pages: [1]