Welcome, Guest. Please login or register.

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - jbruyet

Pages: [1]
1
Installation / Sigh, I must have a typo in NeDi password
« on: October 20, 2017, 05:48:42 PM »
Hey all, I must have a typo in my password list for NeDi. I've tried a couple different login names and a few variations of what I thought was the password but no joy. Is there a way to reset the password from the command line on the server? I took at look at the NeDi Guide but didn't see anything there (well, except for using the GUI). Hopefully I won't have to do a Nuke & Repopulate.

Any help here would be greatly appreciated.

Thanks,

Joe B

2
Installation / It's installed but I get a 403 error from the web page
« on: October 09, 2017, 09:53:56 PM »
Hey all, I was finally able to complete my NeDi installation without errors; I was neglecting to "sudo" that initialization command.

Now that I'm trying to access the web page I'm getting a "403 Forbidden" error. I've chown'ed the entire /opt directory to www-data but no joy. I deleted the soft link and recreated it. Nope. I even went into the nginx default sites configuration and made /opt/nedi/html the default web site but I'm still getting the 403 error.

I've been using the NeDi instructions from this site: https://help.ubuntu.com/community/NediHowTo

Can anyone see where I may have gone wrong?

Thanks,

Joe B

3
Hey all, when I run the nedi.pl script my mysql login fails:

Code: [Select]
jobee@NeDi:/opt/nedi$ ./nedi.pl -i

Initialize NeDi DB!!!
------------------------------------------------------------------------
mysql admin user: root
mysql admin pass: Pass123
DBI connect('dbname=mysql;host=localhost','root',...) failed: Access denied for user 'root'@'localhost' at ./inc/libdb.pm line 37.
jobee@NeDi:/opt/nedi$

I can log in to mysql using the same credentials, create a new user, grant that user all privileges and flush privileges. But even using THAT user for the nedi.pl script fails although the error is a little different:

Code: [Select]
Initialize NeDi DB!!!
------------------------------------------------------------------------
mysql admin user: jobee
mysql admin pass:
DB Version      : 10.0.31-MariaDB-0ubuntu0.16.04.2
----------------------------------------------------------------------
Old DB 'nedi' dropped!
Creating 'nedi' for nedi@localhost:
DBD::mysql::db do failed: Access denied for user 'jobee'@'localhost' to database 'nedi' at ./inc/libdb.pm line 135, <STDIN> line 2.
DBD::mysql::db do failed: Access denied for user 'jobee'@'localhost' to database 'nedi' at ./inc/libdb.pm line 135, <STDIN> line 2.
jobee@NeDi:/opt/nedi$ ./nedi.pl -i

Any ideas, suggestions or recommendations on what is going on here? I've wiped and reinstalled three times now thinking maybe I missed a step somewhere but not that I can tell. I'm using the instructions on this page https://help.ubuntu.com/community/NediHowTo. Is there a step missing here that will fix my problem?

Thanks,

Joe B



4
Installation / Initialize NeDi database failed
« on: October 03, 2017, 08:29:23 PM »
I'm following the installation instructions and made it to the database initialization. I ran the nedi.pl -i command and here's the error:

Code: [Select]
Can't locate DBI.pm in @INC (you may need to install the DBI module) (@INC contains: /etc/perl /usr/local/lib/x86_64-linux-gnu/perl/5.22.1 /usr/local/share/perl/5.22.1 /usr/lib/x86_64-linux-gnu/perl5/5.22 /usr/share/perl5 /usr/lib/x86_64-linux-gnu/perl/5.22 /usr/share/perl/5.22 /usr/local/lib/site_perl /usr/lib/x86_64-linux-gnu/perl-base .) at ./inc/libdb.pm line 17.
BEGIN failed--compilation aborted at ./inc/libdb.pm line 17.
Compilation failed in require at ./nedi.pl line 69.

I posted an earlier problem regarding the available versions of PHP in Ubuntu -- the installation instructions say to use php5 but Ubuntu only has php and php7.0. I decided to go ahead with this install in the hope that by using the 7.0 PHP and the 7.0 PHP mysql they would work with each other. Is this error related to that issue or is this something else?

Thanks,

Joe B

5
Installation / Ubuntu installation script references wrong files?
« on: October 03, 2017, 04:40:31 PM »
Hey all, I just built a machine with Ubuntu 16.04.3 LTS. I'm trying to install the programs per the commands on the top of this page, https://www.nedi.ch/installation/, and not having any luck. When I try to install them I get the following:

Code: [Select]
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package libapache2-mod-php5 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package php5-mcrypt is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package php5-mysql is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package php5-gd is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libapache2-mod-php5' has no installation candidate
E: Package 'php5-mysql' has no installation candidate
E: Unable to locate package php5-snmp
E: Package 'php5-gd' has no installation candidate
E: Package 'php5-mcrypt' has no installation candidate

I tried again with the smaller list on this page, https://help.ubuntu.com/community/NediHowTo, but I get the same result.

I was going to do a "Nuke & Repopulate" but repopulate with an older version of Ubuntu but I thought I'd ask this forum if I'm overlooking some small detail. Does the NeDi software have a preferred distribution? If so what is it?

Thanks,

Joe B

Pages: [1]