Welcome, Guest. Please login or register.

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - pc_sg

Pages: [1] 2 3
1
Discovery / Identify where "rogue" switches are connected to
« on: December 06, 2017, 02:46:38 PM »
Hi!
Maybe this is an already answered question, but haven't find it.
I need to identify where "rogue" switches are connected in our LAN.
Rogue means unmanaged switches used to increase available port in areas where official LAN is not well or enough distributed (but not only, so "rogue")
If anyone ask why we in ICT don't know them, it depends on some anarchy of employees and relevant responsible, and past carelessness of old ICT chiefs...


I supposed Population is the answer, but i present only in few reports (i.e. Reports - Combination) but is not easy to use.
And seems that Population hold all MAC detected on a given port from the first discovery of each device, and is of course too much, I need a shorter period, even current situation.


Else I must do a switch by switch MAC address table export and consolidation, a really huge work.


Maybe NeDi is able to do the same in a simpler way, or maybe a artfully query in the NeDi database.


Could anyone help me?


Thanks in advance!

2
Definition Files / Wanted: Mellanox SX1012 def file
« on: November 13, 2017, 09:08:41 AM »
As in object.
Else, some advices to make one (from which template start, etc...)


Thanks a lot in advance!

3
Installation / Upgrade from 1.5 to 1.6
« on: October 18, 2017, 11:30:29 AM »
Tested yesterday an upgrade from 1.5 to 1.6 on a "test" machine (Debian 9), where 1.5 was running fine.
"System - Files" procedure don't work. Choosed local file (freshly downloaded nedi-1.6C.tgz), then Execute button, but nothing happens at all.
Tested with Chrome, even in Incognito mode to avoid addons interference, without success. The same with IE 11.
So I did a overwrite of NeDi folder with the ones in downloaded file, reinitialized database with "./nedi.pl -i user pwd" procedure.
Now seems OK, but If I choose "System - Files", browser try do download "System-Files.php".
Tried to do what is done by "nebuntu.sh", firstly only the "apt" line (with some errors) the the whole script. No success.
Maybe something is not fully compatible in Debian compared with Ubuntu.
I can uninstall and reinstall all in this Debian machine (any script or procedure to make it like a fresh instaled Debian?), but can't start from scratch.


Any advice?


Thanks in advance!


4
I've just update OS version on one of my NeDi server, running Debian, going to Debian 9.
In the meanwhile I did a brand new installation of latest "community" Nedi, i.e. 1.5.225.
But discovered that NeDi was no mora able to CLI access my switches because access is only by ssh, telnet was disabled for security reasons.
Doing a test using SSH from server console I saw this response: "no matching key exchange method found. Their offer: diffie-hellman-group1-sha1"
Looking around saw that this cyphering is more or less deprecated ad disabled by default in OpenSSH.
A common workaround suggested is to add "-oKexAlgorithms=+diffie-hellman-group1-sha1" to ssh command line.
There is no option in nedi.conf to add this, so I changed line 639 in file /var/nedi/inc/libcli.pm from
"my $known = "-o 'StrictHostKeyChecking no'";"
to
"my $known = "-o 'StrictHostKeyChecking no' -oKexAlgorithms=+diffie-hellman-group1-sha1";"


Now NeDi can access again my (Cisco) device by CLI.


Maybe not the best solution...


Any advice is welcome!

5
Discovery / CLI Bridge Fwd error: connection pattern match timed-out
« on: July 22, 2014, 09:15:27 AM »
Hi to all.


On my "prodution" NeDi servers, running version 1.0.9-010, sometimes we receive a mail alert on uno or more switches, with this error code


"CLI Bridge Fwd error: connection pattern match timed-out"


Inside NeDi code I haven't found any reference to this string.
And in nedi.conf, "timeout" is currently is set to 5 and 2 (5 seconds, 2 retries)


This happens only sometimes, and maybe during backups (that may charge switches CPU), but i'm not sure of this...
Edit: no, happens even in regular use time...
There is something I can do to chase this problem?


Any advice?


Thanks in advance!


Paolo

6
News / NeDi 1.1.155 first test
« on: June 12, 2014, 08:31:11 AM »
Hi Remo,
I'm testing latest 1.1.115 beta (or preview?)
Seems OK. To be more deeply checked , of course!


I've a couple of things to note:
  • in Device - Status filed "Alias" now is too short, and cuts content.
  • Inventory is a giant leap, but how can us obtain a table (or soething like) with all information about all devices, modules, serials, etc. ? I mean the typical (huge?) inventory, that can be passed to "boss" that needs an asset? May be not a single table, of course. I haven't found the right menu  :(
Thanks in advance!


Paolo

7
Discovery / Cisco RPS Discovery
« on: February 05, 2014, 03:33:54 PM »
Hi Remo,
today I had to find some infos about some Cisco RPS we have around connected to critical switches.
I know that some switches (3560 and 3750 afaik) communicate with RPS (at least 2300 models) and is possible to receive some infos, i.e. status, model or S/N.
The CLI command I know is "show env" declinations:
Code: [Select]
show env ?
  all          Show all environment status
  fan          Show fan status
  power        Show power supply status
  rps          Show RPS status
  stack        Show Stack-wide all environment status
  temperature  Show temperature status
  xps          Show XPS status



Do you think it's possible to identify and catalogue them in NeDi, for example as additional modules?


Not a real must, only a "nice to have" ... :)


Thanks in advance!

8
In 1.3.6.1.4.1.9.1.1021.def (WS-C3560V2-24PS) released with 1.0.9-010 Group and Mode parameters was empty.



Group   1.3.6.1.4.1.9.9.46.1.2.1.1.2.1
Mode   1.3.6.1.4.1.9.9.46.1.2.1.1.3.1


Checked by me...

9
Discovery / "Potential CDP loop on"
« on: September 12, 2013, 11:54:44 AM »
Hi Remo,
on my "production" NeDi host (running 1.0.8-116, as read from nedi.pl), occasionaly I receive alert with some "Potential CDP loop on[/size]" warning.
Of course before there is the switch name, and after there is the switch port.

But I haven't found anything around in internet about this kind of problem (except if a router is connected between two switches, but is not my case)

My "test" 1.0.9-240 (that monitors the same devices) doesn't send any similar alert.

Strange...

In the meanwhile, yesterday I've tested unreachable device alerts on 1.0.9-240, rebooting a unused device. No alert message from 240, but from 116.
Launched moni.pl in interactive mode, and I've seen that the failing test number is always 1, it doesn't increase.
Something wrong in my configuration?

TIA!

Paolo

10
Discovery / Fake "Module removed" and "New module" during discovery.
« on: July 15, 2013, 10:03:36 AM »
Hi Remo,
I still receive fake "module removed" and "new module" (even "got replaced with same model and SN").

Seems that this happens more in heavy switch load moments (p.es. this morning after a switch reboot consequent of a power failure, so a lot of traffic in the first minute of activity)

You've said that may depends of failing SNMP queries, of garbage returned.

Any workaround?
Or there will be a definitive solution in 1.0.9 ?

TIA!

Paolo

11
Discovery / Cisco/HP mixed environment
« on: July 01, 2013, 01:24:48 PM »
Hi to all (Remo included, of course :) )

I one of our sites we have a mixed switches environment, our typical is Cisco, but there are some HP (in one case, J9021A).

NeDi doesn't discover them, even if we've set SNMP domains equal to the other (Cisco) switches.

Indeed, on the uplink port (the one from Cisco to HP) the HP switch is not shown.
Checked by hand, "show cdp neighbors" on the last Cisco switch doesn't show the HP switch, instead "show lldp neighbors" shows it and also Cisco ones.

Any idea?

TIA!

Paolo

12
Hi Remo,

in a lot of NeDi windows is possible to "filter" display results by a combination of two columns contents (ANDing o ORing them)

I don't ask for a more complex filtering mask interface (even if highly appreciated), but I suppose that is possible, modifying "by hand" the URL, to compose a filtering with more than two key parameters.

So, there is a way to teach us on how to "compose" this URL?
Seems not easy, but not impossible.

Am I asking too much?

Thanks in advance!

Paolo

13
Discovery / "cosmetic" moni alert issue (if any) ?
« on: June 10, 2013, 09:05:02 AM »
Hi Remo,

nothing really important, but in current NeDi 1.0.8 installations, all with moni service active, when there is more than one alert in one message, the "pluralizer" make a strange thing in the message object field.

Below an example:

"2 2 Monitoring Alertss"

i.e. it doubles the alerts number text (is really 2), and adds "s" twice at the end.

I had a look at relevant code, and seems good, but I'm not skilled enough to be a reliable debugger.

I repeat, is only a cosmetic issue. :) ;) :)

P.S. I'm almost sure it doesn't depend on our SMTP servers, there are a lot (myriad) of other messages sent from other servers and services, without any similar issue.

Paolo

14
GUI / Little idea for a small update
« on: June 06, 2013, 03:37:44 PM »
Hi Remo,
for whom has integrated Cacti in NeDi, could you add a clickable cactus for the handled devices also in Device - List and not only in Device - Status?

I think sholuld be easy, but useful!

Thanks anyway!

Paolo (the bothersome)

15
Discovery / Strange error in a new NeDi 1.0.8 instance
« on: May 30, 2013, 10:58:47 AM »
In a currently running withot other problem NeDi installation, after adding a new seed for a remote switch (not reachable directly using CDP), an error occours.
Here what verbose discovery shows:

(1.2.3.4 is the switch IP address  - SWITCH is the switch hostname, DOMAIN is the SNMP domain)

Code: [Select]
Manual-Discovery (1.0.8-116) with 1 seed at Thu May 30 10:39:09 2013
-------------------------------------------------------------------------------
Device Status Todo/Done-Time
===============================================================================

Discover     ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Identify 1.2.3.4 -------------------------------------------------------
SNMP:Connect 1.2.3.4 DOMAIN v2 Tout:5s MaxMS:1472
IDNT:Name = SWITCH
SOBJ:Reading 1.3.6.1.4.1.9.1.564.def
EVNT:CL=nedd EL=3 TGT=SWITCH MSG=New Device with ID 1.2.3.4 and IP 1.2.3.4 found
DBD::mysql::db selectall_hashref failed: Handle is not in asynchronous mode [err was 2000 now 2000000000]
Field 'device' does not exist (not one of device="SWITCH" AND device regexp ".") at /var/nedi/inc/libdb-msq.pm line 1208.
DBD::mysql::db selectall_hashref failed: Handle is not in asynchronous mode [err was 2000 now 2000000000]
Field 'device' does not exist (not one of device="SWITCH" AND device regexp ".") at /var/nedi/inc/libdb-msq.pm line 1208.
Issuing rollback() due to DESTROY without explicit disconnect() of DBD::mysql::db handle nedi:localhost at /var/nedi/inc/libdb-msq.pm line 1208.

This happens with same error even after a normal discovery, successfully for the already discovered switches.

Any advice?

Thanks in advance!

Paolo

Pages: [1] 2 3