Welcome, Guest. Please login or register.

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - MacBest

Pages: [1]
1
Installation / Re: Installing NeDi on Mountain Lion
« on: September 06, 2012, 02:49:49 PM »
Hi Remo,

I didn't tried to link the nedi.conf to /etc but I'll try that soon.
I'll give you a feedback if this works.
The error message:
Warning: Unknown: 1 result set(s) not freed. Use mysql_free_result to free result sets which were requested using mysql_query() in Unknown on line 0
occurs in http://nedi/User-Profile.php
But if I use http://nedi/User-Profile.php?DEBUG=1 there is no additional debug output (maybe no debug defined in this php script).
Also the apache log does not show any more information than:
[Thu Sep 06 14:40:00 2012] [error] [client 172.16.203.127] PHP Warning:  Unknown: 1 result set(s) not freed. Use mysql_free_result to free result sets which were requested using mysql_query() in Unknown on line 0

If you tell me how to get more needful information please let me know

Greetings from Germany

Jürgen

2
Installation / Re: Installing NeDi on Mountain Lion
« on: September 05, 2012, 09:27:53 AM »
Hi there,

after about one week of testing I got nedi 1.07 running on Mountain Lion. :)
Most stuff can be installed with MacPorts. When I got everything fixed I try to post an installation instruction here.
Some nedi files must be changed because the perl path does not match. Another problem exists with the $nedipath variable not working as expected so I had to do a workaround with a static path to the nedi.conf in some files. Also the System-Services.php has to be modified for OS X.
One thing I don't know what to do with is the following error message:
Warning: Unknown: 1 result set(s) not freed. Use mysql_free_result to free result sets which were requested using mysql_query() in Unknown on line 0
which appears in the browser e.g. on User-Profile.php (maybe Remo can help out here)

Greetings from Germany

Jürgen

3
Installation / Installing NeDi on Mountain Lion
« on: August 27, 2012, 03:48:12 PM »
Hi there,

anybody out there who already installed NeDi on a MAC running Mountain Lion?
I'm running Nedi 1.0.6 on Mac OS 10.6.8. But now I wan't to move to a new MacPro.
I don't wan't to copy all the old stuff to the new machine but want a fresh install of NeDi 1.07.
So any help welcome

Greetings from Germany

Jürgen


4
Discovery / Re: How to disable "Backup Config" for special Devices
« on: September 14, 2011, 09:21:32 AM »
WOW!

the -A Option is great! I didn't even realized, that this exists with such great stuff like
selecting special Devices from the DB.

BTW In this context I also removed the "Backup Config Stuff" from my hourly crontab.
I don't know why I didn't done this earlier  :(

Thanks a lot

Jürgen

5
Discovery / How to disable "Backup Config" for special Devices
« on: September 13, 2011, 11:15:20 AM »
Hi there,

I'm testing nedi 1.0.6 at the moment and one of the new features is, that nedi is able to get some information from (VM-Ware) ESX hosts. That quite nice, but I don't want nedi to login an get the Config of these servers.
In the nedi events I can see:
Config backup error: no working user

every time I run my nedi.pl discovery.
So anybody out there who knows how to exclude these "devices" from the "backup config" stuff?
(or can even explain why nedi wan't to get the config if it already knows that there is no login avail)

Greetings from sunny Germany

Jürgen

6
Discovery / Re: Anyone got any Cisco ASA to work with nedi
« on: April 15, 2009, 02:17:27 PM »
Oh I see that there are others people interested in getting infos out of the asa into nedi :)

The problem with the asa displaying names instead of IPs with a "sh arp" would be no problem for me because I only name devices in the asa config and not simple clients. So I could get a lot of information out of the box anyway.

Wouldn't it be possible to allow an external script to check the asa arp tables (e.g. via expect) and get the values back into nedi. If this will work we can put it in the nedi contib folder so everybody can use it.

Thanks in advance for any help

Juergen

7
Installation / Re: NeDi 1.0.4: Bug in nedi.pl -i ?
« on: April 15, 2009, 02:08:41 PM »
Hi there,

same stuff here. I just solved it by using the following syntax (as Remo mentioned)

nedi -i <dbadminuser> <dbadminpassword>

The old way gave me the same errors as mentioned earlier

Jürgen

8
Discovery / Re: NeDi 1.0.4
« on: April 15, 2009, 02:05:25 PM »
Just a little Question...

I've just updated to 1.0.4 but now my discovery takes much longer than before.
It take up to 2 between seeing the IP address in the log if if set -v and the appearing of the dns name for this device. If I do a nslookup on the nedi machine I get the name instantly resolved.
Anyone knows what's going on between displaying the ip and displaying the name?
Any debug possibility?
Or is it only the first time?


Greetings

Jürgen
 
:'(

I found the reason but this seems to be a little BUG  :o
I have 4 different readonly communities in my nedi.conf  file.
And as told by Remo # Snmp read communities (most frequent ones first).
they are in the correct order. But I rechecked with the -d option and found, that nedi seems to order these communities another way (not even alphabetic). So I temporarily commented out the one making trouble and now discovery speed is back.

So Remo it seems to be your turn now ;-)

9
Discovery / Anyone got any Cisco ASA to work with nedi
« on: April 07, 2009, 09:34:18 AM »
Hi there,

I got a few ASAs and wanted the get the arp table out of this boxes.
It is not posible via snmp so the only way I see is via cli.
In 2007 there was a little discussion about it but no solution yet

The nedi cli stuff will not work on my ASAs.
I've defined them as
OS      IOS-fw
but I only get a red bulb in the cli line of Devices-Status.php
and port 23 is displayed even nedi  should connect via ssh not telnet.
(or do I have to configure something special to get ssh to work)

This is the way if I do it manually:

Code: [Select]
jbmpb:~ jb$ ssh <username>@asawzosued01
vpnbvrou@asawzosued01's password: <enablepassword>
Type help or '?' for a list of available commands.
asawzosued01> en
Password: <enablepassword>
asawzosued01# sh arp
        outside xxx.xxx.xxx.xxx 0012.ef20.aa03
        inside 192.168.74.203 0021.5acb.d042
        inside 192.168.74.200 0022.640c.0842
 


I also tried to put the following line into /opt/local/share/nedi/inc/libcli-netssh.pl
Code: [Select]
$cmd{'IOS-fw'}{'macd'} = 'sh arp';

But until ssh won't work this also will not work I think ;-)

So any help welcome

Greetings from Germany

J?rgen

Pages: [1]