Welcome, Guest. Please login or register.

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - nti

Pages: [1]
1
GUI / Re: Nfdump, Nodes Traffic not shown on GUI (solved)
« on: March 26, 2018, 01:56:07 PM »
Ha! - Sorry!!!  I have to wait > 30 minutes - and voila - there are the graphics....  :)

2
GUI / Nfdump, Nodes Traffic not shown on GUI (solved)
« on: March 26, 2018, 01:53:11 PM »
Hi

I've installed nfdump as recommended. flowi.pl greps the data and it seems everything is OK. But the RRD graphs on "Nodes-Traffic" are empty and queries produces nothing. How can I get it out?

Nicola

./flowi.pl -v
RCFG:./flowi.pl path is relative
RRD :nfdump -M /usr/local/var/nfdump/MkGwLan:MkGwWlan -r nfcapd.201803261340 using packets
PROT:  58        142 pkt       8280 B
PROT:   1        890 pkt      74956 B
PROT:  50       1422 pkt     285244 B
PROT:  17     116507 pkt   39274547 B
PROT:   6     588099 pkt  398207325 B
PORT:  80      23098 pkt    2249880 B
PORT:3389      21417 pkt    1174819 B
PORT:  25         27 pkt       5677 B
PORT:  23         74 pkt       3824 B
PORT: 443     208604 pkt   25085496 B
PORT: 445        614 pkt      83210 B
PORT:  22        113 pkt       5887 B
PORT: 123        460 pkt      35212 B
PORT:  53       4993 pkt     383860 B
TRRD:./rrd/flow.rrd update OK
ALRT:0 mails and 0 SMS sent

3
Installation / Re: no rrd graphics
« on: June 19, 2015, 11:08:38 PM »
And the RRD graphs are away again - thats very curios   :-[

4
GUI / Re: system / services: no information
« on: June 19, 2015, 11:05:42 PM »

"Sensors" are not good supportt on FreeBSD. If you have a Supermicro Board you can install "sysutils/bsdhwmon" from the ports.

Code: [Select]
--- System-Services.php.bak 2014-10-27 21:12:25.000000000 +0100
+++ System-Services.php 2015-06-19 23:00:27.000000000 +0200
@@ -48,7 +48,7 @@
  return 0;
 }

-if(preg_match("/OpenBSD|Linux/",PHP_OS) ){
+if(preg_match("/OpenBSD|FreeBSD|Linux/",PHP_OS) ){
  $pscmd = "ps -axo pid,command";
 }
 $procs  = shell_exec($pscmd); # Get PIDs first
@@ -152,6 +152,8 @@
 <?php
  if(
PHP_OS == "OpenBSD"){
 
system("/usr/bin/top -n -1");
+
}elseif(PHP_OS == "FreeBSD"){
+
system("/usr/bin/top -b");
 
}elseif(PHP_OS == "Linux"){
 
system("/usr/bin/top -bn1");
 
}elseif( strtoupper(substr(PHP_OS03)) === 'WIN' ){
@@ -
165,+167,@@

 <
div class="textpad code pre txta tqrt">
 <?
php
- if(preg_match("/OpenBSD|Linux/",PHP_OS) ){
+
if(preg_match("/OpenBSD|FreeBSD|Linux/",PHP_OS) ){
 
system("df -h");
 
}elseif( strtoupper(substr(PHP_OS03)) === 'WIN' ){
 
system("dir|find \"bytes free\"");
@@ -
180,+182,@@
 <?
php
  if(
PHP_OS == "OpenBSD"){
 
system("/usr/bin/systat -b netstat");
+
}elseif(PHP_OS == "FreeBSD"){
+
system("sockstat -P tcp -c");
 
}elseif(PHP_OS == "Linux"){
 
system("netstat -ln --inet");
 
}elseif( strtoupper(substr(PHP_OS03)) === 'WIN' ){
@@ -
195,+199,@@
 <?
php
  if(
PHP_OS == "OpenBSD"){
 
system("/usr/bin/systat -b sensors");
+
}elseif(PHP_OS == "FreeBSD"){
+
system("sysctl hw.acpi.thermal");
 
}elseif(PHP_OS == "Linux"){
 
system("/usr/bin/sensors");
 
}

5
GUI / system / services: no information
« on: May 24, 2015, 09:35:12 PM »
Hi

Beneath system / services nothing is shown, no "Processes", no "Disks", no "Sensors" etc. only fat grey lines. Also the "moni" service is not registered although it is running.

System is FreeBSD 9.3

Nicola

6
Installation / Re: no rrd graphics
« on: May 24, 2015, 09:26:20 PM »
Crazy, now it works again. I don't know why....  ???

7
Installation / Re: no rrd graphics
« on: May 24, 2015, 12:28:45 AM »
After a computer crash all rrds are gone. I tried the calling on the terminal again but now everything seems to be OK, a test png is created. Nevertheless there is "Keine RRD Datei". I've deleted the hole rrd directory, the rrd files are build again, but I can't get a graphic on nedi.

This command creates a png, but it last a few seconds:
Code: [Select]
rrdtool graph -a PNG test.png -w800 -h200 -s1429536600 -e1432416000 -L6 DEF:cpu=/usr/local/www/nedi/rrd/MkGwLan/system.rrd:cpu:AVERAGE AREA:cpu#cc8844 CDEF:cpu2=cpu,1.3,/ AREA:cpu2#dd9955 CDEF:cpu3=cpu,2,/ AREA:cpu3#eeaa66 LINE2:cpu#884400:"%"
No error messages are given:
Code: [Select]
php -f inc/drawrrd.php dv=MkGwLan s=5 t=mem a=1429537740 e=1432417140 debug=1
How can I find out whats going wrong?



8
Database / Re: Filter on 0.0.0.0 IP
« on: May 20, 2015, 09:34:21 PM »
I use the pgsql installation and nothing works :(
IP = 0.0.0.0, IP like 0%, IP = NULL

I tried NULL also ... - Maybe no query works because of the inet_ntoa funnction ?

Code: [Select]
select '0.0.0.0'::inet+$1;$BODY$
Grüße
Nicola

9
Database / Re: Filter on 0.0.0.0 IP
« on: May 19, 2015, 11:37:44 PM »
? Did I miss something ?
I'm on the nodes list. If I try to filter all 0.0.0.0 IPs it is not possible. Not with "~" or "=" or with "like". With "> 0" I become all regular IPs. But it is not possible to make a query on the 0.0.0.0






10
Discovery / Re: arpwatch data mostly missing
« on: May 19, 2015, 05:44:41 PM »
nedi.pl version 1.4.300 calling Getopt::Std::getopts (version 1.07 [paranoid]),
running under Perl version 5.18.4.

the date of msgt.txt is 26.Feb 15 17:34

We have linksys switches and can't get the nodes on another way. Also I use nbtscan to produce arpwatch like files to get more names of nodes that have no dns entry
Code: [Select]
0:11:4b:2:75:36 192.168.160.222 1431961253
60:36:dd:f9:b9:97 192.168.160.222 1431936342
0:15:58:7d:e0:f7 192.168.160.22 1432047979 nb-0141-tsch
6c:88:14:3c:9a:0 192.168.160.223 1432048644
88:9f:fa:fd:e3:7a 192.168.160.223 1431957718
54:72:4f:1e:34:db 192.168.160.224 1432039802
f8:b1:56:a0:b7:49 192.168.160.224 1432020838
8:fc:88:a9:7b:99 192.168.160.226 1432044383

11
Installation / Re: no rrd graphics
« on: May 19, 2015, 05:18:05 PM »
None. But I've tested rrdtool on the terminal like this

Code: [Select]
rrdtool graph -a PNG /tmp/test.png DEF:cpu=/usr/local/www/nedi/rrd/switch-tl2/system.rrd:cpu:AVERAGE CDEF:cpu1=cpu,1,/ LINE2:cpu#884400:"%"
481x155
ERROR: Could not save png to '/tmp/test.png'

 After some searching on google I reinstalled "cairo" (which is necessary for rrdtool). Now it works!

12
Database / Filter on 0.0.0.0 IP
« on: May 19, 2015, 01:23:14 PM »
How can i set a filter on 0.0.0.0 IP Numbers?

I use the pgsql installation and nothing works :(

IP = 0.0.0.0, IP like 0%, IP = NULL

Any solution?

Also I can't figure out how the IPs are stored in the db, numbers are like "3232276611" - how can I translate this to a normal IP?

13
Installation / no rrd graphics
« on: May 19, 2015, 12:08:14 PM »
Hi

It seems rrds are created, but can't not be shown. There are only litte greey icons on the gui.

If I call a rrd URL directly this error appears:
Code: [Select]
"Die Grafik "http://nedi.local/inc/drawrrd.php?dv=MK883&s=5&t=cpu&a=1429109760&e=1431989160" kann nicht angezeigt werden, weil sie Fehler enthält."
Debug output:

Code: [Select]
rrdtool graph - -a PNG --title="CPU Last 15.Apr 15 16:56" -w800 -h200 -s1429109760 -e1431989160  -L6
DEF:cpu=/usr/local/www/nedi/rrd/MK883/system.rrd:cpu:AVERAGE AREA:cpu#cc8844 CDEF:cpu2=cpu,1.3,/ AREA:cpu2#dd9955 CDEF:cpu3=cpu,2,/ AREA:cpu3#eeaa66 LINE2:cpu#884400:"%"

The rrd is built:
Code: [Select]
ls -la /usr/local/www/nedi/rrd/MK883/system.rrd
66 -rw-r--r--  1 www  www  65968 19 Mai 10:37 /usr/local/www/nedi/rrd/MK883/system.rrd

What can I do to resolve the problem? There are no errors in the php log.

System:
nedi 1.14p3
FreeBSD 9.3-STABLE
psql (PostgreSQL) 8.4.22
perl 5, version 18, subversion 4
PHP 5.4.40
RRDtool 1.4.8


nti



14
Other / Re: Netbios name or service.
« on: May 19, 2015, 11:43:09 AM »
With a litte awk scripting you can put the nbtscan results to the arpwatch directory and nedi will use it

e.g.:
Code: [Select]
nbtscan -s " " 192.168.0.0/24  | gawk '{ $2~"^[a-zA-Z][-_.0-9a-zA-Z]*$"; gsub(/-/, ":", $NF); print $(NF)" "$1" "systime()" " tolower($2) }' > /usr/local/arpwatch/arp.lan.dat
nedi.conf:

arpwatch   /usr/local/arpwatch/arp.*.dat

15
Discovery / Re: arpwatch data mostly missing
« on: May 18, 2015, 11:46:52 PM »
Quote
Use of uninitialized value in hash element at /var/nedi/inc/libmisc.pm line 1529.
Quote
Use of uninitialized value $i[0] in concatenation (.) or string at /var/nedi/inc/libmisc.pm line 745.
Use of uninitialized value in concatenation (.) or string at /var/nedi/inc/libmisc.pm line 745.
Use of uninitialized value in concatenation (.) or string at /var/nedi/inc/libmisc.pm line 745.
Use of uninitialized value $i[0] in concatenation (.) or string at /var/nedi/inc/libmisc.pm line 748.
Use of uninitialized value in concatenation (.) or string at /var/nedi/inc/libmisc.pm line 748.

Same problem here with 1.14p3. I call "nedi.pl -v -N arpwatch" first. Then "nedi.pl -v -po" and i have hundreds of "Use of uninitialized value".

Code: [Select]
Use of uninitialized value in hash element at /usr/local/www/nedi/inc/libmisc.pm line 1533.
Use of uninitialized value in hash element at /usr/local/www/nedi/inc/libmisc.pm line 1533.
Use of uninitialized value in hash element at /usr/local/www/nedi/inc/libmisc.pm line 1533.
ARPW:176 arpwatch entries used

Write ArpND -------------------------------------------------------------------
Use of uninitialized value $i[0] in concatenation (.) or string at /usr/local/www/nedi/inc/libmisc.pm line 745.
Use of uninitialized value in concatenation (.) or string at /usr/local/www/nedi/inc/libmisc.pm line 745.
Use of uninitialized value in concatenation (.) or string at /usr/local/www/nedi/inc/libmisc.pm line 745.
Use of uninitialized value $i[0] in concatenation (.) or string at /usr/local/www/nedi/inc/libmisc.pm line 748.
Use of uninitialized value in concatenation (.) or string at /usr/local/www/nedi/inc/libmisc.pm line 748.

Nicola

Pages: [1]