Welcome, Guest. Please login or register.

Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - rickli

Pages: [1] 2 3 ... 138
1
NeDiO / Re: Fresh NeDio write ArpND Problem
« on: March 24, 2017, 04:19:46 PM »
ARP and ND resolve IP addresses to DNS names. Is the DNS server configured correctly? How long does a nslookup <ip> on that machine take?

2
As a paying customer, you can contact me directly :-)

Some DB installations don't seem to just cut off strings longer than the DB field and just die.
I'll catch this error in the next patch, but you can simply comment line 4378 in libsnmp.pm to avoid it.

3
Discovery / Re: Config Backup of Cisco Nexus
« on: March 06, 2017, 10:20:16 AM »
I've implemented it with that SSH is only considered on port 22. Everything else reverts to telnet...

4
Discovery / Re: vmware host withot distributed switches
« on: March 06, 2017, 10:18:53 AM »
If you have Cisco switches, you could enable CDP on the ESXi as well...

5
Discovery / Re: Feature proposal: node data import
« on: February 28, 2017, 10:23:27 AM »
I will ask, but I think it's just reading ARP tables from other devices (using SSH or Web/REST) and presenting the data through SNMP...

6
Discovery / Re: Feature proposal: node data import
« on: February 13, 2017, 09:06:32 AM »
Sounds like growing need. Recently a customer created an "ARP-Proxy" which exposes the ARP table of a FW via SNMP...

Your idea could be realised already:
  • Create a file in arpwatch format
  • Set arpwatch in nedi.conf
  • Run nedi.pl -Narpwatch

7
Can you do this again and click on the debug icon on the top right? You should then see the "DB insert" query causing this error. Please post it here...

8
Definition Files / Re: HPE 5130/5700/5930/A5120 Cisco C837/C3925
« on: January 31, 2017, 09:23:59 AM »
I've kept the existing 5700-32XGT and added C3920 as alternative. Rest will be added to 1.7, tx

9
Discovery / Re: devices stop updating after 'Discover Replaced'
« on: January 31, 2017, 09:20:14 AM »
It depends on how you discover. Are you using -p to find neighbours via discovery protocol? If so, does the new device support that? I assume the old one did?

It would help to know the discovery options you use and the involved device models...

10
News / Re: Translations
« on: January 31, 2017, 09:16:06 AM »
Merci beaucoup :) I got a french translation already, but will compare the two...tx

11
Installation / Re: Backup HP stack (Nedi 1.5c)
« on: January 05, 2017, 12:31:48 PM »
Right, I missed that one. Just add "| to or <CR>:" to any of those...

But I wonder, do you get all configs or just the commander?

12
Installation / Re: Backup HP stack (Nedi 1.5c)
« on: January 04, 2017, 10:11:15 AM »
I see, a new case to be recognised. Is this a cluster? E.g. they don't provide distributed trunks, right?

You can give it a try by searching for the first "any key|Ctrl-Y" in inc/libcli.pm. Change to:

   }elsif($match =~ /any key|Ctrl-Y| to or <CR>:/i){

13
Installation / Re: Updating to 1.5 receiving DB error
« on: January 04, 2017, 10:05:44 AM »
It sounds like the upload of 1.6 fails in the first place!

The NeDi init only updates the DB scheme to the current version. If the upload fails, your still running 1.5, which can only perform an update from 1.4…

To update NeDi via browser the following prerequisites have to be met:

1)
On your server in php.ini or php-fpm.ini, make sure the NeDi archive can be uploaded:
post_max_size = 128M
upload_max_filesize = 128M

2)
Also if you’re running nginx:
  client_max_body_size 128m;

3)
All files need to be writeable by webserver:
cd /var/nedi
chown -R www-data.www-data /var/nedi

Now you can try again and you should get a green status line after uploading 1.6.

14
Installation / Re: Missing in backup after upgrade to 1.5c
« on: January 02, 2017, 12:53:05 PM »
It's a feature ;)

I wasn't aware it would remove useful information, though. in inc/libcli.pm look for this line:

$cmd{'IOS'}{'cfst'} = '^version';

It determines, where the actual config starts after entering "show run". You can just put "." to get everything...

15
Discovery / Re: Wrong Node Vlan Number in Node List
« on: January 02, 2017, 12:49:09 PM »
Do you have 1.3.6.1.4.1.2636.3.40.1.5.1.5.1.5 as VLnamx in the .def File? Try it, if not...

Pages: [1] 2 3 ... 138