NeDi Community

NeDi Software Specific => NeDiO => Topic started by: rickli on November 19, 2009, 06:28:15 PM

Title: NeDiO45
Post by: rickli on November 19, 2009, 06:28:15 PM
Will be ready with 1oh5 final well. Besides OpenBSD 4.6 it'll also feature a rewritten set of System Modules to edit config files, run nedi itself and properly control the daemons. This greatly improves the "appliance" experience! BTW Putty will be on there as well, from now on...
Title: Re: NeDiO45
Post by: rickli on December 07, 2009, 07:52:39 PM
I'm really close now, but need help to finish my last 2 issues. Maybe someone out there can help?

Code: [Select]

set skip on lo
set reassemble no

rdr proto udp from any to any port 514 -> port 1514
rdr proto udp from any to any port 162 -> port 1162

pass all allow-opts flags any no state
Title: Re: NeDiO45
Post by: rickli on December 08, 2009, 12:05:05 AM
Think I got Crontab editing working from the GUI! This means NeDiO won't require shell access anymore, once it's up and running...yieih  ;D

As to the nmap problem, I'll probably resort to portscan (fingerprinting is not 100% accurate anyway and needs way more time and resources). That said, I'll revoke the -f option in favor of -s (scan)...
Title: Re: NeDiO45
Post by: duanew on December 14, 2009, 06:28:23 AM
The ISO and VMWare image are now available at: ( ( (vm)
Title: Re: NeDiO45
Post by: lschafroth on January 06, 2010, 08:06:33 PM
Can we apply new patches and etc to the nedi iso?
I'm using nedio45 right now and it is running awesome. GREAT work!

I just want to know how to patch or upgrade it when they come available.

Title: Re: NeDiO45
Post by: jlsmith on January 13, 2010, 07:29:52 PM
I am running the new NeDio45 along side my old install.

I cannot get the new NeDi to discover all the sme devices that the old version does, nor will it work for any of the device lists.

If I go into list by IP address and do an IP range, old nedi shows everything on that network, new nedi will not show anything at all.

Looking at lastrun.log most of these devices show up with No name, not discoverable.

Not sure what I am missing in the conf file that this is not getting set correctly.

currently I have all devices in the seedlist, as it was not doing the discovery like the old NeDi did.

But I am still not getting them all populated. It will show Phones, but no other network equipment, printers, pc's and such.

Wanted to add options I am using.
On old ssystem I run -cob, new system I run obp.
Title: Re: NeDiO45
Post by: jlsmith on September 27, 2010, 07:58:47 PM
I have recently downloaded the latest OpenBSD Virtual Appliance.

this appliance is running good, with the exception of getting config backups.

I have the -b option coded on the options, but still not pulling them.

Also, if I go into device/write, all devices come up with error of "No login for (devicename)

I have looked at my nedi.conf and all looks god in it for user and password.

I have: usr  logonid password set, each seperated by a tab between them, but logon does not appear to be working. >:(
Title: Re: NeDiO45
Post by: rickli on September 27, 2010, 10:19:44 PM
Coincidently I've just finished cleaning up the new cli library. It not only supports ProCurve, Extreme and Comware devices now, but verbose mode much more userfriendly, allowing for easier debugging! Here's an example:

Config (CLI)   ----------------------------------------------------------------
TEL: admin:23 Tout:2s OS:IOS EN:(.+?)#\s?$
CLI: Matched Username: , sending username
CLI: Username sent
CLI: Matched Password:, sending password
CLI: Password sent
CLI: No enablepass or not a readonly prompt
CLI: Enable OK
CMD: terminal length 0:
CMD: show run
CFG: Current configuration : 1357 bytes
CFG: !