NeDi Community

NeDi Software Specific => Discovery => Topic started by: dirtyal on July 29, 2009, 06:57:59 PM

Title: Discovery problems
Post by: dirtyal on July 29, 2009, 06:57:59 PM
Iīve a network with 44 cisco routers, Iīve added the core router to the seedlist and after running nedi.pl and nedi.pl -po and nedi.pl -A, it has just discovery 21 routers.
   I am focusing on finding out why a router that is direct connected to the core doesīt get discovered. It answers SNMP requestes fine. If a do a nedi.pl -a <ip> is works.
   Any ideas on what I could do?

   Tks a lot.
Title: Re: Discovery problems
Post by: rufer on August 05, 2009, 08:55:33 AM
Check that CDP is enabled and that you have DEF files for your router/switch models.

Greetings
Rufer
Title: Re: Discovery problems
Post by: dirtyal on August 05, 2009, 05:06:12 PM
Yes, CDP is enabled and the defs exists. If I do a manual discoevery via nedi.pl, it will detect the router.
Title: Re: Discovery problems
Post by: rickli on August 06, 2009, 06:50:51 PM
Do a -vt (ip of the neighbor) and check whether the router in question shows up....
Title: Re: Discovery problems
Post by: dirtyal on August 06, 2009, 08:55:56 PM
Yes, it discovers it perfectly.
[root@ceee-opmon-pae nedi]# ./nedi.pl -t 10.63.164.1

NeDi 1.0.4 - 4.Apr 2009
OUI:    14892 NIC vendor entries read
Dev:    18 devices read from nedi.devices
Link:   0 links (WHERE type = "STAT") read from nedi.links


Discovery with 1 seed(s) on Thu Aug  6 15:33:56 2009
====================================================================================
Device                          Status                               Todo/Done-Time
------------------------------------------------------------------------------------
10.63.164.1     routerxxx        II i10 j1       p0/0 m3  a1                0/1-15s
------------------------------------------------------------------------------------
Took 0 minutes

Devs:   1 devices discovered
Node:   1918 nodes read from nedi.nodes
Node:   0 IP and 0 non-IP nodes processed
Title: Re: Discovery problems
Post by: dirtyal on August 19, 2009, 03:36:04 PM
Any help on this matter?
Title: Re: Discovery problems
Post by: sshapery on August 19, 2009, 04:11:41 PM
try adding a -I, nedi may be trying to use interfaces it can't get to in order to get to the devices.
Title: Re: Discovery problems
Post by: dirtyal on August 19, 2009, 08:06:30 PM
Tried, didīt find the router in question. Tks.
Title: Re: Discovery problems
Post by: rickli on August 20, 2009, 08:45:30 PM
Use -vt in order to get lines starting with CDP:
Title: Re: Discovery problems
Post by: dirtyal on August 20, 2009, 08:48:37 PM
After adding this router to the seedlist and one other router, Nedi discovered all the network. The only strange thing is why it didīt find it. This router is a 3620. Tks.
Title: Re: Discovery problems
Post by: hgerber on October 13, 2009, 09:07:01 AM
The seedlist is only there for you to manualy define devices , Nedi should automatically discover network devices without seedlist.
Title: Re: Discovery problems
Post by: dirtyal on October 13, 2009, 02:38:31 PM
Ok, but it didīt discover the network without the added itens on the seedlist.  Tks.