NeDi Community

NeDi Software Specific => Discovery => Topic started by: piet on January 31, 2019, 03:22:14 PM

Title: Monitoring Windows Node fails
Post by: piet on January 31, 2019, 03:22:14 PM
Hello Forum,
I run NeDi 1.7p3 on Ubuntu 18.04.1 LTS installed from scratch.

I try to monitor a Windows node with NeDi but pinging the node using "moni.pl" fails while a normal ping from OS works as expected.
Disabling the Windows firewall on the target node, did not help.

Any hint would be very much appreciated.

Code: [Select]
sudo -u www-data /var/nedi/moni.pl -vt nuc.hogwarts.local
PERL:Net::DNS::Resolver loaded
PERL:Net::NTP loaded
WEB :LWP-UserAgent loaded
RMON:11 entries (dev) read from nedi.monitoring
RMON:8 entries (node) read from nedi.monitoring
RUSR:1 entries (groups & 8 = 8 AND (phone != '' OR email != '')) read from nedi.users
PING:192.168.10.12 tcp echo fail!
Code: [Select]
ping nuc.hogwarts.local
PING nuc.hogwarts.local (192.168.10.12) 56(84) bytes of data.
64 bytes from nuc.hogwarts.local (192.168.10.12): icmp_seq=1 ttl=128 time=0.382 ms
64 bytes from nuc.hogwarts.local (192.168.10.12): icmp_seq=2 ttl=128 time=1.27 ms
64 bytes from nuc.hogwarts.local (192.168.10.12): icmp_seq=3 ttl=128 time=0.443 ms
64 bytes from nuc.hogwarts.local (192.168.10.12): icmp_seq=4 ttl=128 time=0.293 ms
64 bytes from nuc.hogwarts.local (192.168.10.12): icmp_seq=5 ttl=128 time=0.354 ms
64 bytes from nuc.hogwarts.local (192.168.10.12): icmp_seq=6 ttl=128 time=1.04 ms
^C
--- nuc.hogwarts.local ping statistics ---
6 packets transmitted, 6 received, 0% packet loss, time 5055ms
rtt min/avg/max/mdev = 0.293/0.632/1.278/0.383 ms


Title: Re: Monitoring Windows Node fails
Post by: rickli on February 04, 2019, 06:17:31 PM
NeDi can do ICMP ping, but also TCP ping, which may not work in this case. Check in Monitoring-Setup and change for all Windows hosts. Just be aware, it won't scale well with many (hundreds) hosts as non-SNMP tests are sequential. Testing uptime and the likes is non-blocking...