NeDi Community

NeDi Software Specific => Discovery => Topic started by: harry on January 30, 2013, 10:58:45 PM

Title: Nedi-027 RC issue.
Post by: harry on January 30, 2013, 10:58:45 PM
HI All,

I installed  this RC yesterday I have encountered these following issues.

1. Monitoring page Graphs are not showing anything only blank grid canvas.
2.Phones are not appearing in device list.
3. Backup - in Nedi.conf this field is commented so it should try telent and ssh. It is only trying ssh and not telent. so backup fials in case of the devices are only set for telnet.


some query..
1.what is flower or floodlight manager?

wishlist.
1. all aruba Accesspoint can appear as module to the controller. where they are connected, insted of having them listed as seperate device. A hyperlink can be provided for detailed drilling of data for AP.

I have installed new nedi and done Nedi -I to delete my old RRD's. I hope I have not missed any step of installation or config.

Re.
Harry

Title: Re: Nedi-027 RC issue.
Post by: rickli on January 31, 2013, 07:42:35 PM
1. did you try recreating this graphs? Any nedi -v output? (Look for TRRD: lines, check for hanging threads if you don't see any)
2. Are they matched in the nosnmpdev regexp in nedi.conf?
3. Does the device have a cliport of 22 now? If so, the connection on port 22 succeeded. Is ssh-server running, but not allowing logins?

Floodlight is an Openflow controller, which I'm testing right now. The GUI allows you to inject flows via NeDi. If you have Openflow enabled switches they'll be listed with configured flows as well. The beauty with NeDi's topology awareness is, that it can assist you in creating flows (note the fan icon next to MAC and IP addresses in Nodes-List, if Other-Flower is enabled in nedi.conf).

It's all rather experimental at the moment, but so is Openflow :)

You can change your .defs to show APs as modules:
# Modules
Modesc   1.3.6.1.4.1.14823.2.2.1.5.2.1.4.1.3
Moclas   
Movalu   
Moslot   1.3.6.1.4.1.14823.2.2.1.5.2.1.4.1.2
Modhw   1.3.6.1.4.1.14823.2.2.1.5.2.1.4.1.2.0
Modsw   1.3.6.1.4.1.14823.2.2.1.5.2.1.4.1.4
Modfw   1.3.6.1.4.1.14823.2.2.1.5.2.1.4.1.12
Modser   1.3.6.1.4.1.14823.2.2.1.5.2.1.4.1.6
Momodl   1.3.6.1.4.1.14823.2.2.1.5.2.1.4.1.13

So how is the rest of the new Aruba support coming out? Do you see the wireless clients on the APs? Not the link to list all APs in the controller's Device-Status and the link to the controller from an AP's Device-Status (in the group section)
Title: Re: Nedi-027 RC issue.
Post by: harry on February 04, 2013, 04:36:24 AM
Hello Remo,

1. Graphs are working now. -Thanks I reinitialised with nedi -I
2. No, I have checked the nonsnmp device and it is the same as it was and still it is not scanning the Cisco phones as device.
3. If I set ssh only it will bring only ssh device  config ,which are my Aruba controllers. If I set to NEVER it will scan only my Cisco switches on telnet , but if I keep it commented, it will not bring any of them.

For Aruba OID's when I add it gives me as list of modules -Thanks. is there any way that you can stop them appearing or adding in as device? An AP is only helpful as device if it can show the connected users and other details for that AP.

All and all NEDI is becoming a very useful product for us. We cannot think of managing large number of devices using one product.

I really appreciate Remo’s help every time and his readiness to accept and implement all the suggestions.

Re
Harry






Title: Re: Nedi-027 RC issue.
Post by: rickli on February 04, 2013, 06:46:44 PM
2.Have a look at LLDP: lines in a -v output, you should see what's going on there...
3. Hmm, don't understand that. Again the -v output should reveal what's going on...

APs were not added as devices before, correct? That's what I developed with the help of your controller on the internet :) But you actually should see the clients and their SNR as well. Is that not the case?

You're welcome! Now talk to your boss a about Other-Invoice ;)
Title: Re: Nedi-027 RC issue.
Post by: harry on February 05, 2013, 01:23:23 AM
I do have to comment the BORDER  line, it is working ok now.

still no luck on config backup.
Title: Re: Nedi-027 RC issue.
Post by: rickli on February 05, 2013, 06:20:16 PM
We're getting there! But do you have more info on what it does when backing up? Refer to the CLI tutorial if you need assistance...
Title: Re: Nedi-027 RC issue.
Post by: harry on February 06, 2013, 12:57:01 AM
Thanks Remo,
This tutorial helped me a lot to debug this problem.
My problem was I was having two same user name and different password. e.g. admin for Aruba and for other cisco device also admin as a user.

This was a problem, I commented on one of the Cisco device user ,my backup for Auruba starts working.

Once again Thanks for the help.

I saw all Aruba controller features in NEDI, it has came up so good, it is more than I was expecting, really liked it.

Regards
Harry

Title: Re: Nedi-027 RC issue.
Post by: pc_sg on February 06, 2013, 09:50:44 AM
Have you tried the soultion suggested in nedi.conf example?

Here a "cutted out" example that is functioning in my environment (where I use same user mat different password and enable password, if needed)

Code: [Select]
# The users for telnet and ssh access:
# - Put most frequent ones first.
# - Leave enablepass empty, if the user is priviledged already.
# - Use a dummy pass (and proper enablepass) if no login is required to connect.
# - Append ;1 ;2 etc. to user, if different pw are used.
# - Nortel CLI capable devices may require to configure cmd-interface cli to avoid menus!
# user pass enablepass
usr admin;1 pwd1 enab1
usr admin;2 pwd2 enab2
usr admin;3 pwd3
pwd1, pwd2 and pwd 3 are different password, enab1 and enab2 are different enable password, the last don't need enable password.

Hope this help you.

Paolo